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Assignment #1: Selecting Features & Spatial Analysis 
 
 

Preliminary Steps 
 
I 
 

§ Review Gorr/Kurland, “GIS Tutorial I: Introduction”; “GIS Tutorial 4: 
Geodatabases”; “GIS Tutorial 5: Importing Spatial and Attribute Data” (pages 
172-80); “GIS Tutorial 8: Spatial Data Processing” (pages 269-274); “GIS 
Tutorial 9: Spatial Analysis” (pages 303-7); and Ormsby et al., chap. 4 
(“Exploring ArcCatalog”).   

§ Peruse the following “How To” documents on the course web site: “How to 
Manage GIS Data Sets” and, where relevant, “ArcGIS Tips.”   

§ If you are working on your own computer, make sure that your GIS folders 
are located under c:\TEMP, as described in “How to Manage GIS Data Sets.”   

§ Use ArcCatalog, not Windows Explorer, to manage ArcGIS data files. 
§ The following exercises will use these data layers: Mdbg (which is the Miami-

Dade Block Group), Mobile Homes, Colleges, Highways, and arail.   
§ Their common geographic coordinate system could be: Layers>Properties> 

Predefined>Projected Coordinate Systems>World>North American 1983 
HARN (High Accuracy Reference Network).  It could be more accurate to use 
a locally tailored projected system, such as: Layers>Properties>Coordinate 
System>Predefined>Projected Coordinate Systems>State Plane>NAD 
1983>State Plane Florida _East_FIPS_0901).  Or alternatively you could use 
an unprojected coordinate system: Layers> 
Properties>Predefined>Geographic Coordinate Systems>World>WGS 1984. 

o 5280 feet=1 mile, 1 mile=1.609344 kilometers. 
§ Note that, in ArcMap, Data>Export Data saves a map layer as a shapefile to 

ArcCatalog. 
§ The course web site document ‘Selecting Features’ pertains to the following 

exercises. 
 

II 
 

§ Inspect mdbg, Lmobhome, Lcollege, and AHighway in ArcCatalog 
Preview, Table, and Metadata: 

o In Metadata, inspect the ‘Spatial Reference Information,’ particularly 
the geographic coordinate system).   

o Perhaps an easier way to inspect a coordinate system: right-click a 
file> Properties> Shape (click gray box)>Field Properties>Spatial 
Reference.  Make sure that the files you intend to map share the 
same, appropriate coordinate system.  

 
§ Define a coordinate system in ArcCatalog:  

o Right-click each file>Properties>Fields.  Click the gray area next to 
‘Shape’, then, in the ‘Field Properties’ box below, click the ellipses to 
the right of ‘Spatial Reference’.  Then ‘Select’ or ‘Import’ a coordinate 
system.  

o Do so for mdbg as well. 
o Then for Lmobhome, Lcollege, and LHighway, import the coordinate 

system from mdbg. 
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§ In ArcMap, avoid disrupted layer paths (see “ArcGIS Tips”) by 
‘storing relative path names’:  

o File> Map Properties>Data Source Options>click ‘store relative path 
names’ (see Gorr/Kurland, pages 37-38). 

 
§ In ArcMap, set the appropriate coordinate system on the data frame: 

o Recheck the coordinate system: right-click Layers>Coordinate System, 
and inspect ‘Current coordinate system’. 

 
§ In ArcMap, check the displayed type of map units:  

o Layers>Properties> General>Units>Map>Display.  These correspond 
to the particular coordinate system, as you examined above.  

 
§ Measure Tool:  

o Measure a distance between objects, confirming (on bottom-left 
portion of the display) that the measured number of units make sense. 

o Change the Display to miles. 
o Use the Measure tool to measure a distance, again confirming that the 

measured number of units makes sense. 
o If the measurements don’t make sense: 

§ Check in ArcCatalog to see if the shapefile doesn’t have an 
associated .prj file. 

• If you have another, e.g., Miami-Dade map that 
measures correctly, import or select its projection (i.e. 
its .prj file) in ArcCatalog: right-click the shapefile in 
ArcCatalog’s tree>Properties>Shape>Spatial 
Reference>import or select the projection. 

§ If you can’t find a projected coordinate system, try selecting or 
importing unprojected coordinates (e.g., WGS 1984) in 
ArcCatalog (as described above for projected coordinate 
system). 

 
§ In ArcMap, click ‘Add Data’:  

o Add mdbg, Lmobhome, Lcollege, and Ahighway. 
 

§ Adjust each symbol’s shape, color, and size:  
o Do so by clicking each symbol and selecting adjustments; or by right-

clicking each color in the Table of Contents & selecting an appropriate 
color) and select a background color 
(Layers>Properties>Frame>Background, then select a color). 

 
§ Rename each layer: 

o Do so by right-clicking a layer (Miami-Dade, Mobile Homes, Colleges, 
Highways), then Properties>General, and rename each layer. 

o Put the layers in this order: Highways, Colleges, Mobile Homes, Miami-
Dade. 

§ Make sure that the ‘Display’ tab is selected at the bottom of the 
Table of Contents. 

§ Right-click each layer and move it upward or downward: what 
might doing so accomplish? 

o Explore layer labels: right-click the Mobile Homes layer, then check 
‘Label Features.’  Uncheck and repeat for Colleges and Highways. 
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§ Group the layers: 
o ‘Grouping’ layers can simplify the organization and analysis of map 

layers (see Gorr/Kurland, pages 48-51). 
o Right-click ‘Layers’ at the top of the table of contents. 
o Click New Group Layer.  Then right-click New Group Layer and click 

Properties>General. 
o Name the new group layer ‘Miami-Dade County’. 
o Click ‘Group’ tab in the Group Layer Properties window>Add.  Navigate 

to ArcCatalog and add Lmobhome (which is one way to add layers to 
the group)>OK. 

§ In ArcMap, add the other layers to the group by clicking each 
one and moving it just under the group layer name. 

 
§ In ArcMap, check that the Measurement tool on the Status Bar is set 

to display in miles: Layers>Properties>General>Units: 
o Click the measurement tool & try measuring some distances.  To turn 

it off, click the ‘Select elements’ tool on the Status Bar. 
o If measuring distances does not work properly, see the previous 

instructions on how to correct things. 
 

§ Magnifier Window: 
o Click Window>Magnifier. 
o Drag magnifier across map. 
o Right-click magnifier window’s title bar>Properties>change Zoom 

percentage. 
o Drag magnifier across map, then close magnifier. 

 
§ Overview Window: 

o Click View>Zoom Data>Full Extent. 
o Zoom to a small area on the map. 
o Click Window>Overview. 
o Move cursor to center of the hatch pattern.  Then click the hatch 

pattern and move it to another map area. 
o Close Layers Overview window. 

 
§ Bookmark: 

o Click View>Zoom Data>Full Extent. 
o Zoom to an area of the Miami-Dade map. 
o Click View>Bookmarks>Create. 
o Type a name for the specified area in Bookmark Name field>OK. 
o Click View>Zoom Data>Full Extent. 
o Click View>Bookmarks>your newly created bookmark. 

 
Part A: Exploratory Selections 

 
§ Selection Tab: 

o Right-click Highways>Label features.  Then zoom to layer. 
o Click ‘Set Selectable Layers’: inspect but don’t change. 
o Right-click Highways.  Open attribute table.  Inspect. Close. 

 
§ Identify Tool: 

o Click ‘Identify’ tool.  Select layer Highways at the top of the ‘Identify’ 
dialog box.  Click a highway to identify.  Then in the ‘Identify’ dialog 
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box, right-click the highway and explore the options (e.g., flash, 
zoom).  Close dialog box.  Click ‘Select elements’ tool to turn off 
Identify tool. 

o Click ‘Select feature’ tool (holding down ‘Shift’) to select three 
Highways or Highway segments.  Open Highways attribute 
table>Show>Selected. 

§ Right-click Highways.  Selection>Zoom to selected features. 
§ Open attribute table>right-click ‘Length’>Sort Ascending>Sort 

Descending>Statistics. Close.  Selection>Clear selected 
features. 

§ Selection>Clear selected features. 
§ Close table. 

o Right-click Highways.  Open attribute table>click gray area on the left 
side (holding down ‘Ctrl’) to select three entries.  Show>Selected (at 
bottom of table).  Inspect map.  Close table. On toolbar at top of 
ArcMap: Selection>Clear selected features.  

 
§ Find Tool: 

o Click ‘Find’ tool (binoculars icon) on status bar: set ‘In’ (i.e. active 
layer) to Highways and ‘Search’ (i.e. active field).  Find one of the 
Highways or Highway segments: right-click entry in Find-tool dialogue 
box and specifiy  ‘identify’, ‘flash’, ‘zoom’, and ‘set bookmark’.  Click 
Full Extent to return to full view.  In table of contents, right-click 
Highways> Selection>Clear selected features. 

 
§ Select by Attribute: 

o Selection>Select by Attribute (Layer: Highways; Method: Create a 
New Selection): select the Golden Glades Intersection.  Open attribute 
table>Selected. Table of Contents>right-click layer>Selection>Zoom 
to selected features. Selection>Clear selected features.  Close. 

o Highways Open attribute table: click entry to select Golden Glades 
Intersection.  Selection>Clear selected features. Close. 

 
§ Select Feature Tool, Find Tool, & Bookmark - Review: 

o Use Select Feature tool to select three Highways or Highway 
segments; right-click Highways.  Open Attribute Table>Selected.  
Selection>Clear selected features.  Close. 

o Use Find tool to select the Golden Glades Intersection, then use 
dialogue box to identify, flash, zoom, and set bookmark.  
View>Bookmarks>Golden Glades bookmark.  Full Extent. Selection> 
Clear selected features. Close. 

 
§ Select by Attributes, Sort, Statistics: 

o Make sure that Map Display is set to miles: Right-click Layers> 
Properties>Display and set to miles. 

o Select by Attribute (Layer: Highways; Method: Create a New 
Selection): select “ST_NAME”>Get Unique Values>select Golden 
Glades Intersection. Open attribute table>Show>Selected.  Table of 
Contents>open attribute table>Zoom to feature.  Selection>Clear 
selected features. Close. 

o Select by Attribute: select “FID”>Get Unique Values>select Highways 
if FID<5 or FID>105 and FID<125.  Open attribute table 
>Show>Selected.  Right-click column headed ‘Length’>Sort 
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Ascending>Sort Descending>Statistics. Close.  Selection>Clear 
Selected Features. Close. 

 
o Select by Attribute: select “ST_NAME”>Get Unique Values>select 

Golden Glades Intersection and Gratigny; Open attribute 
table>Show>Selected.  Right-click column headed ‘Length’>Sort 
Ascending>Sort Descending>Statistics. Close.  Clear selected features. 

 
o Select by Attribute: select “LENGTH”>Get Unique Values>select 

Highways if length<400. Open attribute table>Show>Selected.  
Selection>Clear selected features.  Close. 

 
§ Label Features, Zoom to Layer: 

o Right-click Colleges>Open attribute table.  Inspect. Close.   
o Right-click Colleges>Label features.  Zoom to layer. 
o Selection>Set Selectable Layers>Colleges. 
o Select by Attribute: select FIU campuses.  Open attribute table> 

Show>Selected.  Selection>Clear selected features.  Close. 
 

§ Select by Location: 
o Select by Location: select features from Highways that intersect with 

arail.  Open attribute table>Show>Selected.  Right-click column 
headed ‘Length’>Sort Ascending>Sort Descending>Statistics. 
Selection>Clear selected features. Close. 

 
o Select by Attributes: College (‘Name’)>FIU. 
o Select by Location: select features from Highways that are within a 

distance of 2 miles from the FIU campuses.  Open attribute 
table>Show>Selected. Selection>Clear selected features.  Close. 

§ Set Selectable Layers: College.  Right-click College>zoom to 
layer. 

§ Use Select Feature tool to select FIU-North (Biscayne Bay 
Campus). Selection>Zoom to selected feature. Full Extent tool.  
Selection>Clear selected features. Close. 

§ Colleges: open attribute table.  Click entry to select FIU-North. 
Selection>Zoom to Selected Features. Full Extent tool. 
Selection>Clear selected features. Close. 

 
§ Use Find tool to select FIU-North, then use dialogue box to 

identify, flash, zoom, and set bookmark.  View>Bookmark> 
FIU-North bookmark. Selection>Clear selected features. Close. 

 
§ Interactive Selection, Export Data: 

o Right-click Colleges>Label features.  Zoom to layer. 
o Select by Attribute: College (‘Name’)>FIU. 
o Selection>Interactive Selection Method: remove from current selection 

campuses other than FIU-North (Biscayne Bay Campus). Selection tool 
(click FIU-South) (University Park Campus), or remove FIU-South in 
Select by Attribute dialog box. Selection>Clear selected features. 
Close. 

§ Note: if Interaction tool doesn’t work, check that Selections> 
Interaction Selection Method is set appropriately (e.g., if it’s set 
to ‘Select,’ then you can’t remove items.) 
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• If it still doesn’t work, use the corresponding options in 
Select by Location. 

• Selection>Clear selected features. 
 
o Select by Attribute: select FIU campuses. 
o Selection>Interactive selection method: select from current selections. 
o Selection tool (click FIU-North, which will remove FIU-South).  Right-

click Colleges>Data>Export data (‘FIU_North’>OK>Display as map 
layer).  

§ Note: exporting the data saves it as a shapefile in ArcCatalog 
for later use.  (See end of Assignment #1: ‘Note: Create Layer 
from Selected Features’.)  

o Rename map layer ‘FIU North’.  Selection>Clear selected features. 
 

§ Select by Location - Review: 
o Open attribute table for Mobile Homes.  Inspect.  Close. 
o Selection>Set Selectable Layers>Mobile Homes. 
o Select by Location: select features from Mobile Homes that are within 

a distance of  3 miles from FIU-North (click Use selected feature);  
Selection>Zoom to selected features.  Open attribute table for Mobile 
Homes>Show>Selected.  Selection>Clear selected features.  Close. 

 
§ Buffer Spatial Analysis, Create Layer from Selected Features: 

o Add ‘Buffer Wizard’: Tools>Customize>Toolbars>Commands: 
Categories - Tools>Commands: Buffer Wizard.  Then click Buffer 
Wizard icon and drag to tool bar. 

§ Alternatively: ArcToolBox>AnalysisTools>Proximity>Buffer (see 
Gorr/Kurland, pages 304-6). 

o Use Buffer Wizard to create a buffer for FIU-North, 3 miles radius 
(Features: FIU North>Next>At a specified distance: 3 miles.  Buffer 
distance units are: miles>Next>Save output in a new layer: 
C:\…\buffer_FIUNorth_3miles.shp). 

§ Table of Contents: right-click FIU-North buffer layer, then click 
Properties>General>Layer Name, and rename FIU North 3-
miles buffer.   

• In Table of Contents change buffer to another color.  
Right-click buffer> Layer>Properties>General> 
Display>Transparent.  Set to 30% transparent (or some 
other appropriate percentage).  Right-click buffer 
layer>Zoom to layer.   

• Alternatively, change buffer to hollow color, then select 
an appropriate outline color and width. 

§ Create a bookmark for the zoomed layer: View>Bookmark>FIU 
North 3miles buffer.  Full Extent.   

§ Use Identify tool to identify each mobile home park. 
§ Select by Location: select mobile home parks that ‘are 

contained by’ FIU North 3 miles buffer. 
§ Open attribute table for Mobile Homes>Show>Selected.  

Inspect.  Close.   
§ In table of contents for Mobile Homes, Selection>Create layer 

from selected features. 
• What’s the advantage/disadvantage of ‘Create layer 

from selected features’ vs. ‘Export data’? 
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• Right-click new layer. Layers>Properties>General>Layer 
name, and rename it ‘Mobile Homes near FIU North’. 

• On the map, use the measurement tool to measure the 
distance from FIU-North to each mobile home park. 

o Save the map only if you wish (using ‘save as’ to do so).  Recall that 
mhomes_fiu_north has been exported to and saved in ArcCatalog. 

o Note: it’s best to save a map via ‘save as’ in order to conserve its path 
names.  Make sure that you’ve used File>Map Properties>Save 
relative path names. 

o In sum, to buffer a feature selected from a larger set of features: (1) 
select the feature and either Data>Export>Save or ‘Create Layer from 
Selected Features’; and (2) buffer the newly created selected feature. 

 
§ Export Selected Features or All Features in View Extent: 

o Data>Export Data>Selected features or All Features in View Extent 
o Right-click arail>Label features.  Zoom to layer. 
o Then do either one of the following: 

§ Table of Contents, right-click arail>Selection>Create Layer 
from selected features, and, to save in ArcCatalog, 
Data>Export data>Export: Selected features (and don’t choose 
to display on map because it’s already displayed).   

• Or, to directly save the layer as a shapefile in 
ArcCatalog: Data>Export Data>Export: All features in 
view extent>OK>Display as map layer). 

o Selection>Clear selected features. 
 

§ Buffer via Select by Location: 
o Select by Location>Colleges>that are within a distance of>1 mile 

>Highways. 
o Colleges’s attribute table>Show>Selected.  Inspect. 
o Selection>Clear selected features. 

 
§ Definition Query/Query Builder: 

o Selecting a feature in Definition Query/Query Builder removes the 
layer’s other features from the map. 

o Open Colleges’s attribute table>Inspect. 
o Right-click Colleges>Properties>Definition Query>Query Builder: 

“Name” = “Miami-Dade Community College”>OK. 
o Inspect attribute table and the map: only MDCC’s campuses are 

displayed on the map. 
o How to redisplay all of the campuses: clear the selection from Query 

Builder (i.e. so that it is blank)>OK. 
o Inspect the map.  All of the campuses should be redisplayed. 
 

 
Part B: Create a New Map that Eliminates Biscayne Bay & Minimally     

Populated Everglades & Coastal Areas 
 
§ Eliminate Features from Map: 

o Use either the Identify tool or Select Features tool to identify the FIDs 
for minimally populated areas (of Miami-Dade, i.e. mdbg). 
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o You could use Definition Query/Query Builder to exclude the FIDs of 
such areas.  Here’s a way that instead uses Select by Attributes and 
the “Switch Selection” option. 

o Selection>Select by Attributes>Layer: Miami-Dade>Select if FID <> 1 
(to exclude Biscayne Bay). 

o Here’s the easiest way to eliminate low-populaton areas: 
Selection>Select by attributes>Select if POP2000<(insert some ‘low 
population’ number).  

§ Selection>Switch selection.   
o Data>Export data (name as ‘mdmap1’)>OK>Display as map layer. 
 
o Note: In the next assignment we’ll consider what to do with areas that 

have relatively low populations. 
o Recall that Definition Query/Query Builder would be a useful 

alternative way to eliminate the low and/or no-population areas. 
 
o Below we will create sub-maps, but spillage of geographic features 

beyond the boundaries of the reduced map will remain a problem.  In 
another assignment we will eliminate this problem via the ‘Clip’ 
procedure (ArcToolBox>Analysis Tools>Extract>Clip; see 
Gorr/Kurland, pages 275-78). 

 
 

Part C: Create a Sub-Map – Selection Tool Method 
 

§ Selection Tool Method (see Ormsby et al., chap. 8): 
o Turn off all layers except mdmap1 (which you created above). 
o Inspect attribute table for mdmap1. 
o Selection>Set selectable layers>uncheck all layers except mdmap1. 
o Selection>Options, and reset options if desired. 
o Selection>Interactive selection method>Create new selection.   

 
o Perhaps use the Zoom-in tool (the ‘+ magnifying glass’ icon) to 

enlarge the area of interest, then click Select Features tool>Select 
Features tool to select the area of interest.  

§ Inspect the attribute table.   
• To delete selection: Selection>Clear selected features. 

§ To save as map layer only: Right-click layer Selection>Create 
layer from selected features.   Rename the layer. 

§ To save as a shapefile in ArcCatalog: right click>Data>Export 
data>OK>Display as map layer. 

§ Rename the new layer. 
§ Before proceeding to next task:  

• Selection>Clear selected features. 
• Turn off Select Features tool (by clicking Select Element 

tool, right next to it). 
 

§ Other Graphic Possibilities   
o See ‘Help: Selecting features using a graphic’ (such as New Rectangle 

or New Circle). 
o Sketch Tool Method  (see ‘Help: Sketch Tool’).   
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                         Part D: On Your Own - Create a Sub-Map via Query 
 

§ Select by Attributes or Location: 
o Use Select by Attributes or Select by Location to create a sub-map.  

Inspect its attribute table, export and display the new map layer, and 
rename the new layer. 

 
 

Part E:  On Your Own - Create a Sub-Map via Buffer 
§ Buffer: 

o Use Buffer Wizard (or ArcToolBox>AnalysisTools>Proximity>Buffer) to 
create a sub-map.  Inspect its attribute table, export and display the 
new map layer, rename it. 

 
 
 
 
 
 

  Note: Selection>Create Layer from Selected Features 
 
§ Doing so creates a map layer but does not save the selected features as a 

shapefile in ArcCatalog  (including use independent of the current map): what are 
the advantages/disadvantages of each (see Gorr/Kurland)? 

§ To save the created layer of selected features in ArcCatalog as a shapefile, do 
either of the following:  

o Create layer from selected features>Data>Export data>OK>Display as 
map layer (if desired). 

o Or skip the ‘Create layer from selected features’ command by immediately 
right-clicking the selected features and doing Data>Export Data> 
OK>display as a map layer (if desired). 


