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Assignment 16.  GWR 3D Mapping 
 
 
Sources: ESRI online course on 3D Analyst; Kennedy, Data in Three Dimensions: A 
Guide to ArcGIS 3D Analyst (Thomson/Delmar Learning, 2004). 
 
 

I: Background for 3D & ArcScene 
 

§ Surfaces & features: a map layer may contain surfaces or features. 
o Surfaces: model a phenomenon that varies continuously across an 

area (e.g., elevation, slope, aspect, rainfall).  Surfaces are modeled 
with raster data (i.e. consisting of grids of identically sized cells, or 
pixels, each of which represents a unit of surface areas & stores a 
measured or estimated value for a particular unit). 

§ A surface can be estimated from sampled data via interpolation 
(see Spatial Analyst and Geostatistical Analyst: e.g., IDW, 
spline, nearest neighbor, kriging; see ArcGIS help).  

o Features: entities with discrete boundaries (e.g., houses, districts); 
features are represented vector data (i.e. by a polygon, line, or point). 

§ Features are represented by 2D or 3D feature classes (i.e. sets 
of like features) such as shapefiles and geodatabases. 

§ 3D feature: a point, line, or polygon with not only x,y 
coordinates also z-values as parts of its geometry. 

• A z-value stores a measurement such as a base height. 
• A point stores has one z-value, while lines & polygons 

have a single z-value for each vertex in the shape. 
• How to identify shapefiles & geodatabase feature classes 

that store 3D features: the ‘shape’ field in the attribute 
table contains z-values that end with ‘ZM’ (e.g., 
PointZM). 

• A TIN (i.e. Triangulated Irregular Network) represents 
space via a set of non-overlapping triangles that border 
each other & vary in size & proportion. 

o A TIN is created from a set of input points with x, 
y, & z values; the points become triangle vertices 
(nodes) that are connected by lines that form 
boundaries (edges)—a final product that is a 
continuous surface of triangles made of nodes & 
edges. 

o Slope & aspect can be calculated for each triangle 
face. 

• 3D features are manipulated in ArcMap via ArcScene, 
which you need to load (View menu>3D view tools). 

 
 

II: 3D in ArcCatalog  
 

Note: see Part VI, “Trouble shooting” 
 

§ How to preview 3D features in ArcCatalog: 
o Note the symbols that represent a TIN & a raster. 
o Right-click practice.shp>Preview>Geography. 
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§ practice.shp displays in 2D. 
§ How to find out if it can display in 3D? 

o Preview>Table.   
§ practice.shp’s shape field says ‘ZM’, which means that it stores 

‘measured values’ such as 3D. 
§ If it couldn’t store measured values, the shape field would say 

‘Polyline’ only. 
o In the tree, click practice_tin.  Click Preview to display practice_tin in 

2D.    
o Next, click 3D View to see practice_tin in 3D.  What enables it to 

display in 3D? 
o Open ArcScene.  Then drag both practice_tin and practice.shp into 

ArcScene’s table of contents. 
§ If an image displays too large, click Full Extent. 
§ If necessary, choose a new color for practice.shp or practice_tin 

so that both of them display. 
§ How do they look?  What enables them to display this way? 

§ In ArcCatalog, preview a layer file created from a raster: 
o Click practice_layer.lyr. 

§ If this layer doesn’t display properly, delete it.   
§ Then right-click practice (raster), click ‘Create layer,’ & name it 

‘practice_layer’. 
§ Make sure that ArcCatalog’s Preview dropdown is set to 3D 

View.   
§ Right-click practice layer>Properties>Base Height>click ‘Obtain 

heights for layer from surface’ and specify ‘practice’ (raster)> 
Rendering (make sure that both ‘Effects’ boxes are checked)> 
Symbology (select ‘Elevation #1’)>OK. 

§ If the 3D display is off kilter, click the ‘Full Extent’ icon on the 
toolbar. 

o Set the Preview option to 3D View. 
o Note: the raster’s 3D dimensions were created by setting its base 

heights (i.e. elevation values, from a base heights source), shading, & 
symbology.   

§ If you yourself created practice_layer, this is what you did. 
o Note: if a 3D layer does not display properly in Preview, click both the 

layer & the base height source, which will put the z-values in the 
correct metric (i.e. in synch with the x,y coordinates) so that the map 
can display. 

 
§ (If you didn’t already create practice_layer above) Create, symbolize, & 

preview a raster layer file in ArcCatalog: 
o Right-click practice raster & choose Layer (practice_layer2.lyr) and 

save it.   
o Preview>Geography>3D.  Why won’t it display in 3D?  
o Set practice_layer2.lyr’s base heights, symbology, and shading: 

§ Make sure that ArcCatalog’s Preview dropdown is set to 3D 
View.   

§ Preview practice_layer2.lyr in 3D.  How does it display? 
§ In the tree, right-click practice_layer, click Base Heights tab>   

click ‘Obtain heights for layer from surface’ (which will define 
the base heights based on ‘practice.shp’). 

§ Rendering> Make sure that both ‘Effects’ boxes are checked. 
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§ Symbology tab>Color Ramp dropdown: click Graphic View, 
scroll to and select Elevation #1>OK.   

§ Preview in 3D.   
o Note: base heights values can come  from information stored within the 

layer (e.g., cell values in a raster, z-values in a 3D feature layer, 
elevation attribute values for a 2D feature layer); from information 
stored in a different TIN or raster layer; or from a value or expression 
that you enter. 

 
 
 

III: 3D in ArcScene  
 

§ Open ArcScene: 
o File>Document Properties>Store thumbnail image with map>Store 

relative path names. 
o Scene Layers (i.e. the data frame)>Scene Properties>Coordinate 

System: define a coordinate system.  
o Scene Layers>Scene Properties>General>select a background color. 
o Add Data (or drag from ArcCatalog): practice_layer and practice (tin). 
o Right-click Scene Layers>Scene Properties>General>click ‘Calculate 

from Extent’ [Vertical Exaggeration].  Inspect the result.  Then 
experiment by setting other levels in ‘Vertical Exaggeration’.   

§ Vertical exaggeration gives a more pronounced appearance by 
emphasizing small changes in elevation.  It applies equally to 
all layers within a 3D scene, & is a property of the scene but 
not of the layer. 

o Scene Layers>Scene Properties>Illumination: experiment with the 
various settings. 

o Here are some useful procedures to experiment with (although they 
don’t make much sense or always work in this particular example; 
we’ll explore them more fruitfully later in the assignment): 

§ Z-Unit Conversion: 
• Right-click practice_layer>Properties>Base Heights>Z-

Unit Conversion>reset to 3.0.  Observe & then reset to –
3.0.  Observe & then reset to 1.0. 

§ Offset (for future reference: it will not work in this instance): 
• Right-click practice_layer>Properties>Base Heights>Z-

Offset>reset to a desired value. 
§ Extrusion (also for future reference; it typically gives features 

3D extension–upward or downward—to extrude values such as 
price of land parcels, population density, crime or illness rate, 
or % population with some characteristic). 

• Right-click practice_layer>Extrusion>Calculator button 
to open Expression Builder dialog>Fields box>click 
source of height for the extrusion (preceded by ‘-‘ if you 
want downward extrusion). 

 
§ See, e.g., ESRI online ‘3D Analyst’ course for these and other procedures in 

depth. 
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IV: Mapping GWR in 3D: % Foreign Born>% Bach Degrees 
 

§ Recall the last assignment’s cautionary remarks concerning: 
o The displayed intervals of GWR coefficients and map 

symbolization colors. 
o And the fact that interpolated  maps—the basis of the following 

3D maps—are meaningful only if the estimated data points are 
widely dispersed on the map and if  most of the estimated data 
points are statistically significant. 

§ A high portion of PctForeignBorn’s coefficient points are 
statistically significant. 

 
§ In ArcScene, store thumbnail image with map; store relative path names; 

define the coordinate system; and add data: 
o Recall that in ArcMap>Spatial Analyst, from the regression output for 

GWR, you exported>saved kfborn (which is the kriged GWR coefficient 
for PctForeignBorn’s relationship to PctBach).  kfborn will supply the z-
values for the 3D map’s base heights.  

o File>Document Properties>Store thumbnail image with map>Store 
relative path names.  

o Scene Layers>Scene Properties>Coordinate System, & set coordinate 
system.  

o ‘Add Data’: pctbach point, Georgia2004, and kfborn.  Arrange the 
layers in this order in the table of contents. 

§ If you join pctbach point and Georgia2004, you’ll be able to 
map the GWR results in both 3D and color gradation.  You can 
join these layers now or later. 

 
§ In ArcScene, we will set the base heights for each layer as follows. 

o Uncheck pctbach point and Georgia2004. 
o Right-click kfborn>Zoom to layer. 
o kfborn: Layer Properties>Base heights>set to kfborn.  
o If kfborn becomes hugely ‘inflated,’ click ‘Full Extent’ and/or right-click 

kfborn in the table of contents>Zoom to layer. 
§ If you want to symbolize kfborn at this time (which, however, is 

not necessary to make the overall 3D map): Properties> 
Rendering>make sure that both ‘Effects’ boxes are 
checked>Symbology (experiment with ‘Show’: try both 
‘Stretched’ and ‘Classified’ and their graphic -color options). 

 
o Uncheck kfborn. 

 
o Set pctbach point’s 3D base heights to kfborn.  Confirm that, under 

‘Rendering,’ both of the ‘Effects’ boxes are checked. 
 

o Symbolize the values of PARM_4: 
§ Perhaps change the color of PBachMap’s symbols. 

• Try with and without ‘outline color’ (Symbol 
Selector>Properties>Symbol Properties Editor>Outline 
Color). 

§ Symbolize PARM_4: Natural Breaks; five or seven categories; 
two decimal points; no zero padding; display feature values; 
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and perhaps change the color and shape.  Try flipping the color 
spectrum.  

 
o Set Georgia2004’s 3D base heights to kfborn.  Confirm that, under 

‘Rendering,’ both of the ‘Effects’ boxes are checked. 
§ Experiment with the color of Georgia2004: 

Symbology>Features>Single Feature>Select fill color (with 
outline [width=1.0] to display county boundaries). 

 
o Scene Layers>Background color.  Experiment with color and 

illumination. 
 

o Use the Navigation tool and the Pan tool to find the 3D map’s most 
effective display angle and placement. 

 
o Rename the layers:  

§ PBachMap to ‘Georgia counties’. 
§ Georgia2004 to ‘GWR coef.: % Foreign Born>% Bach degrees’ 

 
§ Does your 3D map effectively convey the GWR relationship or not?  How does 

its effectiveness compare to that of the 2D GWR maps that you made in the 
previous exercise? 

 
§ Save the 3D map file via ‘save as’ in Assignment 10 folder (‘3Dfborn’, which 

will have an .sxd extension).   
o Recall that to display a map, all of its component  layers must be 

stored together.  
§ You can also export the scene in 2D or 3D: File>Export Scene> (choose 2D or 

3D). 
 

§ Note: while raster surfaces (e.g., rfborn) are commonly used as 
sources of base heights, in the case of the GWR maps that we’re 
making the raster surfaces create very ragged 3D maps.  (Try and 
see!)  Thus it might make sense in other instances as well to create 
both raster and interpolated surfaces to see what works best in 
making 3D maps. 

 
 
 

V: Mapping GWR in 3D: % Black>PctBach 
 
§ Recall the previous cautionary remarks concerning: 

o The displayed intervals of GWR coefficients and map 
symbolization colors. 

o And the fact that kriged maps are meaningful only if the 
estimated data points are widely dispersed on the map and if 
most of the estimated data points are statistically significant. 

§ A low portion of PctBlack’s coefficient points are statistically 
significant. 

 
§ Restart ArcScene.  

o File>Document Properties>Store thumbnail image with map>Store 
relative path names.  
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o Scene Layers>Scene Properties>Coordinate System, & set coordinate 
system.  

o Add Data: pctbach point, Georgia2004, and kpblack (the other kriged 
surface created in Assignment 9 that will serve as this map’s base 
heights source).  Arrange the layers in this order in the table of 
contents. 

 
§ Set the base heights: 

o Right-click kpblack>Zoom to layer. 
o Set the base heights of kpblack to kpblack: Layer Properties>Base 

heights>set to kpblack.  
§ If you want to symbolize (though it’s not necessary for the 

overall 3D map): Properties>Rendering>make sure that both 
Effects boxes are checked>Symbology (experiment with Show: 
try both ‘Stretched’ and ‘Classified’ and their graphic -color 
options). 

o Uncheck kpblack. 
o Set the base heights of pctbach point and Georgia2004 to kpblack, 

making sure that, under ‘Rendering,’ both Effects boxes are checked in 
each case. 

§ Symbolize Georgia2004, choosing a fill color with an outline 
color so that the counties display. 

§ Symbolize pctpach point (PARM_6).  
§ Is much or any height displayed?  If not, why?  How does this pertain to 

mapping strategy (and ethics) as we discussed in Assignment 9? 
 
§ If you join pctbach point and Georgia2004, you’ll be able to map the GWR 

results in both 3D and color gradation 
 
§ Let’s say that, within the framework of analytically and ethically sound 

practices, it makes sense to compensate for the 3D map’s lack of height.  
How can you do so?  

o ArcScene Properties>General>Vertical Exaggeration=3. 
§ Experiment with other values, including ‘Calculate from Extent’. 
§ In this case, does resetting Vertical Exaggeration make much 

difference? 
 

o Alternatively, do the following for pctbach point and Georgia2004: 
Reset Vertical Exaggeration to 0.  Then: Layer Properties>Base 
Heights>Z-Unit Conversion>Apply conversion factor to place heights in 
same unit as scene>change 1 to 5. 

 
o In this case, which of the two approaches seems best, and why?   
 
o Try combining Vertical Exaggeration values and Z-Unit Conversion. 
o If a layer disappears, click the Full Extent icon. 

 
o Use the ‘Navigate’ tool to move the layer to an angle that most 

effectively conveys the relationship between the GWR’s independent 
variable and dependent variable.  The Pan tool can move the layer in 
the display area. 
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o Does the spatial distribution of heights effectively convey the spatial 
distribution of kforborn’s values?   

§ Do the following for pctbach point and Georgia2004: 
• For each of the two layers, try reversing the spatial 

distribution of heights: Layer Properties>Base 
Heights>Z-Unit Conversion>Apply conversion factor to 
place heights in same unit as scene>change 5 to –5. 

• If necessary, set the Vertical Exaggeration to 0. 
§ Is reversing the Z-Unit Conversion helpful or not in this case? 

 
§ More experimenting for pctbach point and Georgia2004: try 

different settings for ‘Offset’.  Are they helpful in this case? 
 

• Later on we’ll experiment with another height-changing 
procedure, Extrusion (Layer Properties>Extrusion tab). 

 
§ Set the Vertical Exaggeration and, for pctbach point and 

Georgia2004, the Z-unit conversion to the values that work 
best for display purposes. 

• Instructor’s choice: Vertical Exaggeration=3 (and, for 
both Georgia2004 and pctbach point)  Z-Unit 
Conversion=3.  Offset=0.  Reason: attempt to clearly 
display the spatial variation in coefficient values without 
exaggerating the range of values. 

§ Rename the checked layers to ‘Georgia Counties’ and ‘GWR coef: % Black>% 
Bach Degrees’. 

 
§ Save the 3D map file via ‘save as’ in Assignment 10 folder (‘3DBlack’, which 

will have an .sxd extension).   
 

§ Recall, however, that what’s paramount is an analytically and ethically sound 
approach to communicating the GWR’s results.  It may or may not make 
sense to use a 3D map in this context. 

 
 

 
V: Extrusion 

 
§ Here’s another way to create a 3D effect—‘extrusion’: 

o PBachMap>Properties>Extrusion. 
o Click ‘Extrude features in layer’. 
o ‘Extrusion value or expression’: click expression-builder to the right of the 

dialog box. 
o ‘Expression’: click PARM_6 in ‘Fields’.  OK>OK.    
o Experiment with other values. 

o Scene Layers>Vertical Exaggeration: experiment with values. 
o To turn off extrusion: PBachMap>Properties>Extrusion.  Then uncheck 

‘Extrusion value or expression’. 
 
§ Extrusion can be helpful to visually communicate, e.g., land/housing values, 

income levels, poverty rates, crime rates, household features, voting results, and 
disaster damage. 
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VI: Trouble Shooting 

 
§ What if a layer doesn’t display as 3D? 

o Right-click the layer & click View>Refresh. 
o Make sure that the layer file has a selected source of base heights. 
o If the layer does have a selected source of base heights but doesn’t 

display as 3D, either click Scene layers>Vertical Exaggeration (to 
synchronize the z-values with the x,y coordinates) & click the Full 
Extent icon, or else import a coordinate system into Scene layers 
(which also synchronizes the z-values with the x,y coordinates). 

o Recall that the heights displayed are most basically a function 
of the z-values of the base heights: if these are minimal, then 
the displayed heights will also be minimal. 

 
 

VII: Cautionary Conclusions 
 

§ What are the limitations of 3D maps? 
 


