Section II—Aegis
Case Studies
Case Study 1

Introducing Diversification with Aegis Portfolio Manager

Welcome to the first case study in this handbook. This introductory case demonstrates the benefits of diversification and introduces basic features available to students with Barra’s Aegis Portfolio Manager.

- Case Study Objectives
- Exercise 1.1: Creating a Single-Stock Portfolio
- Exercise 1.2: Merging the Stock Portfolios
- Exercise 1.3: Analyzing a More Realistic Portfolio
- Exercise 1.4: Comparing Real Portfolios
- Summary
Case Study Objectives

In this case study, you will

• Create some simple, single-stock portfolios, and observe their high-risk characteristics (without diversification) in the Aegis application.

• Merge the single-stock portfolios into multi-stock ones, and see the improvement from diversification.

• Build a more realistic multiple-stock portfolio.

• Compare the risk decomposition and factor exposures of the portfolios.
Exercise 1.1: Creating a Single-Stock Portfolio

Before You Begin

The Aegis application and data must be installed. Your professor or school contact may access installation instructions on the Barra On Campus password-protected Web site.

Steps

We begin by creating a simple single-stock portfolio so that we can view the basic risk profile of an asset.

1. Open the Aegis program by selecting Barra Aegis System > Portfolio Manager from the Windows program menu.

2. Select File > New Portfolio.

3. In the Select Model and Dates dialog, click OK to accept the default model and date. (All prices in the data came from this cut-off date.)

   An empty portfolio workspace opens.

4. In the drop-down menu above the top left of the workspace, select Exch. Tick., then in the ticker symbol box to the right (or in the Asset ID column in the workspace window), type MSFT (ticker symbol of Microsoft), and press Enter.

   The price and yield data display in the asset row with zero shares and portfolio weight, since the number of shares has not been entered.

   Note: This exercise uses a well-known company to present the features of Barra’s Aegis Portfolio Manager. You can view any U.S. stock on your own following this exercise.

5. In the Shares column type 100, then press Enter.
In the navigation tree to the left of the portfolio workspace, select **Executive Summary (F2)**, or press the F2 key.

A summary of the risk return profile of the portfolio displays, as shown in Figure 28 on page 6.

- **Note**: The total portfolio value displays in the status bar at the bottom of the main application screen.

- **Reminder**: To size a window, drag one of the corners or use the maximize icon on the right side of the window’s title bar.

![Figure 28: Executive Summary: MSFT](image)

- **Note**: The Total Risk indicates a two-thirds probability that the actual return of this portfolio (consisting of 100% Microsoft stock) will be in the range of the expected return, plus or minus 39.69%.
7 In the navigation tree, open (double-click) the Risk folder, then select Risk Decomposition, or press the F6 key.

![Risk Decomposition: MSFT](image)

**Figure 29: Risk Decomposition: MSFT**

▷ **Note:** The Risk Indices and Industries figures combine to form common factor risk.

In the next step we look at the distribution graph to visualize the probable returns to our portfolio.

8 In the navigation tree, open (double-click) the Risk folder, then select Forecast Return Probability Distribution Graph.

The Forecast Return Probability Distribution Graph displays, as shown in Figure 30 on page 8.
This window shows the forecasts of the probabilities of MSFT’s return; zero (in the center) is the expected total return. For example, if the expected return is 5% today, there will be a 67% likelihood that MSFT will return between a gain of 45% and a loss of 35%. Of this amount of volatility, the majority is contributed by individual risk of Microsoft (asset selection = 30.86%, as viewed in the Risk Decomposition window in Figure 29 on page 7). It should be noted that even a single-stock portfolio is affected by common factors such as industry trend and the economy.

We’ll next view the forecast distribution in numeric terms.

9 In the navigation tree’s Risk folder, select Forecast Return Probability Distribution.

The Forecast Return Probability Distribution window displays, as shown in Figure 31 on page 9.
CASE STUDY 1
Introducing Diversification with Aegis Portfolio Manager

This window shows the numeric breakdown (in the Probability column) of the information that we viewed in the Forecast Return Distribution Graph. Note as well that the standard deviation (39.69%) in the summary information at the top of the window matches the total risk shown in the risk decomposition (see Figure 29 on page 7). The total risk of a portfolio with a single asset is equal to the standard deviation of forecasted returns.

Follow the same steps to create a second single-stock portfolio; this time let’s choose a more conservative stock, Exxon Mobil Corp.

1 Close any open windows, then select File > New Portfolio and click OK to accept model date.

2 Type XOM (ticker symbol of Exxon Mobil Corp.) in the Asset ID column, and press Enter.

3 Type 85 in the Shares column, then press Enter.

4 In the navigation tree select Executive Summary (F2), or press the F2 key.

Figure 31: Forecast Return Distribution: MSFT
A summary of the risk return profile of the portfolio displays, as shown in Figure 32:

Notice that the Exxon Mobil portfolio has a much lower Total Risk at 24.86%, compared to Microsoft’s 39.69%. This reflects the fact that Exxon Mobil is a less volatile stock than Microsoft.

5 In the navigation tree, open (double-click) the Risk folder, then select Risk Decomposition, or press the F6 key.
CASE STUDY 1
Introducing Diversification with Aegis Portfolio Manager

Notice that the Risk Indices and Industries (common factor) risks have a greater contribution to the total risk in our Exxon Mobil portfolio compared to Microsoft. Naturally, the return on Exxon Mobil Corp., an oil refinery and distribution conglomerate, will likely have a higher impact from industry or macro-economic events such as an oil shortage.

**Figure 33: Risk Decomposition: XOM**

Choose other stocks and use the Executive Summary, Risk Decomposition and Forecast Return Distribution reports to examine the associated risk. If you encounter unfamiliar terms in the fields on these windows, look them up in your finance or other textbooks, or check the index for topics addressed in the Theory section of this handbook.
Exercise 1.2: Merging the Stock Portfolios

Before You Begin

In the previous exercise we created two independent, single-stock portfolios. In this exercise we'll examine the diversifying effect of merging two assets into a single portfolio.

Steps

1. Click the Exxon Mobil portfolio to make it the active screen.
2. In the second row of the Asset ID Column, type MSFT, then press Enter.
3. Select Actions > Weight > Equal Weight.
   Although 100 shares of MSFT will create approximately equal weight between the two stocks, this function automatically calculates a portfolio that is exactly equally weighted.
4. In the navigation tree, select Executive Summary (F2), or press the F2 key.
   A summary of the risk return profile of the portfolio displays, as shown in Figure 34 on page 13.
CASE STUDY 1

Introducing Diversification with Aegis Portfolio Manager

**Note:** The total risk, at 24.63, is reduced significantly from the Microsoft portfolio’s 39.69, indicating that the merged portfolio is much less volatile in comparison. In addition, the merged portfolio’s total risk is also slightly lower than the Exxon Mobil’s portfolio’s 24.86. This is the benefit of diversification—it spreads the portfolio’s exposure among different factors.

In the navigation tree, open (double-click) the **Risk** folder, then select **Risk Decomposition**, or press the F6 key.
Explore Further

How could the combined total risk be lower than that of either single-stock portfolio? The scale of improvement in the volatility of the merged portfolio depends on the correlation between the two stocks, as given in the following variance equation:

\[
\sigma_p = \omega_1^2 \sigma_1^2 + \omega_2^2 \sigma_2^2 + 2 \omega_1 \omega_2 \sigma_1 \sigma_2 \rho_{12}
\]

\[\text{Eq. 15}\]

where

- \(\sigma_p, \sigma_1, \text{ and } \sigma_2\) = standard deviation of the portfolio, Microsoft, and Exxon Mobil, respectively
- \(\omega_1 \text{ and } \omega_2\) = perspective weight of each stock in the portfolio
- \(\rho_{12}\) = correlation of returns between these two securities
Portfolios composed of less-than-perfectly-correlated stocks always offer a better risk profile than that of those individual securities. This is evident from the above equation, since a correlation value of less than 1 will reduce the standard deviation of the portfolio. This was demonstrated by our exercise of merging the Microsoft and Exxon Mobil stocks.

Note that our firm’s asset-selection risk actually increased compared to the Exxon Mobil portfolio (see Figure 33 on page 11). To have a more effective diversification and reduction in volatility will require more than two stocks. In the next exercise, we examine and compare the more realistic approach of diversification, which is holding multiple securities.
Exercise 1.3: Analyzing a More Realistic Portfolio

Before You Begin

Investors rarely hold just one or two stocks in their portfolio; a large institution or mutual fund may actually hold the entire Standard & Poor’s 500 stocks in its portfolio. This exercise examines the benefits of diversification with a more realistic multiple stock portfolio.

Steps

1. Close all the open portfolios, and do not save them.

2. Select File > Open Portfolio.

3. Navigate to the Aegis\U3EQTY\200209\20020830 folder, then double-click the MMI portfolio (MMI.POR file).

The MMI is an American Stock Exchange index of 20 large capitalization stocks.

The window in Figure 36 on page 17 displays:
In the navigation tree, open (double-click) the Risk folder, then select Risk Decomposition, or press the F6 key.

Compare this portfolio to the Microsoft and Exxon Mobil portfolio in the previous exercise. Notice that this portfolio has much lower total risk and asset selection risk at 13.91% and 5.44%, respectively.

Now that we have a more realistic portfolio, we can analyze the risk profile from more than just a statistical perspective. We can see specific sources of risk. The next step displays the sector exposures.

Select Data > Define Mappings > Sectors, then click OK to confirm US Equity Default as the current sector mapping in the drop-down menu.

In the navigation tree, open (double-click) the Exposures folder, then Sector Graph.
The Sector Exposures Graph opens:

![Sector Exposures Graph: MMI Portfolio](image)

This is the portfolio’s sector breakdown. Note that the portfolio’s exposure is spread among all sectors except Utility and Transportation. Next we will compare the MMI portfolio’s sector exposures with those of the S&P 500.

7 Select File > Open Portfolio, and open the SAP500 portfolio (SAP500.POR file) from the Aegis\U3EQTY\200209\20020830 folder.

8 In the navigation tree, open (double-click) the Exposures folder, then Sector Graph.

The following window opens:
Notice that the S&P 500 has a significantly higher exposure to the Financial sector than any others as of August 30, 2002. Over the years the S&P Board has chosen and replaced components of the S&P 500. Just over two years ago, the S&P 500 had the highest exposure to the Technology sector in the same analysis.

If an investor expects the Financial sector to suffer in the near term and wishes to actively avoid the sector, an S&P 500 Index Fund may not be a good choice for this investment. The relatively high exposure in Financial is not favored by this particular investor’s style or preference.

Perhaps only a few investors in today’s market will actively avoid the Financial sector entirely. Nonetheless, we can begin to see how Barra’s analytics can assist investors or investment professionals in their decision-making process. In most cases, the S&P 500 is deemed a diversified benchmark with respectable returns and broad exposure to most sectors. In the next exercise we look at how the MMI portfolio compares to the S&P 500 in other areas.

Figure 38: Sector Exposures Graph: S&P 500
Exercise 1.4: Comparing Real Portfolios

Before You Begin

Aegis Portfolio Manager allows investment professionals to analyze and compare portfolios in various ways using numerous perspectives. In this exercise we will compare portfolios. We will use a cash benchmark; in the next case study, we explore using other benchmarks.

Steps

1. Close out all open windows in the Aegis application.

2. Select File > New Multiple Portfolio Case, and accept the existing setting by clicking OK.

3. Click the button in row 1, and open the MMI portfolio. Do the same to open the SAP500 portfolio in row 2.

4. Enter 0.50 for the weight of each portfolio.

The Multiple Portfolio Case window opens, as follows:
5 Click the **Results** button to process the comparison. When the **Portfolio Comparison** window is done, click the **Risk Decomposition** tab.

*Figure 39: Multiple Portfolio Case Example*
The following view displays:

![Portfolio Comparison: Risk Decomposition](image)

*Figure 40: Portfolio Comparison: Risk Decomposition*

As the above risk decomposition table shows, the S&P 500 has a significantly lower Active Risk Index and Active Specific risk than the MMI portfolio. Let’s also look at another analysis in this comparison.

6. On the Portfolio Comparison window, select the Factor Exposure tab, then Active Sectors from the drop-down menu.
A direct comparison of the two portfolios opens, as shown below:

![Portfolio Comparison: Factor Exposure](image)

**Figure 41: Portfolio Comparison: Factor Exposure**

**Explore Further**

We did the same comparison in the last exercise by looking individually at each portfolio’s sector breakdown. Choose other portfolios to come up with other comparison analyses.
Summary

This case served to illustrate the rationale behind holding a diversified portfolio. It also showed the extent to which one can lower the risk (volatility) of a portfolio through diversification. Two stocks that have similar exposures and move in the same direction have a less diversifying effect when combined in a portfolio. Knowing the risk profile before adding securities to their portfolios gives investment professionals and fund managers a great advantage.

In this case study we focused on risk and ignored returns; in a later case study exercise we examine them together, since both risk and return should be considered in the diversification.
Case Study 2

Analyzing Portfolio Risks with Aegis Portfolio Manager

After the review of risk diversification and introduction features of Aegis’ analytics in Case Study 1, we will look more closely at the features of Aegis Portfolio Manager. You will be exposed to the in-depth analysis of the factors that contribute to a portfolio’s risk.
Case Study Objectives

In this case study, we will

- Process and set a benchmark to use for tracking portfolio performance.
- Sort portfolio assets by weight and analyze various risk characteristics.
- Examine a portfolio’s sector exposures against a benchmark.
- Study the investment style of a portfolio.
- Explore the transaction summary, and make a few trades to reduce risk.
Exercise 2.1: Building a Portfolio and Benchmark

BoC2002 is a hypothetical portfolio that consists of 50 stocks plus cash. We will use this portfolio to demonstrate how an investment professional uses this software to perform essential analysis.

Before You Begin

If continuing from the previous case, close all open portfolios without saving them.

Steps

1. Select **File > Open** from the Aegis menu bar, then navigate to the Aegis\userdata folder and open the BoC2002 portfolio.

   The portfolio workspace opens.

   Since you are likely to be familiar with exchange tickers to identify the portfolio’s constituent stocks, we will change the **Asset ID** display from Barra IDs to exchange tickers.

2. In the portfolio workspace, click the **Asset ID** column label to highlight all the asset IDs in the portfolio, then in the drop-down menu under the toolbars (on the left of the screen), change the selection from **BARRID** to **Exch. Tick**.

   The portfolio’s asset IDs display as exchange tickers, as shown in Figure 42 on page 28.
According to the portfolio details (in the status bar at the bottom of the application screen, not shown above), the portfolio consists of 51 assets and has a value of over $563 million. The prices of these securities as shown are based on the closing prices on August 30, 2002. Currently, there's no benchmark (Bmk) or market (Mkt) used to analyze this portfolio.

Let's set S&P 500 as the benchmark of our hypothetical portfolio, as mutual fund and managed asset managers often do.

3 Select Data > Benchmark, Market, Composites, click Add File, navigate to the Aegis\U3E0TY\200209\20020830 folder, and open SAP500 (SAP500.POR file).

4 Click Add File again, and open USE3EST.
USE3EST is a portfolio of over 2,000 stocks that Barra uses to analyze and estimate the overall market risk profile.

Data from these two portfolios will be available for us to match against our portfolio. While any index or portfolio available or created in Aegis can be processed as a benchmark for comparison, in this exercise we will use a recognized benchmark, the S&P 500.

5 Click **Process**.

After a few moments the **Composite Processing Summary** window opens.

6 Click **OK** to close the window.

7 Select **Portfolio > Settings**.

The **Settings – BARRA** window opens. (If not displayed, click the **General** tab.)

8 In the **Reference Portfolios** area of the window, click the **Select** button for the **Benchmark** row and select **SAP500**.

The following window displays:
On the **Settings** window button panel, click **OK**.

We are now ready to analyze our portfolio with the S&P 500 as the benchmark.
Exercise 2.2: Analysis of Risk Profiles and Sector Exposures

Before You Begin

Review the concepts and use of betas, total risk, and active risk (or tracking error). The information in this section may be of assistance.

A beta of 1 means that a stock or portfolio is expected to move precisely with the benchmark; a beta of 0 means no correlation exists between the security and the benchmark. Most publications use historical beta, but since Aegis establishes betas from a complex modeling and forecast system, it can generate beta for even relatively new stocks. Portfolio managers also look at total risk, which is the measure of expected volatility of our portfolio relative to a riskless index.

In this handbook active risk and tracking error are used interchangeably. In fact, the two terms describe the same statistical term: how much the risk profile of one’s portfolio deviates from that of the benchmark index. The difference comes from the investment style of the portfolio. For example, if a mutual fund manager expects to outperform the index, certainly she or he will intentionally hold different securities or weights from the index; in this case the portfolio manager actively seeks higher returns and creates differences in the risk profile of the portfolio, hence the term “active risk.”

On the other hand, for an index fund that is supposed to exactly match the performance of an index such as the S&P 500 or the NASDAQ 100, the returns and the risk profile should be exactly the same as the index; any deviation in risk profile of this index fund from the index will be considered a tracking error.
Barra assigns industries to individual stocks based on evaluation in revenue sources or other factors. For example, Microsoft is assigned 100% to Computer Software, while conglomerate Disney has 65% in Media and 35% in Entertainment. Barra reviews the industry breakdown periodically, and makes changes based on the issue's business or revenue source.

In addition to risk decomposition, we can examine the portfolio's breakdown in the terms of the sectors or industries, as compared to the benchmark.

In this exercise we observe weights, beta, and total risk for our BoC2002 portfolio. We also focus on the industry exposures.

Steps

1. Close the Settings window.

2. Click the Weight column label.
   The entire column is highlighted.
   In the following step, we'll sort the securities by weight.

3. Click the icon in the toolbar.
The following window displays.

![Portfolio Workspace: BoC2002 Portfolio](image)

The Weight column has been sorted in descending order.

**Note:** You can sort the order of the securities by any of the columns in ascending or descending order.

4. In the navigation tree, select **Executive Summary (F2)**, or press F2.

The **Executive Summary** window displays, as shown in **Figure 45 on page 34:**
The summary includes additional information compared to the results in the first case study (see Figure 34 on page 13). Once a benchmark is set up, we can see risk characteristics relevant to the benchmark index.

The Predicted Beta, at 0.97, indicates that the overall portfolio is expected to move somewhat closely with the benchmark, the S&P 500. In this case, if the S&P 500 achieves a growth of 100% in five years, our portfolio would be expected to grow 97%.

If the S&P 500 were to go down, on the other hand, we would also expect our portfolio to go down, but not as much. For a 10% decrease in the S&P 500, for example, we would expect our portfolio to go down 9.7%.
By taking higher active risk, the return of our portfolio will deviate substantially from the S&P 500 from period to period. The higher the active risk, the greater the range of deviation of returns that may take place.

A graphical approach will demonstrate the concepts behind one standard deviation.

5 Select View > Return Probability Distribution.

The following screen displays:

![Graph showing forecast return distribution](image)

**Figure 46: Forecast Return Distribution: BoC2002 Portfolio**

The illustration above is similar to the one we covered in the first case study (see Figure 30 on page 8). The difference is that the center of distribution (return of 0.00) now represents the probability that our portfolio will yield the same as the S&P 500. (Note, however, that if we expected our portfolio to outperform the S&P 500, the mean value would be shifted to the right by the amount specified by our expected outperformance.)

Our 3.91% active risk means that we expect a 66% probability (one standard deviation) that our portfolio will return within the range of the S&P 500’s return plus or minus 3.91%. If the Index return is 2% this year, then we can expect our portfolio to return between 5.91% and –
1.91%. To be even more confident with our forecasts, we can use two standard deviations, which forecasts a 95% probability. Using this confidence level, 95% of the time our portfolio will return between 9.82% and –5.82%.

6. In the navigation tree, open (double-click) the Exposures folder, then click Industry Graph.

The window shown in Figure 47 on page 36 opens.

7. To view the analysis on the industries not displayed, click Graph 2 at the bottom left-hand side of the window.

Explore Further

There is no industry standard for matching a fund management style with an active risk range. Rather, one should expect very low active risk in an index fund, and higher risk deviation in an active fund.
Our BoC2002 demonstration portfolio in this exercise had 391 basis points in active risk. Our hypothetical fund might be considered to have a core active management management style. If the fund were to advertise itself as an index fund or a very aggressive growth fund, the manager may need to re-evaluate his or her portfolio.

The advantage of the Industry Exposures Graph is perhaps less obvious on a small portfolio such as BoC2002, since we can look at the sector exposures of each of the 50 stocks individually. However, for a massive mutual fund managed by multiple managers, this tool can ensure that the portfolio will have the right exposure or non-exposure level to certain industries. For instance, a proclaimed socially-conscious mutual fund may choose to avoid the Alcohol and Tobacco industry.

For large international fund managers, the industry analysis tool is even more essential. Barra has developed numerous models for developed market and global portfolios, which allow fund managers to analyze international portfolios in the same manner.

Repeat Exercise 2.1 and Exercise 2.2 using a different benchmark of your choice. See if you can find a portfolio (or multiple portfolios) that results in an active risk level appropriate for an index fund manager, or for a very aggressive manager.
Exercise 2.3: Analysis of Investment Style

Before You Begin

Aside from industry, some mutual fund managers often identify their investment approach as “top-bottom” or “stock-picking.” Using the same BoC2002 portfolio that we’ve worked with earlier, this exercise illustrates how Aegis Portfolio Manager can identify those investment styles.

If a mutual fund labels itself as a “stock-picker” or takes the “bottom-up” approach (which means it places more emphasis on analysis of individual companies rather than industry or trends), then we expect to see a much higher portion of volatility to be explained by asset selection risk. On the other hand, for a mutual fund that places more emphasis on industry, the analysis would reveal highest risk contribution from industries within the Industries risk category.

The Aegis Portfolio Manager can be a powerful tool to assist investment professionals in the decision-making process of examining whether a portfolio exhibits the characteristics that it claims to represent. Aegis also enables fund managers to constantly audit their own portfolios and maintain consistent objectives as securities are bought and sold.
Steps

1. In the navigation tree, open (double-click) the Risk folder, then select Risk Comparison. Review the resulting information (shown in Figure 48).

![Figure 48: Risk Comparison: BoC2002 Portfolio](image)

- **Note:** For this exercise concentrate on the information in the Managed Portfolio columns. In Exercise 3.1 we’ll set an initial portfolio for the purpose of running an optimization.

The Total in the Risk column is the expected volatility of the BoC2002 portfolio to deviate from risk-free assets. Recall that standard deviations do not add up to the total risk, whereas the squares of standard deviations, variances, sum to the total variance.

Since our benchmark is the S&P 500, management will focus on the volatility in excess of the benchmark, or the Active row. Aegis Portfolio Manager analyzes portfolio active risk and decomposes it as either asset selection risk or common factor (risk indices and industries) risk. This analysis enables us to understand the investing style of this portfolio.

Our BoC2002 Portfolio has a 3.22 standard deviation in Asset Selection risk and a 1.97 standard deviation in the Industries portion of common factor risk. We may speculate that this portfolio has more emphasis on stock picking while having a preference for a certain industry.

Let’s look into further breakdowns of risk contribution from the various risk indices such as momentum and size.
2 In the navigation tree, open (double-click) the **Exposures** folder, then select **Risk Index**.

We’ll next examine the risk figures in finer detail.

3 Click the Properties icon on the toolbar, and in the **Report Properties** dialog, change the **Decimal Precision** drop-down menu from 2 to 3, then click **OK**.

**Note:** If the Properties icon does not display in the toolbar, select **Tools > Toolbars > Toolbar 1 > Customize**, locate and move the Properties icon in the **Available toolbar buttons** list to the **Current toolbar buttons** list, and click **Close**.

The following window displays:

![Image of Risk Index Exposures](image)

**Figure 49: Risk Index Exposures: BoC2002**

Barra’s U.S. Equity Model contains 13 risk indices. Through extensive research and model building, Barra has identified these as common factors among U.S. stocks. Each security is then assigned exposures to...
these factors based on its characteristics, as reflected in the figure above. For details about the risk indices used in the USE3 model, see Appendix A.

The Relative column displays the relative difference between the portfolio’s exposure and that of the benchmark. Keep in mind, however, that exposures do not fully describe risk: some factors are riskier than others, and factors are correlated. The MC to Risk column tells us how “risky” relative exposure is, that is, how sensitive the portfolio’s risk is to change.

For example, a fund manager who advertises his or her strategy as momentum-based would have a large active bet (exposure) in Momentum; similarly, a Large Cap Fund would have higher exposure in Size, and a Value Fund in Value. Other exposures may arise as a result of these strategies.

The BoC2002 Portfolio has overall small active exposures across the risk indices. The two largest deviations came from Size and Leverage. In comparison to the S&P 500, the BoC2002 portfolio is less exposed to the Leverage factor and more to the Size factor. This may indicate that BoC2002 is composed of stocks from larger established companies with less debt compared to the average profile of the S&P 500 companies.

To view the comparison in the bar chart, in the navigation tree click Risk Index Graph.
The following window displays:

![Figure 50: Risk Index Graph: BoC2002](image)

Details of an individual stock within the portfolio can be examined by looking at the risk profile.

5 In the portfolio workspace, highlight one of the stocks in BoC2002 (for the example in Figure 51, we use American Express), and in the navigation tree open (double-click) the Asset Details folder, then select Risk Model Details (F12), or press F12. Use the vertical scroll bar as needed to view all the data.
The following window displays:

![Risk Model Details: American Express](image)

**Figure 51: Risk Model Details: American Express**

Portfolio managers can use this function to study the individual stock and decide if it will match their investment style.
Exercise 2.4: Examine the Effect of Trading

Before You Begin

In this exercise we simulate trades and see how they may improve the risk profile of our portfolio; it will also prepare us for our next case study on optimization. We'll start by taking a look at risk indices once again.

Keep in mind that the marginal contribution to active risk (MCAR), a concept used in this exercise, expresses the change in a portfolio’s tracking error given a 1% increase in the stock position (taking the money out of cash or shorting cash).

Steps

1. Return to the portfolio workspace with BoC2002 open, and in the navigation tree, open (double-click) the Exposures folder and select Risk Index.

   The Risk Index Exposures window displays (see Figure 49 on page 40).

2. Look at the MC to Risk column.

   To create a minimum-risk portfolio, you might begin by selling some shares of the stock with the highest MCAR and buying shares in the stock with the lowest MCAR. The risk reduction that results will be proportionate to the difference in the MCARs of the two assets. (Once you change weights of any stocks in the portfolio, the MCARs of all stocks will change.) You can repeat this process until you reach a situation where all stocks in the portfolio have the same MCAR and you cannot reduce risk any further.

   In our current context, MCAR describes the sensitivity of the portfolio’s risk to the over- and under-exposures for each risk index. In this case, our portfolio’s most exposed risk index, Size, is also the risk index that we are most sensitive to. Keep in mind that risk reduction can be
achieved by either reducing the MCAR of the highest contributors to active risk or by increasing the MCAR of the risk indices with negative contribution to active risk.

In addition, portfolio managers may intentionally choose to increase MCAR for a targeted risk index based on a bet to anticipate changes in exposure and sensitivity. This exercise, however, presents an example of risk reduction through diversification.

Continue on to learn how to fine-tune our marginal contribution to active risk.

3 Close the Risk Index Exposures window, and select Actions > Marginal Contribution to > Risk.

The window in Figure 52 displays:

![Figure 52: Marginal Contribution Ranking: BoC2002 Portfolio](image)

On the left are the most diversifying stocks to our BoC2002 portfolio; adding to the weight of these stocks decreases risk the most. On the right are the least diversifying stocks in our portfolio. Increasing the holdings of the most diversifying and decreasing the holdings of the least diversifying stocks will lower the deviation from the risk profile of our benchmark, S&P 500. If an investor disagreed with the investment style of the S&P 500, he or she would need to set a different benchmark to suit the desired approach.
4 In the Input Id column, click USACDQ1 (Campbell Soup Co.), and click the Simulate Trade button in the lower right corner.

The following window displays:

![Simulate Trade Window: Campbell Soup Co.](image)

The y-axis shows the current active risk of our portfolio, 3.91 (the light dot). The x-axis shows the current weight of Campbell Soup in our portfolio. The illustration indicates the portfolio's active risk as a function of the weight of Campbell Soup stock in this portfolio. Reading from the graph, an even lower risk of 3.867 could be achieved by using cash to increase the portfolio weight of Campbell Soup 1%.

However, if we sell some of the riskier stocks and use the proceeds to buy Campbell Soup, we can achieve even higher risk reduction.

5 Click ORACLE CORP in the Trade USAAUL 1 With field.
The graph changes to recommend an increase of Campbell Soup portfolio weight somewhere between 1.17 and 2.17%, resulting in a lower active risk.

6 To view finer x-axis increments, set the **Set Range** drop-down menu to 2.5%.

   The finer view recommends a portfolio weight of 1.42% for Campbell Soup.

7 **Change the** **Set Weight** **field to 1.42%**, and click **Make Trade**.

   We should see more Campbell shares and fewer Oracle shares.

8 **To see the improvement in risk profile, in the navigation tree open (double-click) the Portfolio folder and select Executive Summary (F2), or press F2.**

**Explore Further**

Conduct more trade simulations to make the active risk even lower by repeating this exercise. Be aware that the list of most and least diversifying stocks may change after each trade.

**Summary**

In this case study we covered how to view and interpret the risk a portfolio’s risk factors and characteristics. The case study also gave introductions to features and capabilities of the Aegis Portfolio Manager and how these assist investment professionals. In the following case study, we discuss how to use the Aegis optimizer module to construct superior portfolios without having to make trades manually.
How much do we know about the BoC2002 Portfolio based on these exercises? From our analysis we know that

- The portfolio has an active investment style, trying to beat S&P 500 returns.
- The manager of the portfolio uses the bottom-up approach, picking stocks over industries.
- The average size of the companies that the portfolio invested in is larger than that of the S&P 500.
- The portfolio has a higher emphasis on the finance stocks than does the Index.

Indeed, the BoC2002 Portfolio is composed of 50 stocks from the S&P 100, which is composed of the 100 largest companies within the S&P 500.

**Explore Further**

Input your own portfolios and see what investment style or preference Aegis Portfolio Manager reveals!
Case Study 3

Constructing a Superior Portfolio with the Aegis Optimizer

We analyzed our BoC2002 portfolio's various risk characteristics and exposures and conducted risk-reducing trades, one asset at a time. For managers of large portfolios, this process needs to be executed in a speedy and sophisticated fashion. The Aegis optimizer finds optimal portfolios that meet each level of risk and return preferences.
Case Study Objectives

The goal of portfolio construction or optimization is to maximize utility. Please review the theory pertaining to utility in this handbook or other sources.

In this case study, we will

- Optimize a portfolio with no constraints.
- Perform optimizations subject to transaction costs, preference, and expected return.
- Generate an efficient frontier of the portfolio based on these inputs.
- Familiarize themselves with the different features of the Aegis optimizer for serving different investment styles.
Exercise 3.1: Minimal Risk Optimization

Before You Begin

If continuing from the previous case, close all open portfolios without saving them.

Steps

1. In Aegis Portfolio Manager, select File > Open Portfolio and open the BoC2002 portfolio that we used in the last case study.

2. Select Portfolio > Settings (or click the icon) and in the General tab, confirm that SAP500 is selected as the benchmark. Click OK to close the Settings window.

   In the next step we will optimize the portfolio.

3. Select Action > Optimize, or click on the toolbar.

   After a few moments an optimum portfolio displays in the portfolio workspace as shown in Figure 54 on page 52. (To display asset IDs as exchange tickers, highlight the Asset ID column, then select Exch. Tick. in the drop-down menu over the top left of the portfolio workspace.)
In the navigation tree, open (double-click) the Risk folder, then select Risk Decomposition (or press F6).
Compared to our original portfolio summary, it shows a decrease in total risk from 14.60 to 14.15; more importantly, active risk was reduced from 3.91 to 2.91. Compared to the original portfolio, the optimized portfolio has a lower deviation from the risk profile of the benchmark. The 100-basis-point reduction was achieved by selling and buying shares of the 50 securities in the portfolio. At this point the Aegis optimizer can only rebalance the weights of existing securities in the portfolio to achieve higher utility; later in this case, we can set the optimizer to add or remove securities for better utility maximization.

Save the changes to the optimal portfolio by selecting **File > Save Portfolio As**, and name the new portfolio optimal.por.
6 In the navigation tree, open (double-click) the Trade List folder, then select All Trades.

The trades made during optimization display.

Turnover always comes at a cost. In the following exercise, we will subject our optimization to transaction costs as well as other considerations.
Exercise 3.2: Optimization with Constraints

Before You Begin

We can now take a more realistic approach with our optimization process. Imagine that a new portfolio manager just took over the BoC2002 portfolio; the new manager would like to rebalance the current portfolio, still benchmarking against the S&P 500, with the following considerations:

- A more active bet towards Growth.
- Transaction costs at $0.10 per share traded, and 0.50% of total value per trade.
- Allow purchase of new stocks and complete sell-off of existing ones from the portfolio.

This exercise guides us through implementing the rebalancing process using the above considerations as optimization constraints. Two definitions are important for understanding the optimization process:

A constraint is an upper or lower bound that enables you to control exposure to a parameter during optimization. (You can also set both upper and lower bounds for a constraint parameter.) The Aegis optimizer will attempt to meet the specified constraint; if it cannot be met, the program will indicate that the constraint is infeasible.

A penalty enables you to tilt an optimization toward a desired characteristic or restrict a factor value to a certain range. Unlike constraints, penalties are not binding. Setting a penalty requires setting a targeted value with upper and lower bounds to indicate how closely the value should approach the target.
Steps

1. Close all windows pertaining to the optimal portfolio, and open the BoC2002 portfolio. Select **Portfolio > Settings**, or click \( \text{ } \) in the toolbar, and click the **Constraints** tab.

   **Risk Indices** should display as the default in the **Constraint Type** drop-down menu. (If it does not display, select it.)

2. Type \( b+0.25 \) (indicates benchmark + 25 bps) next to the **Growth** factor under the **Min** column, and next to **Constraint Priority**, click **Tighter**.

   The following window displays:

   ![Settings Window: Constraints Tab]

   *Figure 56: Settings Window: Constraints Tab*

   *Growth constraint has been set to \( b+0.25 \), tighter.*
Adding a $b+0.25$ constraint requires the optimizer to achieve a higher risk exposure to the Growth factor: the optimized portfolio must have at least 25 basis points in excess of the benchmark in the Growth risk index.

3. Click the **Transaction Costs** tab on the **Settings** window. In the **Overall Transaction Costs: Buy Costs** row, enter 0.50 in the box by \% and 0.1000 in the box by **Per Share**; do the same for the **Sell Costs** row.

The following screen displays:

![Image of Settings Window: Transaction Cost Tab](image)

*Figure 57: Settings Window: Transaction Cost Tab*

4. Click the **General** tab.

   ▶ **Note:** If the SAP500 does not display as the benchmark, select it.

5. Click the **Use benchmark as universe** button.
The **Universe** setting provides the optimizer with a universe of securities from which to purchase. Any portfolio within the database could be selected as the source of new stock selection; however, the S&P 500 is the ideal candidate because our benchmark is the S&P 500.

The following window displays:

![Figure 58: Settings: Constraints Tab](image)

*The universe portfolio has been set to the S&P 500.*

6. Click **OK** to save and close the **Settings** window.

7. Select **Actions > Optimize**, or click ![ ] on the toolbar.

8. After optimization is complete, in the navigation tree open (double-click) the **Portfolio** folder, then select **Executive Summary (F2)**, or press F2.
The following window displays:

![Executive Summary View: Optimized BoC2002 Portfolio Using Constraints](image)

**Figure 59: Executive Summary View: Optimized BoC2002 Portfolio Using Constraints**

The Executive Summary indicates some increase in Total Risk, at 15.03. Active Risk was reduced only to 3.39, as compared to 2.91 when no restrictions were placed on the optimization. Although the reductions were not as high as the previous optimization, this optimization has a lower turnover rate at 14.35%. With a $500 million portfolio, the reduction in turnover means a significant saving in transaction costs.

Next, we will look at the trades.

9 Close the **Executive Summary** window.
In the navigation tree, open (double-click) the **Trade List** subfolder, and select **All Trades**. Highlight the **Initial Shares** column and click **$** in the toolbar.

The following window displays:

![Figure 60: Trade List for Optimized Portfolio](image)

In this scenario, the optimizer conducted 18 trades with just over $1 million in transaction costs (to view a summary, select the **Transaction Summary** in the **Trade List** subfolder). Starting from the top of the list, stocks from E-Bay to LX Capital were added, while stock from National Semiconductor through AOL Time Warner were sold. Do these transactions reflect our new portfolio manager’s investment preference? Let’s investigate further.

In the navigation tree, open (double-click) the **Exposures** folder, then select **Risk Index**.

The following window displays:
The exposure to the Growth factor is 0.250 relative to the benchmark, which was a preference of our new manager, who likes to have more exposure to growth stocks.

**Explore Further**

Run a similar exercise using the penalty option with the 25 basis points preference. The result may not reach the desired deviation, but it should deliver a better utility or lower risk.

**Note:** An Aegis optimizer constraint is set as an absolute value, whereas a penalty is set relative to utility maximization. Using the example in this exercise, if an optimized portfolio has a constraint of Growth factor plus 25 basis points, then the optimization results must show at least 25 basis points of such deviation. If the penalties Growth factor option were used instead, the optimizer would find the least deviation from 25 basis points while maximizing overall utility; the result may or may not reach the desired 25-basis-point deviation.
Exercise 3.3: Optimization with Expected Returns

Before You Begin

In the previous exercises in this case study, we considered several inputs to the utility function: risk, transaction costs, and constraints. However, to fully maximize utility, an investor must achieve a balance among cost, risk, and return. In this exercise we explore the last component in optimization—expected returns.

To examine the risk and return profile of our BoC2002 portfolio, we will use a set of pre-generated returns from a spreadsheet, provided with the Barra On Campus software. Steps 1 and 2 in this exercise will process these returns into data that are usable for by the Aegis system.

If continuing from the previous exercise, close all open portfolios without saving them.

Steps

1. Select Data > Import User Data, and navigate to the Aegis\userdata folder. Change File of Type drop-down menu to Worksheets and open BoC2002.XLS.

2. Click Process.

   Aegis Portfolio Manager processes the spreadsheet of returns.

3. Click OK.

   The Summary: Custom Data Processing window closes.

4. Open the BoC2002 portfolio.

5. Select Portfolio > Settings or click ☰ in the toolbar. In the General tab, ensure that the benchmark is set to SAP500.
Open the **Expected Returns** tab. Click the button to the right of **Return Source** field, then locate and select **Alpha**; and in the drop-down menu under **Return Type**, select **Active**.

The following window displays:

![Settings Window: Expected Returns Tab](image)

Return types represent different expressions of the expected return: **Total** is the total asset return; **Active** is the return net of the benchmark return; **Excess** is the return in excess of the risk-free rate; **Residual** represents return net of the market return (beta times expected market return); **Exceptional** reflects the return over and above asset return attributable to the market risk premium.

Click **OK**.
8 Set the transaction cost and growth constraints, and investable universe parameters to match those used in the previous exercise, then optimize the portfolio. (Repeat Step 1 through Step 7 starting on page 56).

9 After the optimization is complete, in the navigation tree open (double-click) the Portfolio folder, then select Executive Summary (F2), or press F2.

The following window displays:

![Figure 63: Executive Summary After Optimization Using Expected Returns](image)

Figure 63: Executive Summary After Optimization Using Expected Returns
Note: Compared to our last optimization (see Figure 59 on page 59), this optimization has a much higher turnover ratio. Also, transaction costs are significantly higher; for this scenario the optimizer conducted 51 trades with just over $7 million in transaction costs (to view a summary, select the Transaction Summary in the Trade List subfolder). Close the Executive Summary window, and examine the trades by opening the Trade List folder and selecting All Trades.

With expected returns included, the optimizer became very aggressive in purchasing stocks with high expected returns and selling those without. This may not be ideal for more risk-averse investors. (For the impact of risk aversion in the mathematical definition of utility, see Equation 14 on page 92.) Aegis Portfolio Manager enables investment professionals to set their preferred risk aversion for use in optimization; in this exercise we use a standard risk aversion figure.

Explore Further

Experiment with other settings and generate different optimizations for the BoC2002 portfolio.

Note: In Portfolio > Settings: Risk tab, you can view the risk aversion ratio. The default risk aversion ratio is 1.0000, which yields a risk aversion value of 0.0075. Barra has arrived at the default by determining the level of risk aversion that would lead an investor to choose 100% equity in a trade-off between cash and an investment in a market portfolio. This level of risk aversion does not capture the typical trade-off for most active managers.

You can increase or decrease the risk aversion and reoptimize to see how it affects the results. Since our BoC2002 is a relatively conservative Large-Cap portfolio from the S&P 100, lower risk aversion will encourage higher turnover to purchase riskier stocks with higher expected return.
Exercise 3.4: Generating an Efficient Frontier

Before You Begin

The optimizer enables you to generate an efficient frontier with a given portfolio and set of preferences. An efficient frontier is a set of optimal portfolios at differing levels of return and variance. Each portfolio on the frontier offers the highest possible expected return at its level of variance, and the lowest possible variance at its level of expected return.

The efficient frontier can be generated for any user portfolio in Aegis Portfolio Manager; however, pricing information will come from the cut-off day of this edition of Barra on Campus, which is August 30, 2002.

Close any open windows from the previous optimization without saving changes.

Steps

1. Open the BoC2002 portfolio.
   - Note: If portfolio settings were changed by individual users in the last exercise, the efficient frontier generated in this exercise will look different. (To reset the settings to those used previously, repeat Step 1 through Step 6 starting on page 56 before continuing.)

2. Select Portfolio > Settings or click in the toolbar, click the Optimize tab, and click the Frontier radio button.
The default settings are **Risk-Return Frontier** with 40 maximum points to construct the efficient frontier (see Figure 64 below). Each point represents an optimized portfolio with a different risk and return trade-off.

3. Click **OK**.

4. Optimize by selecting **Actions > Optimize**, or click ![Optimize button](image) on the toolbar.

Aegis Portfolio Manager generates the frontier.

- **Note**: Networks or computers with limited memory and other resources may take longer to generate the frontier. If the calculation causes a system crash, you can try optimizing again using a lower maximum number of points.
At the end of the calculation, the following window displays:

![Parametric Optimization Curve](image)

The maroon-colored dot in the graph in Figure 65 (the diamond-shaped dot near 3.2 on the x-axis) represents our starting point, the BoC2002 portfolio. Aegis generated 40 portfolios with higher return or lower risk. To examine the portfolio summary and transaction costs of one of the optimized portfolios on the efficient frontier, click a row number in the lower window.
Summary

In this case study we covered various functions of the Aegis optimizer and conducted optimization with and without constraints on costs, preference, and addition of stocks. The construction of the efficient frontier also graphically demonstrates the very essence of the benefit of optimization.