# Table of Contents

## Chapter 1  The Barra Aegis System  .............................................. 1

- Introducing the Barra Aegis System .............................................. 2
- About this Guide ............................................................................. 3
- Other Sources of Information ......................................................... 4
- Contacting Us ................................................................................. 4

## Chapter 2  Aegis Portfolio Manager ................................................. 7

- Introducing the Aegis Portfolio Manager .......................................... 8
  - Many Ways to Use Portfolio Manager ............................................. 8
  - What is in this Chapter ................................................................. 9
- Creating Risk Reports ...................................................................... 10
  - Step 1: Format Portfolio Files .................................................... 10
  - Step 2: Select a Model and Pricing Date ...................................... 12
  - Step 3: Open your Portfolio ........................................................ 14
  - Step 4: Select a Benchmark ......................................................... 16
  - Step 5: Work with Reports .......................................................... 20
- Analyzing your Portfolio’s Risk ....................................................... 23
  - Executive Summary: What Is the Risk? The Anticipated Tracking Error? .................................................... 24
  - Risk Decomposition: What Are the Largest Contributors to Risk? ......................................................... 26
Risk Index Exposures vs. MCAR:
  Are Style Characteristics in Line
  with the Benchmark? ...........................................28
Industry Exposures: Are Industry Weights in Line
  with the Benchmark? .............................................30
Country Exposures: Are Country Weights in Line
  with the Benchmark? .............................................32
Market Risk Exposures: Which Countries Contribute
  Most to Risk? ....................................................34
Marginal Contribution to Asset Selection Risk:
  Which Assets Contribute Most to
  Asset Selection Risk? ............................................36
Deciding Which Assets to Trade .........................38
  Simulating Trades ..............................................38
  Viewing the Trades ...........................................40
  Viewing the Impact of the Trades .......................41
Optimizing your Portfolio .................................42
  Types of Optimizations .......................................43
  Overview of Bounds, Constraints, and Penalties to
    Impose on an Optimization .................................44
  Setting Bounds ..................................................46
  Executing the Optimization .................................47
Other Useful Features ........................................48
  Customizing your Workspace ...............................49
  Changing Properties of Reports ...........................50
  Saving Favorite Reports .....................................51
  Printing Reports ...............................................52
  Importing your Data to Use in an Analysis ...........53
## Chapter 3  
*Aegis Performance Analyst* ................................. 57

- Introducing Performance Analyst .......................... 58
- What is in this Chapter ......................................... 59
- Creating Performance Reports .............................. 60
  - Step 1: Prepare your Portfolios and Accounting Returns .......................... 60
  - Step 2: Create an Attribution Data Source ............................... 62
  - Step 3: Set Up the Analysis ....................................... 66
  - Step 4: View the Reports ......................................... 68
- Analyzing your Portfolio’s Return ........................... 71
  - How Can I Interpret an Attribution Report? .................. 71
  - How Can I Graph my Cumulative Results Over Time? ........... 73
  - Which Styles Affected Performance? ......................... 75
  - How Can I Review the Timing of my Style Policies? ...... 77
  - Which Assets Contributed Most to Performance? ........... 78
- Understanding Return ........................................... 79
  - Active Return Breakdown for Different Models ............... 79
  - Time Frames for Reporting Return ............................ 87
- Other Useful Features ........................................... 88
  - Customizing Reports ........................................... 89
  - Importing Accounting Returns and Transaction Costs. .... 90

## Chapter 4  
*Aegis Portfolio Accountant* ................................. 95

- Introducing Aegis Portfolio Accountant ..................... 96
- Basic Steps to Run Portfolio Accountant 83
- Creating or Opening a Portfolio Database .................. 97
- Importing Records from Source Files ........................ 100
  - Importing Barra-Defined Source Files ......................... 101
  - Importing User-Defined Source Files ......................... 102
Entering/Changing Records Directly .......................106
Creating an After-Tax Portfolio Database ..................107
Updating Multiple Portfolio Databases from a Single File .108
Updating Portfolio Databases in Bulk ....................109
Viewing the Records in a Portfolio Database ..............112
   Viewing All Records for a Specific Date ..............112
   Narrowing the Scope ..................................112
   Searching for a Particular Asset in the Database ......113
   Scrolling Through the Records by Date ...............114
   Viewing All Dates in the Portfolio Database ..........114
   Viewing the Entry Log ..................................115
Generating Reports from a Portfolio Database ..........116
   Viewing Calculated Holdings as of a Particular Date .117
   Viewing Trades Between Specified Dates ...............117
   Viewing a Reconciliation Report ......................118
   Viewing Tax Lots ..................................119
Managing your Mapping Cases .............................120
Setting Portfolio Accountant Preferences .................123
   General Tab ........................................123
   Import Tab ........................................124
   Columns Tab ......................................125
   Date Tab ..........................................126
   Number Tab ......................................126
   Cash Tab ..........................................127
   Reject Tab ........................................127
Portfolio Accountant Menus ................................128
Field Requirements for your Source Files .................130
   For Trades .......................................130
   For Holdings ....................................131
Chapter 6  Aegis DataConnect .......................... 185
  Introducing Aegis DataConnect ................. 186
    Before you Begin ................................ 187
  Step 1: Create a New Job ......................... 187
    Creating an Job that Imports Portfolio/Index Data into Aegis ......................... 187
    Creating a Job that Imports Industry Classifications into Aegis ...................... 189
    Creating a Job that Imports User Data into Aegis .................................. 191
  Step 2: Schedule your Job ......................... 193
  Step 3: Check the Status of Your Job .......... 194

Appendix .............................................. 197
  Asset Identifier Types and Model Codes .... 198
  Weight Codes ....................................... 200
  Numeraire Codes ................................... 201

Glossary ............................................. 203

Index .................................................. 219
Chapter 1

The Barra Aegis System

• Introducing the Barra Aegis System

• About this Guide

• Other Sources of Information
Introducing the Barra Aegis System

The Barra Aegis System™ offers a powerful suite of integrated tools to help you analyze your equity portfolios and make superior investment decisions. Here’s what the Aegis Suite includes:

- **Portfolio Manager**—A comprehensive risk analysis and optimization tool that helps you construct portfolios, analyze their risk profiles including Value-at-Risk or Return-at-Risk, view the effect of any position on portfolio risk, incorporate predicted returns and transaction costs into utility assessment, and determine optimal trades.

- **Performance Analyst**—A performance analysis system that calculates and attributes portfolio performance to specific investment policies over time, including the contributions of country and currency selection, industries or sectors, styles, market timing, and individual assets.

- **Portfolio Accountant**—A utility for importing your accounting system files into time-dimensional portfolio databases which can be accessed directly by Portfolio Manager, Performance Analyst, Automation Assistant, and Developer’s Toolkit.

- **Automation Assistant**—An application that lets you automate routine or recurring tasks in Portfolio Manager (generating risk reports, optimizations, and multiple portfolio comparisons) and schedule them to run at your convenience.

- **DataConnect**—A utility that helps you to integrate your data flow into Aegis. It automates the transformation and import of your portfolio/index data, industries, and user data into Aegis.

- **Update Scheduler**—A tool that allows users of Aegis Portfolio Manager and Aegis Performance Analyst to schedule data updates using the existing BarraLink system.

- **Developer’s Toolkit**—A programming tool that lets your developers access Barra’s equity analytical code directly, so they can integrate it into your own custom applications, create high-volume batch processes for risk/performance analysis and optimization, and produce custom reports tailored to your organization’s specific needs.
About this Guide

This Getting Started Guide introduces the major functions of the Aegis Suite and will help you get started using its components. You can find additional information in Aegis’ online help, accessible through the Help menu of the Aegis programs.

Here’s what the Getting Started Guide contains:

- **Chapter 2, “Aegis Portfolio Manager”:** Analyze your portfolio’s risk, screen the database to build your desired asset list, and optimize according to your specifications.

- **Chapter 3, “Aegis Performance Analyst”:** Build a performance database and generate a wide range of reports to assess your portfolio’s performance.

- **Chapter 4, “Aegis Portfolio Accountant”:** Create databases of holdings and trade records for all your portfolios over time, including data imported from your accounting system.

- **Chapter 5, “Aegis Automation Assistant”:** Specify the reports, optimizations, multiple portfolio comparisons, and portfolio database updates you want and schedule them to run automatically.

- **Chapter 6, “Aegis DataConnect”:** Create jobs that can automatically import your data into Aegis on a regular schedule.

- The “Glossary” on page 203 defines commonly used Aegis terms.
Other Sources of Information

- The online help system contains detailed information about each Aegis application.
- The *Installation and Technical Guide* provides information about installing the Aegis software and scheduling data updates.
- The *Model Reference Guide* provides basic information about the single-country and global equity risk models available in Aegis. It is available from *Windows Start > Programs > Barra Aegis System > Model Reference Guide* and the Aegis website.
- The Aegis *Developer's Toolkit Reference Guide* is available in your ADT program directory and on the Aegis website.
- On the Aegis website, at [http://aegis.barra.com](http://aegis.barra.com), you’ll also find the latest Aegis support information, answers to frequently asked questions, tips for advanced users, model details, late-breaking news, and more.
- The client support website [http://support.barra.com](http://support.barra.com) contains useful information including tutorials, Barra telephone numbers, and links to downloads.

Contacting Us

If you have questions about the installation process, or any support question relating to Barra products, please contact a support representative in your area, listed in the tables on page 5.

Also, we welcome your feedback about this publication. You can send comments to mscibarra_tw@mscibarra.com. Please put “Aegis” in the subject line.
# Direct Regional Numbers

<table>
<thead>
<tr>
<th>Region</th>
<th>Phone Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America</td>
<td>(510) 649-6400</td>
</tr>
<tr>
<td>Europe</td>
<td>+44 (0)20 7618 2222</td>
</tr>
<tr>
<td>Asia (Japanese)</td>
<td>+81-3-5402-4150</td>
</tr>
<tr>
<td>Asia (English)</td>
<td>+81-3-5402-4151</td>
</tr>
</tbody>
</table>

# Worldwide Free Access Numbers

<table>
<thead>
<tr>
<th>Region</th>
<th>Country</th>
<th>Phone Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America</td>
<td>US &amp; Canada</td>
<td>(888) 588-4567</td>
</tr>
<tr>
<td>Europe</td>
<td>Belgium</td>
<td>0800.77526</td>
</tr>
<tr>
<td></td>
<td>Denmark</td>
<td>808.82981</td>
</tr>
<tr>
<td></td>
<td>Finland</td>
<td>0800.119556</td>
</tr>
<tr>
<td></td>
<td>France</td>
<td>0800.91.59.17</td>
</tr>
<tr>
<td></td>
<td>Germany</td>
<td>0800.250.7948</td>
</tr>
<tr>
<td></td>
<td>Greece</td>
<td>00800.125.368</td>
</tr>
<tr>
<td></td>
<td>Republic of Ireland</td>
<td>1800.557.476</td>
</tr>
<tr>
<td></td>
<td>Italy</td>
<td>800.87.68.87</td>
</tr>
<tr>
<td></td>
<td>Luxembourg</td>
<td>0800.29349</td>
</tr>
<tr>
<td></td>
<td>The Netherlands</td>
<td>0800.023.2036</td>
</tr>
<tr>
<td></td>
<td>Norway</td>
<td>800.15.708</td>
</tr>
<tr>
<td></td>
<td>Spain</td>
<td>900.99.1848</td>
</tr>
<tr>
<td></td>
<td>Sweden</td>
<td>0207.96787</td>
</tr>
<tr>
<td></td>
<td>Switzerland</td>
<td>0800.894.703</td>
</tr>
<tr>
<td>Region</td>
<td>Country</td>
<td>Phone Number</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>Asia</td>
<td>China</td>
<td>10800-852-0717</td>
</tr>
<tr>
<td></td>
<td>Hong Kong</td>
<td>001-800-2536-2929</td>
</tr>
<tr>
<td></td>
<td>India</td>
<td>000800-810-1109</td>
</tr>
<tr>
<td></td>
<td>Indonesia</td>
<td>001.803.852.3194</td>
</tr>
<tr>
<td></td>
<td>Malaysia</td>
<td>00-800-2536-2929</td>
</tr>
<tr>
<td></td>
<td>South Korea</td>
<td>001-800-2536-2929</td>
</tr>
<tr>
<td></td>
<td>Singapore</td>
<td>001-800-2536-2929</td>
</tr>
<tr>
<td></td>
<td>Taiwan</td>
<td>0080.855.280</td>
</tr>
<tr>
<td></td>
<td>Thailand</td>
<td>001-800-2536-292</td>
</tr>
</tbody>
</table>
Chapter 2

Aegis Portfolio Manager

- Introducing the Aegis Portfolio Manager
- Creating Risk Reports
- Analyzing your Portfolio’s Risk
- Deciding Which Assets to Trade
- Optimizing your Portfolio
- Other Useful Features
Introducing the Aegis Portfolio Manager

The Barra Aegis Portfolio Manager is a comprehensive, Windows®-based portfolio risk analysis and optimization tool for equity portfolio managers. Portfolio Manager provides a flexible, adaptable framework designed to support the decision-making processes of and portfolio construction for managers investing in equity securities and their derivatives.

Many Ways to Use Portfolio Manager

You can use Portfolio Manager to:

- **Analyze portfolio risk.** Explore the risk characteristics of your portfolio, including its predicted beta, exposure to style and industry risk factors, and active risk with respect to a benchmark you specify.

- **Analyze multiple portfolios.** Compare the risk profiles of up to 200 accounts at once and view their forecast correlations.

- **Test different investment scenarios.** Examine the effects that trades might have on your portfolio’s risk characteristics. View the assets you could buy or sell to improve the portfolio’s risk profile.

- **Determine optimal trades.** Use Portfolio Manager’s optimizer to determine the trades that maximize expected return per unit of risk.

- **Check your intuition.** See if the expected returns of the assets you hold, as implied by their weights and risk, agree with your own ranking.

- **Find substitute assets.** Find highly correlated substitutes for assets you can’t hold.

- ** Include your own data, options and index futures.** Define and use your own variables, create call or put options linked to individual securities, and include index futures in your portfolios.

- **Hedge market risk.** Find the optimal combination of index futures to fully hedge the market risk of your portfolio.

- **Screen an asset universe.** Select only those stocks that meet a set of criteria.
• **Customize the asset database.** Add assets that are not in the database that Barra provides, or modify assets to suit your insights.

• **Save your favorite reports.** Saving customized reports to your Favorites folder gives you quick access to frequently used reports and makes these reports available to run automatically from Aegis Automation Assistant.

**What is in this Chapter**

This chapter introduces the basic concepts needed to get started in Portfolio Manager.

▷ **Note:** You should use this chapter after you have installed your Aegis software, permission file, and data. You should also have mapped to your data. See the *Aegis Installation and Technical Guide* for assistance.

The basic steps to get started are:

• Creating reports (page 10), including getting holdings into Portfolio Manager and selecting a benchmark.

• Analyzing the portfolio’s risk (page 23), looking at various reports to understand the source of risk in the portfolio.

• Deciding which assets to trade (page 38), introducing the Simulate Trade feature and showing the impact of trades on your portfolio.

• Optimizing the portfolio (page 42), introducing the Optimizer.

• Other features (page 48), such as customizing your workspace, working with reports, and importing user data.

We use a simple example to guide you through the basic steps.
Creating Risk Reports

Step 1: Format Portfolio Files

If you have a portfolio that you would like to analyze with Portfolio Manager, simply supply a file with identifiers and shares, and a one-character code to indicate the identifier type, as in the example on the next page.

As long as you follow the formatting procedures on the next page, Portfolio Manager reads portfolio holdings from files of many file types, including:

- worksheet (.xls)
- database (.dbf)
- text (.inp, .txt, .tab, .prn)
- comma-separated (.csv)

Tip: If your holdings are not readily available in one of the formats listed above, you can use Aegis Portfolio Accountant to import files from your accounting system or other sources directly into portfolio databases (see page 96). Alternatively, you can automate the transformation and import of your portfolio/index data, industries, and user data into Aegis using DataConnect (see page 185).

For details, see this help topic:

- Format a Portfolio File
A sample portfolio file looks like this:

Under the headers, Column A contains asset IDs. For this global portfolio we are using SEDOLs.

Column B indicates the type of asset ID entered in column A. In this case, we entered “S,” because that is the code for SEDOL in the MS Equity model.

For a list of identifier types by model, see page 198.

Header rows tell Portfolio Manager which model to use to open the portfolio, which weighting scheme to apply, and the date of the holdings.

In this case, we indicated that our portfolio should be:

- opened with the MS Equity Model
- share weighted
- as of the last trading day in March 2003

(See page 198 for model and weight codes.)
Step 2: Select a Model and Pricing Date

Now that we have our portfolio ready, we can launch Portfolio Manager and select a risk model and price date for our analysis.

What is a risk model? Barra risk models are central to portfolio analysis. They capture various components of risk and provide a multifaceted, quantitative measure of exposures to risk. Barra provides risk models by country (i.e., United Kingdom), by region (i.e., Europe), and two global models (MS and FT).

---

To do this, select one of the following:

- Data > Select Model and Dates
- F3

For details, see this help topic:

- Selecting a Risk Model

---
For our analysis, we have selected the Morgan Stanley version of the Global Equity Model (MS Global Equity).

Our holdings will be analyzed as of the end of March 2003.

Tip: If you scroll to the top of this list, the first entry is Latest. Select Latest to have portfolios always open with the most recent model date available in your database.

Our MS Global Equity data resides in this location. This is also where any Barra-supplied portfolios can be found.

Each month begins with the last trading day of the preceding month.
Step 3: Open your Portfolio

Now that we have formatted our portfolio file and selected the model and pricing date with which to analyze the portfolio, we are ready to view the portfolio in the Portfolio Manager workspace.

※ Tip: You do not need to import the portfolio file. Simply open it in Portfolio Manager.

Portfolio Manager Workspace

The workspace is where all of the assets in your portfolio are listed, along with their IDs and any other variables you would like to add.

All reports in Portfolio Manager are based on the portfolio you have loaded in the workspace.

______________________________
To do this, select one of the following:

  • File > Open Portfolio
  • Ctrl + O

For details, see this help topic:

  • Opening a Portfolio

______________________________
When you are looking at reports, you can click the Workspace icon to return to this workspace.

The selected numeraire indicates the currency perspective in which your portfolio is valued and from which portfolio risk is calculated. (This is available for multi-country models only.

Select the asset ID type to display here.

The status bar supplies basic information about your portfolio, such as the total value, the model, and the price date.

A tab is available for every portfolio you have open.
Step 4: Select a Benchmark

When you analyze the risk of a portfolio, it is useful to compare your results to a benchmark or market portfolio. We call these “reference portfolios” in Aegis.

What is the difference between the benchmark and market portfolios?

The market portfolio represents the overall movement and direction of the country’s stock market. You would specify a market portfolio to evaluate market timing or beta policy, for example.

The benchmark is the portfolio that you would like to compare your own portfolio to. It is the portfolio against which your performance is being measured.

You can select any portfolio covered by the model (such as an index) or a cash (risk-free) portfolio. If you do not specify a particular portfolio, “cash” is selected by default.

To do this, select either:

- Portfolio > Settings > General tab
- > General tab

For details, see this help topic:

- How Do I Set a Benchmark?
1. To select a benchmark other than cash, click the Select button.

2. Click the Add Benchmark button to add portfolios to the list of available benchmarks.
To have a portfolio available to select as a benchmark, it must first be processed as a composite asset (a portfolio of assets that acts as one asset).

**Tip:** You can also add any portfolio processed in this dialog as a composite asset to your portfolio.

1. Click the Add File button and select any portfolios you would like to have available as benchmarks for the selected risk model.

2. Select portfolios. You can use Ctrl+click or Shift+click to select multiple portfolios at once.

3. After you have selected the portfolios, click Open.

4. In the Composite Processor dialog, click Process.
The portfolios that we processed as composites are now available to select in the Select Benchmark dialog.

1. Highlight the benchmark portfolio and click OK. In this example, we select the MSEAFE.

2. The MSEAFE appears as the benchmark. We keep the market index as cash.

3. Click OK to return to the portfolio workspace.

Note: Availability of different benchmarks depends on your subscription with that vendor. Contact Barra for more information.
Step 5: Work with Reports

Now that we have opened our portfolio and selected a benchmark, we are ready to view reports.

Reports are available as:

- Tables
- Graphs
- Charts
- Asset workspace

For details, see this help topic:
  - About Reports
1. The upper pane shows the report explorer, which organizes reports according to the information they contain. For example, the Risk folder contains the Risk Decomposition report. When you click on a folder, the reports within that folder are listed in the lower pane.

2. Click on a report to view it.

3. The selected report appears in this area.

※ Tip: If you double-click a report, it appears in a new window.
Types of reports

Here is a snapshot of the folder navigation tree, showing how reports are organized in each folder.

- **Portfolio reports** summarize the characteristics of your portfolio.
- **Risk reports** decompose risk and display forecast return distributions.
- **Exposure reports** break down the portfolio's exposures to common factors of the model.
- **Marginal Contribution reports** rank assets by their concentrating and diversifying characteristics along different dimensions of risk.
- **Trade List reports** show the buy and sell lists when trades are made.
- **Asset Details reports** show the risk model details and other characteristics of each asset in the workspace.

You can save customized reports from any category to your Favorites folder.

For details, see this help topic:

- Report Categories
Analyzing your Portfolio’s Risk

Let’s look at a few reports in order to pinpoint the source of our portfolio’s risk. The reports can help us answer questions like this:

<table>
<thead>
<tr>
<th>To answer this question</th>
<th>See this report</th>
</tr>
</thead>
<tbody>
<tr>
<td>What is the risk? What is the tracking error?</td>
<td>Executive Summary</td>
</tr>
<tr>
<td>What are the largest contributors to risk?</td>
<td>Risk Decomposition</td>
</tr>
<tr>
<td>Are the style bets in line with the portfolio’s sources of risk?</td>
<td>Risk Index Exposures vs. MCAR</td>
</tr>
<tr>
<td>Are industry weights in line with the benchmark?</td>
<td>Industry Exposures</td>
</tr>
<tr>
<td>Are country weights in line with the benchmark?</td>
<td>Country Exposures</td>
</tr>
<tr>
<td>Which countries contribute most to risk?</td>
<td>Market Risk Exposures</td>
</tr>
<tr>
<td>Which assets contribute most to asset selection risk?</td>
<td>Marginal Contribution to Asset Selection Risk</td>
</tr>
</tbody>
</table>
Executive Summary: What Is the Risk? The Anticipated Tracking Error?

The Executive Summary displays the most important portfolio statistics, such as tracking error and total risk.

Note: The initial and managed portfolios are identical in this report until you make a change to your portfolio (see “Customizing your Workspace” on page 49).

---

To do this, select either:

- 📄 Portfolio > 📄 Executive Summary
- F2

For details, see this help topic:

- Generating an Executive Summary
TOTAL RISK: The forecasted total risk for this portfolio is given as an annualized standard deviation of the portfolio’s total returns. If we assume returns follow a normal distribution, there is a two-thirds probability that the portfolio will come within 16.34% of its expected value.

TRACKING ERROR: The managed portfolio’s active risk, or tracking error, versus the Morgan Stanley Europe Australia Far East index (the benchmark we selected on page 16) is 6.53%. With no active return expectations set, there is a two-thirds probability that the portfolio will deviate from the benchmark by +/- 6.53% over the next year.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>EXECUTIVE SUMMARY</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Portfolio Statistics</td>
<td>Initial Portfolio</td>
<td>Managed Portfolio</td>
<td>Change</td>
</tr>
<tr>
<td>Total Risk</td>
<td>16.34</td>
<td>16.34</td>
<td>0.00</td>
</tr>
<tr>
<td>Active Risk</td>
<td>6.53</td>
<td>6.53</td>
<td>0.00</td>
</tr>
<tr>
<td>Active-return-at-risk (%)</td>
<td>-10.71</td>
<td>-10.71</td>
<td>0.00</td>
</tr>
<tr>
<td>Active-return-at-risk (Value)</td>
<td>-115,728,952.06</td>
<td>-115,728,952.06</td>
<td>0.00</td>
</tr>
<tr>
<td>Probability Level (%)</td>
<td>5.00</td>
<td>5.00</td>
<td>N/A</td>
</tr>
<tr>
<td>Predicted Beta</td>
<td>0.92</td>
<td>0.92</td>
<td>0.00</td>
</tr>
<tr>
<td>Active Predicted Beta</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Coefficient of Determination</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Active Coefficient of Determination</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Implied Information Ratio</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Turnover</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
</tbody>
</table>

ACTIVE RETURN AT RISK: Active Return-at-Risk gives a worst-case scenario for the portfolio’s performance. There is a 5% probability that the portfolio will underperform the benchmark by more than 10.71%. (You can change the probability level in the Portfolio > Settings > Risk dialog.)

BETA: The portfolio’s beta is given with respect to the benchmark selected. This is a fundamental beta derived from the underlying multiple factor model rather than the traditional 60-month regression.

All return fields under the Objective Summary remain empty until you supply expected returns (see “Importing your Data to Use in an Analysis” on page 53).
Risk Decomposition: What Are the Largest Contributors to Risk?

While the Executive Summary shows overall risk numbers for your portfolio, the Risk Decomposition report breaks risk down into its components, so you can determine which parts of your investment strategy comprise the largest sources of active risk.

Displaying the report as a chart lets you clearly see how components of risk are broken into other components. You can also view it as a table or graph.

The components of risk are shown in terms of standard deviation and variance-weighted percent of active risk.

To do this, select:

- Risk > Risk Decomposition Chart

For details, see this help topic:

- Decomposing Risk
ACTIVE RISK (TRACKING ERROR) consists of market timing risk, common factor risk, and asset selection risk.

Active risk arises from bets made relative to the benchmark portfolio. As we saw in the Executive Summary (page 24), our active risk versus our benchmark is 6.53%.

MARKET TIMING RISK is caused by beta differences between the portfolio and its market. Since no market portfolio has been selected (we kept it as cash on page 19), market timing risk is zero.

ASSET SELECTION RISK is due to each security’s intrinsic risk. In our example, asset selection risk contributes most to our portfolio’s risk.

COMMON FACTOR RISK is caused by factors found throughout the market.

Contributions to active risk are found by dividing the variance of each source by the variance of active risk.

The Covariance term captures the covariance across groups of factor returns. Here the negative value shows that the risks of each type of common factor bet diversify one another.

Note: Country and Currency nodes are not available for single-country models.
Risk Index Exposures vs. MCAR: Are Style Characteristics in Line with the Benchmark?

Now we can view different reports to drill down and better understand the sources of active risk.

We can see from the Risk Decomposition report on page 27 that, in our example, risk arising from risk indices (styles) comprises 3.17% of the active risk of the portfolio.

Note: The list of risk indices (styles) varies by model. For more information about risk indices by model, see the Aegis Model Reference Guide.

If we look at our style exposures versus the marginal contribution to active risk (MCAR), we can see which style characteristics of our portfolio differ from the benchmark, and which are most impacting the portfolio’s risk.

What is the difference between active exposures and MCAR? Active exposures show us what is the difference between our portfolio and the benchmark, while MCAR shows us what difference is the riskiest.

To do this, select:

- Exposures > Active Risk Index Exposures vs. MCAR Graph
The assets held in the portfolio have a smaller capitalization (Size) than the ones in the benchmark index.

Marginal Contribution to Active Risk (MCAR) describes the effect that a small increase (0.01) in exposure would have on the portfolio’s active risk. We are about as sensitive to the underexposure in Size (a capitalization factor) as we are to the overexposure in Variability in Markets (a volatility-related factor).

The portfolio has a higher exposure to Value than the benchmark index, which means the portfolio emphasizes less expensive assets than the benchmark.
Industry Exposures: Are Industry Weights in Line with the Benchmark?

We can see from the Risk Decomposition report on page 27 that, in our example, risk arising from industries comprises 10.21% of the active risk of the portfolio.

If we look at our industry exposures, we can see how our industry weights compare to the benchmark.

To do this, select:

- Exposures > Industry
Industry weights are given as percentages of the portfolio’s value. Our portfolio has a 14.25% weight in Beverages & Tobacco.

Here relative exposures measure the difference between the portfolio and the benchmark exposures, or the active weight in each industry. (If we had selected a Market, this number would be beta-adjusted). The largest relative overweight is in the Forestry & Paper Products industry.

<table>
<thead>
<tr>
<th>Industry</th>
<th>Managed</th>
<th>Benchmark</th>
<th>Relative</th>
<th>MC to Risk</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forestry &amp; Paper Products</td>
<td>13.50</td>
<td>0.72</td>
<td>12.77</td>
<td>0.08</td>
</tr>
<tr>
<td>Beverages &amp; Tobacco</td>
<td>14.25</td>
<td>2.53</td>
<td>11.72</td>
<td>0.02</td>
</tr>
<tr>
<td>Automobiles</td>
<td>3.96</td>
<td>2.88</td>
<td>1.07</td>
<td>0.01</td>
</tr>
<tr>
<td>Electronic Components &amp; Instruments</td>
<td>4.00</td>
<td>2.98</td>
<td>1.02</td>
<td>-0.01</td>
</tr>
<tr>
<td>Metals-Non Ferrous</td>
<td>1.74</td>
<td>1.24</td>
<td>0.50</td>
<td>0.06</td>
</tr>
<tr>
<td>Multi-Industry</td>
<td>1.72</td>
<td>1.23</td>
<td>0.49</td>
<td>0.00</td>
</tr>
<tr>
<td>Leisure &amp; Tourism</td>
<td>1.39</td>
<td>1.07</td>
<td>0.31</td>
<td>0.01</td>
</tr>
<tr>
<td>Metals-Steel</td>
<td>0.83</td>
<td>0.52</td>
<td>0.31</td>
<td>0.05</td>
</tr>
<tr>
<td>Transportation-Shipping</td>
<td>0.58</td>
<td>0.30</td>
<td>0.29</td>
<td>0.01</td>
</tr>
<tr>
<td>Gold Mines</td>
<td>0.00</td>
<td>0.03</td>
<td>-0.03</td>
<td>0.10</td>
</tr>
<tr>
<td>Wholesale and International Trade</td>
<td>0.56</td>
<td>0.61</td>
<td>-0.05</td>
<td>0.02</td>
</tr>
<tr>
<td>Energy Equipment &amp; Services</td>
<td>0.00</td>
<td>0.06</td>
<td>-0.06</td>
<td>0.03</td>
</tr>
<tr>
<td>Misc. Materials &amp; Commodities</td>
<td>0.00</td>
<td>0.09</td>
<td>-0.09</td>
<td>0.00</td>
</tr>
<tr>
<td>Data Processing &amp; Reproduction</td>
<td>0.00</td>
<td>0.14</td>
<td>-0.14</td>
<td>-0.03</td>
</tr>
<tr>
<td>Construction &amp; Housing</td>
<td>0.69</td>
<td>0.85</td>
<td>-0.16</td>
<td>0.03</td>
</tr>
</tbody>
</table>

The marginal contributions to risk for industries measure the effect of a 1% increase in the industry’s weight, holding all else constant. If we increase our exposure by 1% in Automobiles, our risk increases by 1 basis point. However, if we increase our exposure in Electronic Components & Instruments by 1%, our risk decreases by the same amount.
Country Exposures: Are Country Weights in Line with the Benchmark?

We can see from the Risk Decomposition report on page 27 that, in our example, risk arising from countries comprises 13.16% of the active risk of the portfolio.

If we look at our country equity exposures, we can see how our country equity weights compare to the benchmark.

▶ **Note**: Country exposures are not available in single-country models.

---

**To do this, select**:

- Exposures > Country Equity Graph
Look at the Relative bar (third bar) to see where your portfolio is over or underweight compared to the benchmark. This graph shows the portfolio’s largest overweighting as Finland and the largest underweighting as the United Kingdom.
Market Risk Exposures: Which Countries Contribute Most to Risk?

The market risk exposures, just like risk index, industry, and currency exposures, contribute to portfolio-level risk. In the risk decomposition chart on page 27, the country risk number is derived from market risk exposures.

Because market risk exposures for an asset are its historical beta relative to a local index, risk exposure for a market indicates the market’s sensitivity to the local market in the portfolio. (Market risk exposures are a percentage of equity weight in a country, as shown on page 32, scaled by a weighted sum of the historical betas.)

Note: Market risk exposures are not available in single-country models.

To do this, select:

- Exposures > Market Risk
We are nearly twice as sensitive to the overweight in Spain as we are to the underweight in Australia.

<table>
<thead>
<tr>
<th>Market Risk</th>
<th>Managed</th>
<th>Benchmark</th>
<th>Relative MC to Risk</th>
</tr>
</thead>
<tbody>
<tr>
<td>Japan Mkt</td>
<td>0.25</td>
<td>0.21</td>
<td>0.04</td>
</tr>
<tr>
<td>United Kingdom Mkt</td>
<td>0.17</td>
<td>0.28</td>
<td>-0.10</td>
</tr>
<tr>
<td>Switzerland Mkt</td>
<td>0.08</td>
<td>0.08</td>
<td>0.00</td>
</tr>
<tr>
<td>France Mkt</td>
<td>0.07</td>
<td>0.09</td>
<td>-0.02</td>
</tr>
<tr>
<td>Finland Mkt</td>
<td>0.07</td>
<td>0.02</td>
<td>0.05</td>
</tr>
<tr>
<td>Spain Mkt</td>
<td>0.05</td>
<td>0.04</td>
<td>0.01</td>
</tr>
<tr>
<td>Germany Mkt</td>
<td>0.05</td>
<td>0.06</td>
<td>-0.01</td>
</tr>
<tr>
<td>Netherlands Mkt</td>
<td>0.04</td>
<td>0.05</td>
<td>-0.01</td>
</tr>
<tr>
<td>Australia Mkt</td>
<td>0.03</td>
<td>0.05</td>
<td>-0.02</td>
</tr>
<tr>
<td>Italy Mkt</td>
<td>0.03</td>
<td>0.04</td>
<td>-0.01</td>
</tr>
<tr>
<td>Hong Kong Mkt</td>
<td>0.02</td>
<td>0.02</td>
<td>0.00</td>
</tr>
<tr>
<td>Ireland Mkt</td>
<td>0.01</td>
<td>0.01</td>
<td>0.01</td>
</tr>
<tr>
<td>Norway Mkt</td>
<td>0.01</td>
<td>0.00</td>
<td>0.00</td>
</tr>
</tbody>
</table>
Marginal Contribution to Asset Selection Risk:
Which Assets Contribute Most to Asset Selection Risk?

We can see from the Risk Decomposition report on page 27 that, in our example, risk arising from asset selection comprises more than 75% of the active risk of the portfolio.

If we look at the Marginal Contribution to Asset Selection Risk report, we can determine which assets contribute most to asset selection risk. We can then reduce the asset selection risk in our portfolio by trading these assets.

---

To do this, select:

- Marginal Contribution > Asset Selection Risk

For details, see this help topic:

- Generating a Marginal Contribution Ranking
This report shows the top and bottom ten assets in your portfolio ranked by their marginal contribution to asset selection risk.

※ Tip: The rankings are determined by the universe of assets provided in the portfolio’s workspace. To consider additional assets as candidates for purchase, add them to the workspace with zero holdings.

The most diversifying names are the least risky positions. Purchasing an additional 1% of Shell Transport & Trading, while shorting our numeraire currency, will decrease asset selection risk by 0.01%.

The least diversifying names are the most risky positions. Selling 1% of Stora Enso and placing the balance into our numeraire currency will decrease asset selection risk by 0.35%.

<table>
<thead>
<tr>
<th>Input Id</th>
<th>Name</th>
<th>MC-AS Risk</th>
<th>Wgt%</th>
<th>Input Id</th>
<th>Name</th>
<th>MC-AS Risk</th>
<th>Wgt%</th>
</tr>
</thead>
<tbody>
<tr>
<td>080341</td>
<td>SHELL TRNSPT&amp;TRDG</td>
<td>-0.01</td>
<td>0.45</td>
<td>507267</td>
<td>STORA ENSO OYJ (FIM10)</td>
<td>0.35</td>
<td>13.27</td>
</tr>
<tr>
<td>051052</td>
<td>HSBC HOLDINGS</td>
<td>0.00</td>
<td>2.08</td>
<td>677690</td>
<td>SAPPORO BREWERIES</td>
<td>0.09</td>
<td>7.92</td>
</tr>
<tr>
<td>590254</td>
<td>NOKIA CORP</td>
<td>0.00</td>
<td>1.25</td>
<td>618628</td>
<td>COCA-COLA WEST JAPA</td>
<td>0.01</td>
<td>0.58</td>
</tr>
<tr>
<td>573252</td>
<td>TELEFONICA SA (EUR1)</td>
<td>0.00</td>
<td>1.01</td>
<td>604396</td>
<td>NIPPON YUSEN</td>
<td>0.01</td>
<td>0.58</td>
</tr>
<tr>
<td>092528</td>
<td>GLAXOSMITHKLINE</td>
<td>0.00</td>
<td>2.33</td>
<td>607064</td>
<td>BRL HARDY LIMITED</td>
<td>0.01</td>
<td>0.74</td>
</tr>
<tr>
<td>712387</td>
<td>NESTLE R</td>
<td>0.00</td>
<td>1.94</td>
<td>303454</td>
<td>WHITBREAD</td>
<td>0.01</td>
<td>0.54</td>
</tr>
<tr>
<td>679805</td>
<td>BP</td>
<td>0.00</td>
<td>3.14</td>
<td>661040</td>
<td>MURATA MFG</td>
<td>0.01</td>
<td>0.50</td>
</tr>
<tr>
<td>505125</td>
<td>UPM-KYMMENE OYJ (NF)</td>
<td>0.00</td>
<td>0.23</td>
<td>889567</td>
<td>TOKYO ELECTRON</td>
<td>0.01</td>
<td>0.34</td>
</tr>
<tr>
<td>710316</td>
<td>NOVARTIS AG RSH</td>
<td>0.00</td>
<td>2.56</td>
<td>557955</td>
<td>FORTUM OYJ (FIM20)</td>
<td>0.01</td>
<td>0.64</td>
</tr>
<tr>
<td>473601</td>
<td>AVENTIS</td>
<td>0.00</td>
<td>0.01</td>
<td>649926</td>
<td>KYOCERA</td>
<td>0.01</td>
<td>0.37</td>
</tr>
</tbody>
</table>
Deciding Which Assets to Trade

Now that we understand the sources of risk in our portfolio, we can make trades to change the portfolio’s risk. We can use the Simulate Trade feature to see, on an asset-by-asset basis, how trades will impact the risk in our portfolio.

We can try out different trading scenarios, one stock at a time, until we find the one we want. We can then have Portfolio Manager make the trade in our workspace portfolio.

▷ Note: To learn about the optimizing your entire portfolio, see page 42.

Simulating Trades

Based on our portfolio’s marginal contribution rankings on page 36, we can trade at least one diversifying asset to diversify our portfolio and lower its risk profile.

The rankings showed that trading Stora Enso would reduce asset selection risk in our portfolio. We also saw that buying Shell Transport & Trading would reduce our asset selection risk. Let’s try simulating a trade with these two assets.

To do this, select one of the following:

• highlight an asset > Actions > Simulate Trade
• highlight an asset > right-click > Simulate Trade
• highlight an asset > F8

For details, see this help topic:

• Simulating a Trade
1. The list of securities in the Trade With box is determined by the names in our workspace. We can add names with zero-share positions in our workspace to have them available in this analysis. Scroll down the list of assets and highlight the one you would like to trade with the asset listed at the top of the dialog.

2. We can type, or use the arrows, to incrementally change the weight of Stora Enso. Shell’s new weight is automatically displayed in the Trade With box.

3. By adjusting the weight in Stora Enso, we find that we can minimize risk between these assets by reducing the weight of Stora Enso to 3.27 and increasing the weight of Shell to 10.45. (Note: We are making an exaggerated trade in order to make a clear point.)

4. We click Make Trade to see the trade reflected in our workspace.
Viewing the Trades

We can view the trades that we have executed in our portfolio in the Trade List report.

---

**To do this, select:**

- Portfolio > Trade List > All Trades

**For details, see this help topic:**

- Viewing the Trade List

---

We have invested 10% of the portfolio into Shell Transport & Trading, funding the transaction by selling our position in Stora Enso. The small difference between the buy and the sell amount appears in cash.

<table>
<thead>
<tr>
<th>Asset ID</th>
<th>Name</th>
<th>Price</th>
<th>Traded Value</th>
<th>Traded Value (%)</th>
<th>Trans. Cost</th>
<th>Trade Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>EURCURREN</td>
<td>Shell Transport &amp; Trading</td>
<td>6.54</td>
<td>108,063,712.25</td>
<td>10.00</td>
<td>0.00</td>
<td>Buy</td>
</tr>
<tr>
<td>507267</td>
<td>Stora Enso</td>
<td>4.45</td>
<td>-108,063,712.25</td>
<td>-10.00</td>
<td>0.00</td>
<td>Sell</td>
</tr>
</tbody>
</table>

**Tips:**

- This trade list can be saved as a long-short portfolio by selecting File > Save Trade List As.
- To view a summary of these transactions, select the Transaction Summary report.
Viewing the Impact of the Trades

Let's look again at the Active Risk portion of the Risk Decomposition chart, compared to the one on page 27. Notice that this one trade has significantly reduced the risk of our portfolio.

Active risk (tracking error) is down to 4.44%.

The amount of active risk attributable to asset selection risk is down from around 75.10% to 57.03%, a reduction of about 18%.

Let's look again at the Executive Summary report, compared to the one on page 24. It shows the changes to the general risk characteristics in the portfolio.

The Initial Portfolio column shows the characteristics of the portfolio we started with (before the trades were made).

The Managed Portfolio column shows the risk numbers after any changes are made to the portfolio.

The Change column shows the difference between the initial portfolio and the managed portfolio.

Active risk (tracking error) has been reduced by more than 2%.

<table>
<thead>
<tr>
<th>Portfolio Statistics</th>
<th>Initial Portfolio</th>
<th>Managed Portfolio</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Total Risk</strong></td>
<td>16.34</td>
<td>15.89</td>
<td>-0.44</td>
</tr>
<tr>
<td><strong>Active Risk</strong></td>
<td>6.53</td>
<td>4.44</td>
<td>-2.09</td>
</tr>
<tr>
<td><strong>Active-return-at-risk (%)</strong></td>
<td>-10.71</td>
<td>-7.33</td>
<td>3.38</td>
</tr>
<tr>
<td><strong>Active-return-at-risk (Value)</strong></td>
<td>-115,728,952.06</td>
<td>-79,178,345.69</td>
<td>36,550,606.37</td>
</tr>
</tbody>
</table>
Optimizing your Portfolio

While the Simulate Trade feature (see page 38) lets you adjust your portfolio's risk profile one trade at a time, optimization creates an optimal portfolio all at once by trading assets found in the initial portfolio (the portfolio you want to optimize) and the universe portfolio (the list of all assets eligible for consideration for inclusion in a portfolio). The goal is to maximize utility while taking into account any constraints specified on the Portfolio > Settings tabbed pages.

By maximizing utility, we are trying to balance several competing objectives:

- Maximize expected returns.
- Minimize risk. The optimizer can minimize total risk or risk relative to a benchmark.
- Minimize transaction costs.
- Minimize tax costs.
- Minimize penalties. Penalties help tailor the characteristics of the portfolio.

The utility calculation is basically a trade-off between expected net return (expected returns minus transaction costs minus penalties) and risk. It is calculated as:

$$\text{Utility} = \alpha - (\text{risk aversion} \times \text{portfolio risk}^2) - \text{transaction costs} - \text{tax costs} - \text{penalties}$$

In addition to the goal of maximizing utility, Aegis must meet any specified constraints, such as the upper or lower bounds on the weights of assets, industry constraints, cash contributions or withdrawals, or transaction type limitations.
Types of Optimizations

You can choose from a Portfolio or Frontier optimization.

**Portfolio optimization**

This produces one optimal portfolio that meets a specific set of optimization criteria. If you select a portfolio optimization, you can choose from five types of portfolio optimization:

- **Standard risk-return tradeoff.** Your optimized portfolio will correspond to the point on the frontier associated with the risk aversion level you have specified on the Risk tab of the Portfolio > Settings dialog.

- **After-tax risk-return tradeoff.** Similar to the standard risk/return tradeoff, the after-tax optimization also takes into account the tax lots in your portfolio.

- **Risk target.** Your optimized portfolio will represent the optimal tradeoff between a target level of risk and the maximum level of return available at that level of risk.

- **Return target.** Your optimized portfolio will reflect the level of return you specified along with the minimum level of risk attainable at that level of return.

- **Long-short.** Similar to the standard risk/return tradeoff, the long-short optimization lets you create an optimal portfolio composed of cash combined with long and short equity positions.

**Frontier optimization**

This produces a set of optimal portfolios.

The frontier can be either a risk-return frontier (also known as an efficient frontier), which is the set of optimal portfolios with the highest return per unit of risk, or a turnover-utility frontier, which is the set of optimal portfolios at various levels of utility and turnover.
Overview of Bounds, Constraints, and Penalties to Impose on an Optimization

The optimizer must meet any bounds, constraints, and penalties you have indicated. The screenshots below show a few typical options for setting optimization constraints. Other settings not shown here include transaction costs, trading constraints, expected returns, roundlots, and more.

To do this, select either:

- Portfolio > Settings > various tabs
- > various tabs

For details, see this help topic:
- Defining your Investment Strategy

You can set bounds on asset weights prior to optimization. Portfolio Manager alerts you when you exceed these bounds in the workspace, and the optimizer observes the bounds when constructing an optimal portfolio.
Click the Constraints tab to control exposure to various parameters.

You can set upper and lower bounds for risk indices, industries, sectors, etc.

Click the Penalties tab to restrict factor values to certain ranges.

Penalties, like constraints, let you customize your optimization by tilting toward certain characteristics. Unlike constraints, penalties are not binding. When you apply a penalty, you specify a target for a portfolio characteristic as well as an upper and lower penalty threshold (you must specify all three), which indicate how closely the characteristic value in the optimal solution should approach the target value.
Setting Bounds

You can supply bounds that the Optimizer will observe when constructing an optimal portfolio. In this example, we are using the Conditional Rule feature to prevent a large portion of our portfolio from being attributable to a small number of issuers.

To do this, select either:

- Portfolio > Settings > Holdings tab
- > Holdings tab

For details, see this help topic:
- Holdings Settings

The default conditional rule is that the weight of an issuer cannot exceed 10% (Individual Upper Bound %), and the sum of the issuers with a weight larger than 5% (Aggregate Threshold %) cannot be greater than 40% (Aggregate Upper Bound%). However, you can change the defaults to define your own parameters.

Check this box to apply the conditional rule during optimization.
Executing the Optimization

After you have set the basic parameters, you can run your optimization. The Optimization Output dialog appears, displaying the status of your current optimization.

※ Tip: This information is also available as a report in Portfolio > Trade List > Optimization > Optimization Log.

To do this, select either:

• Actions > Optimize

For details, see this help topic:

• Executing an Optimization

Once your optimization is complete, you can:

• View the trades that were made during optimization (see “Viewing the Trades” on page 40).

• Compare the optimized portfolio with the initial portfolio (see “Viewing the Impact of the Trades” on page 41).
Other Useful Features

So far, we have seen how to enter holdings into Portfolio Manager, drill down to understand the sources of risk in the portfolio, and trade assets with the Simulate Trade and Optimization features.

Portfolio Manager has many other utilities. Some commonly used ones, discussed on the following pages are:

- Customizing your Workspace
- Changing Properties of Reports
- Saving Favorite Reports
- Printing Reports
- Importing your Data to Use in an Analysis
Customizing your Workspace

You can add columns to your workspace or customize the settings.

For details, see this help topic:

- The Asset Workspace

The interactive asset workspace lists your assets and any columns you choose to add with View > Customize Columns. Here we added Marginal Contribution to Risk in order to see how each asset contributes to the risk of the portfolio.

If you customize your workspace (for example, if you change the decimal precision or add columns), your settings will be saved. The settings will be applied anytime you open a portfolio in the selected model (such as the MS Equity model, as we used in the examples in this chapter). We call this the Model Workspace.

If you want to save your settings for a particular portfolio rather than the whole model, you must create a Portfolio Workspace (right-click on a workspace and save it as a Portfolio Workspace). Then every time you open that particular portfolio, the customized settings will appear. (This does not apply to Barra-supplied portfolios.)
Changing Properties of Reports

You can set properties for:

- individual reports, with the Properties feature (shown below). This includes sort order, decimal precision, page orientation, display status of zero values, and the factors that are displayed in the report.
- all reports, with the Preferences feature. This includes setting undefined values and decimal precision.

To do this, select either:

- Tools > Preferences > Report tab
- right-click report name > Properties > Report tab

For details, see these help topics:

- Report Properties
- Setting User Preferences

For sortable reports, it is useful to sort by the "Relative" column to help see your largest exposures, which determine your risk. (The column is referred to as Relative because the contents depend on whether you have selected a cash or non-cash benchmark and/or market portfolio.)

To make graphs easier to read, it is useful to uncheck the Display Zero Values box.
Saving Favorite Reports

Favorites are a convenient way to organize and link to reports that you use frequently.

atório: If you use Aegis Automation Assistant, you can automatically generate reports saved to Favorites.

To do this, select either:

- Tools > Add to Favorites
- right-click report name > Add to Favorites

For details, see this help topic:

- About Favorites
Printing Reports

You can print any report or group of reports.

---

To do this, select one of the following:

- File > Print
- 
- Ctrl + P

For details, see this help topic:

- Printing Reports

---

You can print the report you have active, or a collection of reports.

If you store reports that you print frequently to a Favorites folder, you can print the entire folder at once.
Importing your Data to Use in an Analysis

You can define and maintain a set of your own variables to use with your portfolio. Typical variables include alphas, bounds, transaction costs, or fundamental corporate data. User data can be specified as text, comma-separated, or Microsoft Excel formats. Here we show expected returns, or alphas, as a user data variable.

Tips:

• You do not need to create a different file for each variable. You can add many columns of variables in one file.

Step 1: Format a User Data File

Use the simple format shown in the example below.

For details, see this help topic:

• Formatting your Data Spreadsheet
Step 2: Import your Custom Data

Once you format your user data file, you can import it for use in Portfolio Manager. When your user data files have been successfully imported, you can:

- load your variables into your workspace (see “Customizing your Workspace” on page 49), or
- use your variables as asset-level data inputs in your analysis.

To do this, select:

- Data > Import User Data

For details, see this help topic:

- Importing User Data

Tip: You can use DataConnect to automatically import user data on a regular basis (see page 185).
Step 3: Include your Data in your Analysis

Now that we have imported our asset-level expected returns, we can use these data in our analysis.

⚠️ Note: Expected returns are not required for any part of our analysis. Returns of zero indicate that we have no insight in these areas.

---

To do this, select either:

- Portfolio > Settings
- """

For details, see this help topic:

- Defining your Investment Strategy
1. We select the variable we created in the user data file (see page 53).

2. Since our alphas are expected active returns above the benchmark, we select Active.
Chapter 3

Aegis Performance Analyst

- Introducing Performance Analyst
- Creating Performance Reports
- Analyzing your Portfolio’s Return
- Understanding Return
- Other Useful Features
Introducing Performance Analyst

The success of a strategy is ultimately measured by performance. Aegis Performance Analyst uncovers the drivers of risk-adjusted performance to help you improve your portfolio management decisions.

Whether you use Aegis to improve decision-making, attract and retain clients, or evaluate managers, it is important to clearly and consistently communicate results. Performance Analyst streamlines the reporting process by providing, in presentation-ready format, more than 50 single-country reports and 100 global reports.

- Evaluate performance in meaningful detail by attributing returns to their fundamental and asset-specific components, in absolute terms or relative to a benchmark.
- Calculate daily performance to capture the results of intra-month trading decisions.
- Isolate drivers of return in order to gain insights that will improve future performance.
- Test your strategic investments through analysis of return contributions, risk, information ratios, and t-statistics.
- Streamline internal and external communication with automated reporting and industry-standard language and measures.
- Demonstrate risk-adjusted performance to attract and retain clients.
- View holdings-based analysis to enable precise risk and performance attribution.
- Assess the feasibility of a backtested strategy by viewing its performance over time.
- Evaluate a fund’s style footprint and judge its consistency over different economic periods.
What is in this Chapter

This chapter introduces the basic concepts needed to get started in Performance Analyst.

Note: You should use this chapter after you have installed your Aegis software, permission file, and data. You should also have mapped to your data. See the Aegis Installation and Technical Guide for assistance.

The basic steps to get started are:

- Creating reports (page 60).
- Analyzing the portfolio’s return over time (page 71), looking at various reports to understand the sources of return in the portfolio.
- Understanding the categories of return that are used in Performance Analyst, which differ by model (page 79).
- Other features (page 88), such as customizing your reports, and importing accounting returns and transaction costs to use in reports.

We use a simple example to guide you through the basic steps.
Creating Performance Reports

Follow these simple steps to set up your analysis and view performance attribution reports.

Step 1: Prepare your Portfolios and Accounting Returns

To analyze your holdings and returns with Performance Analyst, simply format your portfolio files as you would for Portfolio Manager (see page 10) and store your portfolio files as shown on page 61.

✻ Tips:

• For the most accurate results, you should provide holdings for each day or month, depending on the frequency you prefer. One of the strengths of Performance Analyst, however, is that you can analyze a portfolio’s performance over time even if you don’t have an actual portfolio for each day or month in the timespan. For instance, if you choose monthly frequency but only quarterly holdings are available, Performance Analyst fills in the missing months by extrapolating forward the most recent holdings. This is achieved by applying known capital adjustments (stock splits and stock dividends) that have occurred since your last holding date.

• In our example on page 61, we supplied monthly portfolio files. However, you can instead supply daily portfolio files in order to more closely track the holdings and hence more accurately calculate the return of the portfolio.

• You can also use Aegis Portfolio Accountant to easily create and store your holdings (see page 102.)

For details, see this help topic:

• Creating and Storing Portfolio Files
Create a series of dated portfolio files, one for each available month-end or day-end holding (format them as shown on page 10). If you are using monthly files, as in this example, the file extension should be in the form *.YYM, where YY is the last two digits of the calendar year and M is the month (1-9 for January through September, and “a”, “b”, and “c” for October, November and December, respectively). Our analysis will be from February 1999 to January 2001. (This example shows the portfolio from February 1999 to January 2000.) Note: If you are using daily holdings, the file extension should be *.YYYYMMDD.

This file contains holdings that existed for this portfolio as of the last day of January 1999.

Place all of the dated portfolio files in a unique directory on your local hard drive or an accessible network drive. The directory name must be the same as the portfolio file name. This means that each portfolio time-series has its own portfolio directory. (If you have monthly and daily files for the same portfolio, they can share the same directory.)

This file contains holdings that existed for this portfolio as of the last day of December 1999.
Step 2: Create an Attribution Data Source

The Attribution Data Source (ADS) is a database that contains performance attribution results for your portfolio. Performance Analyst creates it by looking at all of the daily or monthly portfolio files that you provide. It is from this body of information that you generate reports for analyzing portfolio performance.

To do this, select one of the following:

- File > Attribution Data Source
- F7

For details, see this help topic:

- Creating a New Attribution Data Source

Click New to create a new attribution data source. The ADS wizard will help you to set up the ADS.
Highlight a model for your ADS from the list of mapped models (see the Installation and Technical Guide for information about mapping more models). When you choose a particular equity model for the ADS, you are deciding from what perspective you want to conduct your analysis.

If you have daily and monthly data available for the model you have chosen, you can select a frequency for your analysis.

Note: Daily performance is only available for selected models.

Click Next.

Choose the folder where you would like your ADS to reside. Each ADS requires its own folder.

Note: The portfolio used to create the ADS does not have to be in the same location as the ADS.

To create a new folder for your ADS, press Create In ... and enter the new folder name. Because the ADS is vital to your analysis, we recommend you give some thought to the directory structure. We suggest you name the directory by the type of ADS you create, such as “Value” or “Growth” as in this example.

Click Finish.
After choosing a model and location of the ADS, you specify the portfolios that will comprise it—both your own that you want to analyze and any Barra-supplied indexes you might want to use as benchmarks or market portfolios.

* Tip: To get to this dialog again, go to the Attribution Data Source Administrator dialog (shown on page 62) and either double-click an ADS or select an ADS and click Modify.

To add Barra-supplied portfolios, click the Barra Portfolios tab. Then click Add to browse through the list of portfolios supplied. We have added the DJWLD index, which we will use as a benchmark.

To bring in your own portfolios, click the User Portfolios tab. Then click Add to browse and select your portfolio directories. We added the Global portfolios we setup on page 60.

For a global analysis, click the Numeraire tab to include additional currency perspectives. We have selected USA and EMU.

All of the portfolios we have selected for our ADS appear in this area.

The numeraires we selected appear in this area.

Once you have selected all of the portfolios and numeraires for your ADS, click Process List to create it.
After processing the Attribution Data Source, Aegis shows you a high-level summary of the ADS.

※ Tip: To get to this dialog again, go to the Attribution Data Source Administrator dialog (shown on page 62), select an ADS, and click View Details.

For details, see this help topic:
- Viewing the Attribution Data Source Summary
Step 3: Set Up the Analysis

Once you have created the Attribution Data Source, you are ready to set up the analysis. In the Attribution Data Source Administrator dialog (shown on page 62), click New Analysis to specify the settings you want for your analysis.

You can return to this dialog by selecting one of the following:

- File > New Single Portfolio Analysis
- Ctrl+N

For details, see this help topic:

- Creating a Single-Portfolio Analysis
Select the managed portfolio. In our example, Global is the managed portfolio.

You can change the time span for the analysis by clicking Set Dates. We have indicated a 24-month analysis.

Select the benchmark portfolio. In our example, DJWLD is the benchmark portfolio. Note: If you are doing a single-country analysis (rather than global, as in this example), you would also select a market reference portfolio.

For global analyses, select the numeraire perspective. We have selected EMU.

When you have completed your settings, click OK to begin processing the criteria. A new analysis workspace will open from which you can view reports.
Step 4: View the Reports

Now that you have created a new portfolio analysis and selected the settings for the analysis, you can use Performance Analyst’s reporting workspace to view the reports.

Reports are available as:

- Tables
- Graphs
- Charts

For details, see this help topic:
- Produce and View Reports
1. The upper pane shows the report explorer, which organizes reports in categories based on return type. For example, the Total folder displays contributions to total return. When you click on a folder, the reports within that folder are listed in the lower pane.

2. Click on a report to view it.

3. The selected report appears in this area.

* Tip: If you double-click a report, it is opened in a new window.
Types of reports

Performance Analyst offers several standard reports to accurately analyze portfolio performance.

For details, see this help topic:

- Report Categories

The PERFORMANCE ATTRIBUTION reports decompose your portfolio’s active return into underlying sources of return.

The ASSET CONTRIBUTION reports decompose your portfolio’s return by individual companies.

You can save and organize reports that you use frequently in the FAVORITES folder. For details, see page 51.

Performance Attribution reports in the Total folder show the total (gross) return to a portfolio including gains and dividend income.

Performance Attribution reports in the Benchmark folder show the total return of the benchmark portfolio.

Performance Attribution reports in the Active folder show the difference in total return between the managed portfolio and the benchmark portfolio. Note: To learn about the return breakdown within the Active folder, see page 79.

The asset review reports give a time-series view of each asset in the analysis.
Analyzing your Portfolio’s Return

Let’s look at a few reports in order to understand the sources of our portfolio’s return.

How Can I Interpret an Attribution Report?

The attribution reports decompose each level of performance attribution into its underlying components so that you can drill down to the policies that influence your overall active return. An example of an attribution report for our analysis is shown on page 72.

To do this, select:

- Performance Attribution > Total > Annualized Attribution

For details, see this help topic:

- Attribution Reports

※ Tip: You can quickly change the analysis period in a report by selecting File > Change Dates.
In the Contribution column, we can see how active return is distributed. In this example, most of the portfolio’s active return was due to country selection and asset selection. Style (risk index) policy detracted from performance.

The t-statistic allows us to gauge whether the policy is based on skill rather than luck. In general, a t-stat larger than 2 indicates that the performance result can is probably a result of skill rather than luck, with a 95% confidence level. In this example, the portfolio’s asset selection contribution is most likely a skillful result. The strategy has successfully and consistently selected the best names. Other results, such as country selection, may have been due to luck rather than skill.

The t-statistic allows us to gauge whether the policy is based on skill rather than luck. In general, a t-stat larger than 2 indicates that the performance result can is probably a result of skill rather than luck, with a 95% confidence level. In this example, the portfolio’s asset selection contribution is most likely a skillful result. The strategy has successfully and consistently selected the best names. Other results, such as country selection, may have been due to luck rather than skill.

<table>
<thead>
<tr>
<th>Source of Return</th>
<th>Contribution (%)</th>
<th>Risk (Std Dev)</th>
<th>Info Ratio</th>
<th>T-Stat</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Risk Free</td>
<td>3.71</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>2 Total Benchmark</td>
<td>15.10</td>
<td>17.72</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>3 Country Selection</td>
<td>5.57</td>
<td>8.04</td>
<td>0.59</td>
<td>0.04</td>
</tr>
<tr>
<td>4 Currency Selection</td>
<td>-5.32</td>
<td>4.45</td>
<td>-1.04</td>
<td>-1.47</td>
</tr>
<tr>
<td>5 Cash Equity Policy</td>
<td>-0.01</td>
<td>0.00</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>6 Asset Allocation [3+4+5]</td>
<td>0.24</td>
<td>7.84</td>
<td>0.02</td>
<td>0.02</td>
</tr>
<tr>
<td>7 Local Market Timing</td>
<td>-0.08</td>
<td>1.24</td>
<td>-0.61</td>
<td>-0.72</td>
</tr>
<tr>
<td>8 Risk Indices</td>
<td>-0.82</td>
<td>2.37</td>
<td>-0.10</td>
<td>-0.14</td>
</tr>
<tr>
<td>9 Industries</td>
<td>1.51</td>
<td>1.97</td>
<td>0.81</td>
<td>1.14</td>
</tr>
<tr>
<td>10 Asset Selection</td>
<td>5.85</td>
<td>3.65</td>
<td>1.33</td>
<td>1.88</td>
</tr>
<tr>
<td>11 Within Market [7+8+9+10]</td>
<td>5.44</td>
<td>5.39</td>
<td>1.02</td>
<td>1.40</td>
</tr>
<tr>
<td>12 Trading</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>13 Transaction Cost</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>14 Total Active [6+11+12+13]</td>
<td>5.88</td>
<td>9.98</td>
<td>0.59</td>
<td>0.83</td>
</tr>
<tr>
<td>15 Total Managed [2+14]</td>
<td>20.88</td>
<td>20.85</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</tbody>
</table>

The information ratio measures the active return achieved per unit of active risk. An information ratio close to 1 indicates that per each unit of risk taken, a unit of return was gained. In this example, the manager was able to gain a level of return that more than offset the level of risk taken within the markets the portfolio was invested in. That is, the risk-adjusted performance is relatively good.
How Can I Graph my Cumulative Results Over Time?

While the previous table showed the annualized contributions to return, you can also graph the same categories of return by month. (For details about time frames used for reporting, see page 87.)

To do this, select:

- 📊 Performance Attribution > 🧨 Total > 📈 Monthly Cumulative Attribution Graph

For details, see this help topic:

- Attribution Reports

※ Tip: You can select which lines to display on the graph by right-clicking the report name in the bottom left pane and selecting Graph Properties. In this case, to simplify the graph, we selected only Within Market and Asset Allocation.
Within Market return shows the total contribution to return due to policies within each local market. (Available for global models only.) In this example, Within Market policies have continued to be the dominant influence on the portfolio’s performance.

Asset Allocation return shows the contribution to return due to the manager’s decision to hold more or less weight in the equities and currencies of each country present in the benchmark. (Available for global models only.)
Which Styles Affected Performance?

We saw in the Total Annualized Attribution report on page 72 that our performance suffered from our style policy. Let’s look at the Annualized Attribution report in the Risk Indices folder to learn how risk indices (styles) affected performance.

To do this, select:

- Performance Attribution > Total > Active > Risk Indices > Annualized Attribution

For details, see this help topic:

- Attribution Reports
Average active exposures measure (in standard deviations) the average difference between the portfolio and benchmark exposures over the analysis period. Active risk index exposures of 0.2 or more standard deviations should be considered significant active bets.

Average contribution arises from the average active exposure held over the analysis period.

Variation or timing contribution arises from deviations in the average active exposure that are, in theory, made to time market movements.

In this example, our portfolio's largest active positions are towards stocks with higher relative strength.

In this report, we can see that Size and Variability in Markets detracted most from style return, even if their active exposures are not significant.

<table>
<thead>
<tr>
<th>Source of Return</th>
<th>Average Active Exposure</th>
<th>Contribution (% Return)</th>
<th>Total Risk</th>
<th>Info Ratio</th>
<th>T-Stat [% Std Dev]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>[1]</td>
<td>[2]</td>
<td>[1+2] [%]</td>
<td></td>
</tr>
<tr>
<td>Size</td>
<td>0.10</td>
<td>-0.28</td>
<td>-0.61</td>
<td>-0.90</td>
<td>0.40</td>
</tr>
<tr>
<td>Success</td>
<td>0.35</td>
<td>-1.46</td>
<td>2.09</td>
<td>0.63</td>
<td>0.84</td>
</tr>
<tr>
<td>Value</td>
<td>0.17</td>
<td>-0.63</td>
<td>0.47</td>
<td>-0.16</td>
<td>0.20</td>
</tr>
<tr>
<td>Variability in Markets</td>
<td>0.08</td>
<td>-0.02</td>
<td>-0.37</td>
<td>-0.39</td>
<td>0.40</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td>-0.82</td>
<td>2.37</td>
<td>-0.10</td>
<td>-0.14</td>
</tr>
</tbody>
</table>

This is the total style contribution that we saw on page 72.
How Can I Review the Timing of my Style Policies?

The style report on page 76 showed that Size detracted most from style return. Let’s look more closely at the style policy for Size.

To do this, select:

- Performance Attribution > Total > Active > Risk Indices > Individual Risk Indices > Size

The fluctuation in the Size exposure reflects either an inconsistent policy or ineffective timing.

The fluctuation in the Size exposure reflects either an inconsistent policy or ineffective timing.
Which Assets Contributed Most to Performance?

We saw in the Total Annualized Attribution report on page 72 that much of our portfolio’s active return was due to asset selection. Let’s investigate which assets contributed most to performance.

To do this, select:

- Asset Contributions > Annualized Contributions - Assets Held

For details, see this help topic:

- Asset Contribution Reports

Tip: Highlight a column and press Å to sort the report from highest to lowest based on that column.

<table>
<thead>
<tr>
<th>Asset ID</th>
<th>Asset Name</th>
<th>Contribution (%) Return</th>
</tr>
</thead>
<tbody>
<tr>
<td>HD41</td>
<td>CHINA MOBILE (Hkd) (Hkd)</td>
<td>2.03</td>
</tr>
<tr>
<td>FINAAL4</td>
<td>NOKIA (A/B) OY (EUR) (EUR)</td>
<td>1.31</td>
</tr>
<tr>
<td>JPN6702</td>
<td>FUJITSU</td>
<td>1.39</td>
</tr>
<tr>
<td>JPN8603</td>
<td>NIKKO SECURITIES</td>
<td>1.21</td>
</tr>
<tr>
<td>FRAAO2</td>
<td>BOUYQUES (EUR)</td>
<td>1.05</td>
</tr>
<tr>
<td>JPN8770</td>
<td>TELEFONICA (EUR)</td>
<td>0.31</td>
</tr>
</tbody>
</table>

Because we sorted the list by contribution to total return, the assets at the top are the best names held in the portfolio, in terms of contributing most to total return.

We can see how each asset contributes to the different types of active return displayed.
Understanding Return

Active Return Breakdown for Different Models

We used a global model in our example on the preceding pages. However, you can also use a European model or one of many single country models to analyze your return.

Each model breaks down Total return into Benchmark and Active return. But how Performance Analyst breaks down active return depends on which model you are using.

Global Models

Global models use the following attribution tree.

The nodes of the attribution tree are described in the following table.
<table>
<thead>
<tr>
<th>This type of return</th>
<th>Shows this</th>
<th>And answers this question</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asset Allocation</td>
<td>The contribution due to the manager’s decision to hold more or less weight in the equities and currencies of each country relative to the benchmark</td>
<td>How did my allocation of equities and currencies across countries affect my portfolio’s performance relative to the benchmark?</td>
</tr>
<tr>
<td>Country Selection</td>
<td>The contribution due to the managed portfolio’s active equity weight and the performance of each country’s equities in the benchmark, relative to the benchmark as a whole. For instance, if a portfolio is overweighted in Brazil and the Brazilian benchmark equities outperformed the benchmark equities as a whole, then the contribution from this policy will be positive.</td>
<td>Did I choose the right countries to over and underweight my equity positions? Did I benefit from holding more U.S. assets relative to the benchmark?</td>
</tr>
<tr>
<td>Currency Selection</td>
<td>The contribution due to the managed portfolio’s active country weight and the performance of the country’s currency relative to the currencies of the benchmark as a whole. The active currency weight is the sum of the implicit currency exposure gained by the active equity weight and the explicit currency positions in each country.</td>
<td>Is my portfolio over or underexposed to the countries with favorable and unfavorable exchange rates?</td>
</tr>
<tr>
<td>Implicit Currency</td>
<td>The contribution to currency selection return that is due to the managed portfolio’s active equity weight for the country (implicit currency holdings) and the performance of the country’s currency relative to the benchmark’s country currencies as a whole.</td>
<td></td>
</tr>
<tr>
<td>Explicit Currency</td>
<td>The contribution to currency selection return that is due to the managed portfolio’s active currency weight (explicit currency holdings) and the performance of the country’s currency relative to the country currencies of the benchmark as a whole.</td>
<td></td>
</tr>
<tr>
<td>Cash–Equity</td>
<td>The contribution due to the tradeoff between holding cash versus equity securities in a global market. For instance, if the managed portfolio was overweighted in equities and the excess return to the benchmark equities was positive, then the policy contribution will be positive.</td>
<td>Did I benefit from holding more or fewer equities than currencies?</td>
</tr>
<tr>
<td>This type of return</td>
<td>Shows this</td>
<td>And answers this question</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Within Market</td>
<td>The contribution due to policies within each local country market</td>
<td>How did my style, industry, beta, and asset allocation policies within a given market affect the performance of my portfolio relative to the benchmark?</td>
</tr>
<tr>
<td>Market Timing</td>
<td>The contribution due to the managed portfolio’s active beta relative to each local market and the performance of each local market. For instance, if the active beta of the equities in Brazil is positive and the return to Brazil’s market is positive, the contribution from this policy will be positive.</td>
<td>Did my beta policy within each country pay off? Was investing in U.S. assets with high betas a wise choice?</td>
</tr>
<tr>
<td>Risk Indices (Styles)</td>
<td>The contribution due to the managed portfolio’s active risk index exposures relative to the benchmark</td>
<td>Did my portfolio benefit from style deviations away from the benchmark?</td>
</tr>
<tr>
<td>Industries</td>
<td>The contribution due to the managed portfolio’s active industry weights relative to the benchmark</td>
<td>Did I pick the “right” industries to be over and underweighted in?</td>
</tr>
<tr>
<td>Asset Selection</td>
<td>The contribution specific to the assets themselves and not due to any common factor influences. The contribution comes from all assets held by the managed portfolio and all benchmark assets not held.</td>
<td>Were the stocks I picked within any country, industry, and style the best that I could find? How did over weighting and under-weighting assets relative to my benchmark contribute to active return?</td>
</tr>
<tr>
<td>Trading</td>
<td>The contribution to active return due to the difference between buy-and-hold and the user-supplied (accounting or daily) return</td>
<td>Did I add value by trades made during the month?</td>
</tr>
<tr>
<td>Transaction Cost</td>
<td>The contribution to active return due to the explicit costs of purchasing or selling assets in the portfolio, ignoring cash flows. This is also user-supplied.</td>
<td>Did the cost of trading detract too much from return?</td>
</tr>
</tbody>
</table>
Single-Country Models

Single-country models use the following attribution tree.

The nodes of the attribution tree are described in the following table.

<table>
<thead>
<tr>
<th>This type of return</th>
<th>Shows this</th>
<th>And answers this question</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expected</td>
<td>The contribution to active return that one would expect given the manager’s active beta (adjusted for cash) and the long-term expected market risk premium</td>
<td>Given my portfolio’s beta, what return am I guaranteed just by investing in equities?</td>
</tr>
<tr>
<td>Exceptional</td>
<td>The contribution to active return that is due to the manager’s implicit or explicit investment policies; it is the value added by the manager beyond that already provided by the stock market on average</td>
<td>Aside from the return that I was guaranteed by just participating in the equity market, did I outperform or under-perform my benchmark?</td>
</tr>
<tr>
<td>This type of return</td>
<td>Shows this</td>
<td>And answers this question</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>Market Timing</td>
<td>The contribution to exceptional active return that is due to the manager’s decision to hold cash and to hold assets that have a higher or lower beta on average, relative to the benchmark’s assets</td>
<td>Did my decision to hold cash have a positive or negative impact on my performance? Did my decision to hold assets with higher or lower betas have a positive or negative impact on my performance?</td>
</tr>
<tr>
<td>Risk Indices (Styles)</td>
<td>The contribution to exceptional active return that is due to the managed portfolio’s active risk index exposures relative to the benchmark</td>
<td>Did my portfolio benefit from style deviations away from the benchmark?</td>
</tr>
<tr>
<td>Industries</td>
<td>The contribution to exceptional active return due to the managed portfolio’s active industry weights relative to the benchmark</td>
<td>Did I pick the “right” industries to be over and underweighted in?</td>
</tr>
<tr>
<td>Asset Selection</td>
<td>The contribution specific to the assets themselves, and not due to any common factor influences. The contribution comes from all assets held by the managed portfolio and all benchmark assets not held.</td>
<td>Were the stocks I picked within any industry or style the best I could find? How did overweighting and underweighting assets relative to my benchmark contribute to active return?</td>
</tr>
<tr>
<td>Trading</td>
<td>The contribution to active return due to the difference between buy-and-hold and the user-supplied (accounting or daily) return</td>
<td>Did I add value by trades made during the month?</td>
</tr>
<tr>
<td>Transaction Cost</td>
<td>The contribution to active return due to the explicit costs of purchasing or selling assets in the portfolio, ignoring cash flows. This is also user-supplied.</td>
<td>Did the cost of trading detract too much from return?</td>
</tr>
</tbody>
</table>
European Model

The European model uses the following attribution tree.

The nodes of the attribution tree are described in the following table.

<table>
<thead>
<tr>
<th>This type of return</th>
<th>Shows this</th>
<th>And answers this question</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expected</td>
<td>The contribution to active return that one would expect given the manager's active beta (adjusted for cash) and the long-term expected market risk premium</td>
<td>Given my portfolio's beta, what return am I guaranteed just by investing in equities?</td>
</tr>
<tr>
<td>Exceptional</td>
<td>The contribution to active return that is due to the manager's implicit or explicit investment policies; it is the value added by the manager beyond that already provided by the stock market on average</td>
<td>Aside from the return that I was guaranteed by just participating in the equity market, did I outperform or under-perform my benchmark?</td>
</tr>
<tr>
<td>This type of return</td>
<td>Shows this</td>
<td>And answers this question</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Market Timing</td>
<td>The contribution to exceptional active return that is due to the manager’s decision to hold cash and to hold assets that have a higher or lower beta on average, relative to the benchmark’s assets</td>
<td>Did my decision to hold cash have a positive or negative impact on my performance? Did my decision to hold assets with higher or lower betas have a positive or negative impact on my performance?</td>
</tr>
<tr>
<td>Countries</td>
<td>The contribution to exceptional active return that is due to the managed portfolio’s active country weight relative to the benchmark.</td>
<td>Did my country bets pay off?</td>
</tr>
<tr>
<td>Risk Indices (Styles)</td>
<td>The contribution to exceptional active return that is due to the managed portfolio’s active risk index exposures relative to the benchmark.</td>
<td>Did my portfolio benefit from style deviations away from the benchmark?</td>
</tr>
<tr>
<td>Industries</td>
<td>The contribution to exceptional active return due to the managed portfolio’s active industry weights relative to the benchmark.</td>
<td>Did I pick the “right” industries to be over and underweighted in?</td>
</tr>
<tr>
<td>Asset Selection</td>
<td>The contribution specific to the assets themselves, and not due to any common factor influences. The contribution comes from all assets held by the managed portfolio and all benchmark assets not held.</td>
<td>Were the stocks I picked within any industry or style the best I could find? How did overweighting and underweighting assets relative to my benchmark contribute to active return?</td>
</tr>
<tr>
<td>This type of return</td>
<td>Shows this</td>
<td>And answers this question</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Currency Selection</td>
<td>The contribution to active return that is due to the managed portfolio's active country weight and the performance of the country's currency relative to the country currencies of the benchmark as a whole. The active country weight is the sum of the active equity weight in the country (implicit currency) and the active currency weight in the country (explicit currency).</td>
<td>Is my portfolio over or underexposed to the countries with favorable and unfavorable exchange rates.</td>
</tr>
<tr>
<td>Implicit Currency</td>
<td>The contribution to currency selection return that is due to the managed portfolio's active equity weight for the country (implicit currency holdings) and the performance of the country's currency relative to the benchmark's country currencies as a whole.</td>
<td></td>
</tr>
<tr>
<td>Explicit Currency</td>
<td>The contribution to currency selection return that is due to the managed portfolio's active currency weight (explicit currency holdings) and the performance of the country's currency relative to the country currencies of the benchmark as a whole.</td>
<td></td>
</tr>
<tr>
<td>Trading</td>
<td>The contribution to active return due to the difference between buy-and-hold and the user-supplied (accounting or daily) return.</td>
<td>Did I add value by trades made during the month?</td>
</tr>
<tr>
<td>Transaction Cost</td>
<td>The contribution to active return due to the explicit costs of purchasing or selling assets in the portfolio, ignoring cash flows. This is also user-supplied.</td>
<td>Did the cost of trading detract too much from return?</td>
</tr>
</tbody>
</table>
Time Frames for Reporting Return

Each report displays sources of return using one of the following time frames:

- **Annualized**—This is the average return measured in units of 12 months (for a monthly analysis) or, for a daily analysis, the number of trading days in a year, which is implied by the overall return across the entire timespan of the analysis.

  Note: The underlying components of active return are also algebraically adjusted such that they sum to active return. As a result, the annualized returns may not simply be the geometric average 12 month return of the cumulative return. This calculation displays a single value for each source of return.

- **Cumulative**—This is overall return across the entire time horizon of your analysis. This calculation displays a single value for each source of return.

- **Monthly/Daily**—This is the monthly or daily return stored within the Attribution Data Source, calculated as the return from the first trading day to the last trading day of each month. This calculation displays a time-series of values for each source of return.

- **Standardized**—This is a quotient of the monthly return, divided by the monthly predicted risk based on the Barra risk model. This calculation displays a time-series of values for each source of return.

- **Monthly/Daily Cumulative**—This is the return, calculated from a fixed start date to an incrementally extended end date. Thus, for a given source, the last Monthly/Daily Cumulative return of the analysis timespan matches the Cumulative return; whereas the first Monthly/Daily Cumulative return matches the first Monthly/Daily return. This calculation displays a time-series of values for each source of return.
Other Useful Features

So far, we have seen how to prepare data and create an analysis, drill down to understand the sources of return in the portfolio, and understand the way active return is decomposed for different types of models.

Performance Analyst has many other helpful utilities. For example, you can:

- Customize performance reports, so they appear exactly as you want. See page 89.
- Save commonly used reports as Favorites (as in Aegis Portfolio Manager). See page 51.
- Print your reports (as in Aegis Portfolio Manager). See page 52.
- Import your Accounting Returns and Transaction Costs into Performance Analyst to include in the performance reports. See page 90.
Customizing Reports

You can easily select the information that will be shown in your performance reports.

You can set properties for:

- individual reports, with the Report Properties feature. This includes sort order, how many rows to display, decimal precision, page orientation, and macros to apply.
- all reports, with the Preferences feature. This includes setting undefined values, decimal precision, header location, and composite preferences.

To do this select one of the following:

- Tools > Report Properties
- highlight report name > right-click mouse > Properties
- F9
- Tools > Preferences > General tab

For details, see these help topics:

- Choosing Report Properties
- Setting your User Preferences

※ Tip: You can also save reports to Excel, where you can use all of Excel’s features to customize them.
Importing Accounting Returns and Transaction Costs

Performance Analyst allows you to import your own daily or monthly returns and transaction costs as a means of reconciling your accounting system returns with Barra-derived returns.

To import your user data, you must first format your data file so that Performance Analyst can read it.

For details, see this help topic:

- Importing Accounting Returns and Transaction Costs

Step 1: Format a User Data File

To import your own data to use in Performance Analyst, such as portfolio returns and transaction costs, you must supply the daily or monthly data in one of the following formats:

- comma-separated (*.csv)
- Excel (*.xls)
- tab-delimited (*.tab, *.txt)
- space-delimited (*.txt, *.prn, *.inp)

The user-data file contains header lines with variables by column, and monthly or daily values by row, as shown on page 91.

For details, see this help topic:

- Format of a User Data File
Headers must be in uppercase and prefixed with an exclamation point. They must be:

- !ID, which specifies the unique name of each variable
- !TYPE, which specifies the type of user data supplied in each column (R=portfolio return, TCV=transaction cost by value, TCP=transaction cost by percent)
- !NUMERAIRE, which specifies the currency perspective (for global and European models only). For a list of numeraire codes, see the appendix on page 201.

Data rows must be associated with a daily or monthly date. In this case we are supplying monthly data.
Step 2: Select a Model and Frequency

User-supplied returns and transaction costs are set on a model-by-model basis. In Performance Analyst, select a model to supply with user data before beginning to import data. Also, the frequency you select in that dialog will determine if your data is imported as monthly or daily holdings.

To do this, select one of the following:

- Data > Select Model and Dates
- F3

For details, see this help topic:
- Adding a Model Database

We have selected the Morgan Stanley version of the Global Equity model.

If you subscribe to daily data, you have the option to select a daily, rather than a monthly, frequency for your analysis.
Step 3: Import your Returns or Transaction Costs

You are now ready to import your data.

To do this select:

- Import > User Data

For details, see this help topic:

- Importing Accounting Returns and Transaction Costs

Click Import and then select the user-data file.
Chapter 4

Aegis Portfolio Accountant

- Introducing Aegis Portfolio Accountant
- Basic Steps
- Managing your Mapping Case
- Setting Preferences
- Menus
- Field Requirements for our Source Files
Introducing Aegis Portfolio Accountant

Portfolio Accountant is a utility designed to make the use of all Aegis products easier. Portfolio Accountant creates a common format—the “portfolio database”—for all Aegis components, including Portfolio Manager, Performance Analyst, Automation Assistant, and Developer’s Toolkit.

Basic Features

• Helps you create portfolio databases containing holding and trade records for all your portfolios over time.

• Imports files from your accounting system or other sources directly into portfolio databases.

• Eliminates the need for different sets of text files (.por, .yym, or .yyyyymmdd) for Portfolio Manager and Performance Analyst.

• Makes it easy to edit and browse portfolio records over time.

Advanced Features

• Calculates a holdings position as of any day, given the initial holdings and trades you supplied and capital adjustments (such as stock splits) provided by Barra.

• Reconciles your holdings and trades, and reports the items that may be in error.

• Lets you create after-tax portfolio databases to use with Portfolio Manager’s tax analysis features.

• Allows you to update multiple portfolio databases from a single file

• Allows bulk importing of files into multiple portfolio databases for multiple models simultaneously.

What You’ll Need

• In addition to having permission for Portfolio Accountant, you must install and have permission for Portfolio Manager, Performance Analyst, or both.
Basic Steps to Run Portfolio Accountant

The basic steps to run Portfolio Accountant are:

1. Create a new portfolio database or open one that you’ve already created. See page 97.

2. Import existing files into the database. These can be files you’ve created in other Barra applications, or your own files, such as those from your accounting system. You can also type records directly into Portfolio Accountant if you choose. See page 100.

3. Once you’ve added records to the database, you can view them all or view them selectively by record type or date. See page 112.

4. You can also generate reports from the database, including the calculated holdings as of a specific date, trade activity for a period of time, and a reconciliation report for holdings over a specified time period. See page 116.

The records you’ve added to the database are available for use in all other applications in the Aegis Suite.

Creating or Opening a Portfolio Database

In order to import existing data files (of any type) into Portfolio Accountant, you must first create the portfolio database, or open an existing portfolio database. For more information regarding opening an existing portfolio database, see “To Open an Existing Portfolio Database:” on page 99.
To Create a New Portfolio Database:

1. Select File > New or click the button. The New Database dialog appears:

2. Type the name of the database in the Name field.

3. Type comments, if desired, in the Comment field.

4. From the Model dropdown menu, select the model you want to use as a basis for this database.

5. Select the Weighting Scheme that applies to this model.

6. Use the Browse button to locate the folder where you would like the database file to be stored.

7. Check the Use for After-tax optimization checkbox if you want to use the portfolio database with Portfolio Manager’s tax analysis features. For more information, see “Creating an After-Tax Portfolio Database” on page 107.

Note: Once you’ve created an after-tax portfolio database, it remains tax-enabled and cannot be changed to a non-tax portfolio database. Likewise, a non-tax portfolio database cannot be tax-enabled.
8 Click OK to create the database. The database will be empty until you enter records by hand or import them from source files.

To Open an Existing Portfolio Database:

1 Select File > Open or click the button.

The Open Database dialog appears. Existing databases are listed by name, model, weighting scheme, and tax status:

![Open Database Dialog]

An X in the Tax column means the portfolio database was created as an after-tax database to use with Aegis Portfolio Manager’s tax analysis features. For more information, see “Creating an After-Tax Portfolio Database” on page 107.

2 To display only those databases associated with a specific model and/or weighting scheme, choose from the Model and Weighting Scheme dropdown lists.

3 If a portfolio database does not appear in the list of available databases because it was created by another user/installation of Portfolio Accountant, click the Register button to locate the “PortfolioName.PAC” directory you are looking for.
The Register Portfolio Database dialog appears.

- Use the **Browse** button to locate the folder you want to register.
- Type comments in the **Comments** field, if you like.
- Click **OK** to register the selected folder. To be registered, the folder must contain valid portfolio accountant databases.

4 To view the properties for a selected portfolio database, click **Properties**. You can edit the path information for the database or change the comment information.

5 To open a database, select it in the list and click **OK**. You can use the CTRL or SHIFT keys to select multiple databases.

---

### Importing Records from Source Files

Once you have created a portfolio database, you can import existing files into the database. There are two types of source files you can import:

- **Barra-Defined Source Files**—You can add files you’ve created in other Barra applications so you can access the information from the Portfolio Accountant database. Portfolio Accountant automatically recognizes the formats of these files when importing them.

- **User-Defined Source Files**—You can add your own files, such as those from your accounting system, directly to the portfolio database. These files can be either delimited or fixed width, and to import them you create a mapping case which tells Portfolio Accountant how to recognize the file format.
Importing Barra-Defined Source Files

You can import the following standard Barra-defined file formats:

- *.por – Portfolio Manager portfolio files
- *.tax – Portfolio Manager tax files
- *.yyym – Performance Analyst monthly data files
- *.yyymmdd – Performance Analyst daily data files

These file(s) will automatically be mapped by Portfolio Accountant, and as a result, the contents of the file(s) will be appended to the current selected database.

To Import a Standard Format File:

1. Either open an existing database or create a new one, so you are viewing the list of assets or a blank spreadsheet in the main window.

2. Select File > Import. The Import dialog appears.

3. Locate and select the file(s) you want to import. Use the SHIFT and CTRL keys to select multiple files.

   ◀ Note: The files that are imported into the database must have the same weighting scheme as the database.

Files that have a standard Barra-defined format will be recognized by the system, and the Mapping Case field will be grayed out.

4. To import the selected files, click Open. The files will be appended to the active database.
Importing User-Defined Source Files

You can import User-Defined file formats, such as accounting system files, using the Import Wizard. The Import Wizard is a step-by-step process which helps you map each column of data in your file(s) to the appropriate Barra-defined fields in the portfolio database. You thus create a "mapping case" that shows Portfolio Accountant how to read your file each time it imports another file of the same type.

Note: There are required and optional fields that your accounting files should contain to be imported successfully. For a complete list of the necessary fields, see “Field Requirements for your Source Files” on page 130.

Generally, there are two types of accounting files or record types.

• Holdings, also known as account position appraisals.

• Trades, also known as transactions.

Once a mapping case has been defined and saved, it can be reused automatically for other accounting system files that have the same format. Normally, you would have a mapping case for each record type.

To Import a User-Defined File Format:

1. Either open an existing database or create a new one, so you are viewing the list of assets or a blank spreadsheet in the main window.

2. Select File > Import. The Import dialog appears.

3. Locate and select the file(s) you want to import. Use the SHIFT and CTRL keys to select multiple files.

   Note: The files that are imported into the database must have the same weighting scheme as the database.
Since the selected file(s) do not have a standard Barra format, they will not be recognized by the system and the Mapping Case field will display “New Mapping Case”.

Note: If you have already defined a mapping case that you would like to use for this file, select it from the Mapping Case dropdown menu.

4 To import the selected files click Open.

5 If you have not selected an existing mapping case, the Import Mapping Wizard dialog appears. The import mapping wizard will step you through the process of creating a new mapping case, which will tell Portfolio Accountant how to read your specific file format.

The options available within the Mapping Wizard depend on the data type of the file you are importing:

- If you are importing a Delimited file, your file(s) contain fields that are separated by commas or tabs. For more information on importing this type of file see “Importing a Delimited File” on page 103.
- If you are importing a Fixed Width file, your file(s) contain fields that are aligned in columns with spaces between each field. For more information on importing this type of file see “Importing a Fixed Width File” on page 105.

Importing a Delimited File

When you click the Open button on the Import Dialog, the Import Mapping Wizard Dialog (1 of 4) appears.

1 Select the Delimited data type option. (“Delimited” indicates that the file contain fields that are separated by commas or tabs.)

2 Check the Headers Present box if the files contain header rows, and specify its row number in the box provided.

3 Specify what row the import should start at in the field provided.
4 Click the **Next** button. The Import Mapping Wizard dialog (2 of 4) appears.

5 In the **Delimiters** box, check the box that corresponds to the type of delimiter that your file contains.

6 Check the **Treat Consecutive Delimiters as One** check box if you want multiple occurrences of a delimiter to be ignored.

7 Select a text qualifier from the dropdown menu, if your file uses text qualifiers. A preview of the data will be displayed in the preview window.

8 Click the **Next** button. The Import Mapping Wizard dialog (3 of 4) appears.

9 Select a **Record Type**, **Model**, and **Weighting Scheme**.

10 Using the checkboxes to the left of the **User Field Name** column, check all of the columns you want to import and map them to Barra fields they correspond to. Specify both a **Barra Field Name** and a **Field type**, using the dropdown menus provided. (Click a **Barra Field Name** cell to activate its dropdown list.)

   Uncheck any columns you don’t want to import. Portfolio Accountant will ignore these columns of data and they will not be imported.

11 Click the **Next** button. The Import Mapping Wizard dialog (4 of 4) appears.

12 Assign **ID types** using the dropdown menus provided, so Portfolio Accountant will know what ID types your file uses.

13 Assign **Transaction types**, if applicable.

   **Note:** If you are importing files into an after-tax portfolio database, follow the guidelines for mapping the applicable transaction types. For more information, see “Creating an After-Tax Portfolio Database” on page 107.

14 Click the **Finish** button.
Importing a Fixed Width File

When you click the Open button on the Import Dialog, the Import Mapping Wizard Dialog (1 of 4) appears.

1 Select the Fixed Width Data type option. (“Fixed” indicates that the file contain fields that are aligned in columns with spaces between each field.)

2 Check the Headers Present box if the files contain header rows, and specify its row number in the box provided.

3 Indicate what row the import should start at in the field provided.

4 Click the Next button. The Import Mapping Wizard dialog (2 of 4) appears.

5 This screen lets you set the field width, or column breaks, for the file.
   • To create a line break, click at the desired position.
   • To delete a break, double-click on the line.
   • To move a line break, click and drag it.

6 Click the Next button. The Import Mapping Wizard dialog (3 of 4) appears.

7 Select a Record Type, Model, and Weighting Scheme.

8 Using the checkboxes to the left of the User Field Name column, check all the items you want to import, and map them to the Barra fields they correspond to. Specify both a Barra Field Name and a Field type, using the dropdown menus provided. (Click a Barra Field Name cell to activate its dropdown list.)

   Uncheck any items you don't want to import. Portfolio Accountant will ignore these columns in your file, and they will not be imported.

9 Click the Next button. The Import Mapping Wizard dialog (4 of 4) appears.
10 Assign **ID types** using the dropdown menus provided, so Portfolio Accountant will know what ID types your file uses.

11 Assign **Transaction types**, if applicable.

   **Note:** If you are importing files into an after-tax portfolio database, follow the guidelines for mapping the applicable transaction types. For more information, see “Creating an After-Tax Portfolio Database” on page 107.

12 Click the **Finish** button.

---

**Entering/Changing Records Directly**

Portfolio Accountant allows you to hand-key data into the Portfolio Database. This is most useful for correcting errors that were in the source files. You can also use this functionality to create the entire database if you choose.

**To Key Information Directly into a Portfolio Database:**

1 Open an existing portfolio database, or create a new portfolio database.

2 Select a record type and date in the toolbar.

3 You can directly key information into the following fields:
   - Asset ID
   - Trade Size/Holding
   - Market Value (for holdings)
   - Price (for holdings)
4 For **ID Type** and **Trade Type**, you can click in the cell and select appropriate field information from the dropdown menus.

▷ **Note:** Date and **BARRA ID** fields are not editable.

---

**Creating an After-Tax Portfolio Database**

When you create a portfolio database, you can classify it as “after-tax.” This lets you import your accounting system data and use it with Aegis Portfolio Manager’s tax analysis features, such as:

- Performing after-tax optimizations with one or two tax rates.
- Viewing the tax lot details of individual assets.
- Examining the tax costs of any trades in your portfolio.
- Viewing the details of potential wash sales.

**To import your files into an after-tax portfolio database:**

- You must import all positions as trades. There can be no holdings imported or entered directly.
- The portfolio database can contain no short trades, as these are not supported in Portfolio Manager.
- All transactions must include Asset ID, Trade Date, Price, Trade Size, Trade Type (buy or sell), and tax lot number.
- Each “Buy” and “Taxable Adjustment” transaction type must have a unique tax lot ID associated with it.
- Each “Sell” transaction type must refer to a pre-existing tax lot ID.
- Any adjustment information you want included (such as dividends and stock splits) must come from your accounting system files. Barra-supplied adjustments are not applied to after-tax portfolio databases.
Two transaction types in the Import Mapping Wizard, “Taxable Adjustment” and “Non-taxable Adjustment,” help you map your adjustment data to Barra fields. Non-taxable adjustments will affect both the number of shares and the cost basis for existing tax lots. Please check with your tax regulation agency to see whether non-cash disbursements are taxable or not.

### Updating Multiple Portfolio Databases from a Single File

If your accounting system or trade order management system has the ability to output holding or trade information for multiple accounts or portfolios into a single file (with a label for each record in the file), you can use that file to automatically create each of your portfolio databases and import the files in one step. That way, you don’t need to create a separate portfolio database for each account or portfolio before importing the data.

For example, suppose your file looks like this, showing the holdings for multiple accounts:

<table>
<thead>
<tr>
<th>Security</th>
<th>Date</th>
<th>Position</th>
<th>Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>MSFT</td>
<td>2/04/2000</td>
<td>10000.00</td>
<td>High Cap Growth</td>
</tr>
<tr>
<td>CSCO</td>
<td>2/04/2000</td>
<td>24000.00</td>
<td>Small Cap Growth</td>
</tr>
<tr>
<td>T</td>
<td>2/04/2000</td>
<td>11000.00</td>
<td>Mid Cap Growth</td>
</tr>
<tr>
<td>R</td>
<td>2/04/2000</td>
<td>23000.00</td>
<td>High Cap Value</td>
</tr>
</tbody>
</table>
To create and/or update the databases for multiple accounts:

1. Create at least one of the portfolio databases, using one of the account names specified in your file.

2. Select File > Import, and browse to select your file. If you already have created a mapping case for this file with the Portfolio field mapped, select that mapping case from the dropdown menu. Otherwise, leave it as New Mapping Case and click Open.

3. Define the mapping case as usual, but be sure to map the label for each record to the Portfolio field. For example, in the sample file shown above, you would map the Account column to the Portfolio field.

4. Finish creating your mapping case. If one or more of the names in the Portfolio field do not match existing registered portfolio databases, Portfolio Accountant asks you if it should create the portfolio database. Click Yes to create the first portfolio database or Yes to All to create all the databases.

Portfolio Accountant then imports each record into its corresponding portfolio database.

Updating Portfolio Databases in Bulk

With the Advanced Import feature, you can easily import files from a single directory into Portfolio Accountant in bulk. You can simultaneously import files:

- of different types
- for different models
- with different mapping cases
- into different portfolio databases
Before you can use the Advanced Import feature, you must have already:

- created the portfolio database(s) into which you'll import the files
- created the mapping case(s) for the files you want to import, either by having imported other files already or through the Mappings Manager
- mapped to the appropriate models (those you'll be importing files for) in Aegis Portfolio Manager or Aegis Performance Analyst
- placed in a single directory (containing no other files) all the files you want to import

To update portfolio databases in bulk:

1. Select File > Advanced Import.

2. Click Browse, select the directory where the files are located, and click OK. All the files in the directory are then listed in the Details section of the dialog.

3. From the dropdown list, choose the model you want.

4. If you want to import all the files into the same portfolio database, check the Use the same database for all files checkbox and choose the portfolio database from the dropdown list.

   > **Note:** To use this option, your mapping case(s) must have the date field mapped. To verify this, use the Mappings Manager to edit the mapping case(s). In Step 3 of the Wizard, look for Date in the Barra Field Name column. If not there, map the appropriate User Field Name to Date.

5. If you want to use the same mapping case for all the files (for example, if they are all holdings files in the same format), check the Use the same mapping case for all files checkbox and choose the mapping case from the dropdown list.

6. To use the dates specified in the imported files, choose Use dates specified in files.

   To use this option with your own accounting system files, your mapping case(s) must have the date field mapped.
For standard Barra-format portfolio (.por) files and dated portfolios (.yyym or .yyyyymmdd), Portfolio Accountant automatically reads the dates from the files.

➤ **Note:** Portfolio files created in Aegis Portfolio Manager have a date header near the top of the file that Portfolio Accountant recognizes. If you’ve created your own .por files with another application (such as a spreadsheet) and have not included a date, the holdings or trades will not be imported, and Portfolio Accountant will move on to the next file in the import list.

With dated portfolios in .yyym or .yyyyymmdd format, such as “MyPortfolio.987,” the date always indicates holdings as of the last trading day (e.g., July 31, 1998).

7 If you want to use the same date for all files, choose **Use same date for all files**, then click the dropdown box to choose a date from the calendar.

➤ **Note:** For any mapping cases that have the date field mapped, the date in the file is used instead of the date you specify here.

8 In the column to the left of the file names, check the checkboxes of the files you want to import, and for each one choose a portfolio database name and mapping case from the dropdown menus. If any files are in Barra format (.por, .yyym, or .yyyyymmdd), their **Mapping Case** field will show **Not Needed** because Portfolio Accountant recognizes them automatically.

➤ **Note:** If you chose to use the same portfolio database or mapping case for all files in step 4 or 5, you can’t access the portfolio database name or mapping case dropdown menus in the spreadsheet.

✱ **Tip:** Click the column heading of the checkbox column to check or uncheck all the checkboxes.

9 Click **Import**.

When importing is finished, Portfolio Accountant displays the AdvancedImport.log file that summarizes the import process. The log notes any files that were not imported and the reason (such as date not specified).
Viewing the Records in a Portfolio Database

When displaying a database in Portfolio Accountant's main window, you can use the navigation bar to view the records you want:

![Record Type: Holdings Date: 12/31/1988]

Portfolio Accountant displays records by date.

*Tip:* You can sort columns with the A-Z or Z-A buttons in the toolbar, or by right-clicking in a column heading.

Viewing All Records for a Specific Date

To view all the records in the database (both holdings and trades) as of a specific date, choose *All* from the *Record Type* dropdown list.

Narrowing the Scope

To Narrow the Scope of Data Displayed in the Spreadsheet:

1. Select Holdings or Trades from the *Record Type* dropdown.

2. Type a date in the *Date* field or click the dropdown arrow to choose a date on the calendar.
Searching for a Particular Asset in the Database

1. Select **Database > Find Asset** or press CTRL+F.

2. Under **Search By**, indicate whether you’d like to search using the asset name (Name) or the asset identifier (Id). If you elect to search by identifier, choose an identifier type from the dropdown list.

   ➤ **Note:** When searching by name, the selection in the ID dropdown list determines which of the asset’s IDs will appear in the list of found assets.

3. If you want to match your search string to the initial characters of an ID or asset name, select **Match to prefix of all assets**.

   If you want to match your search string to a string of characters appearing anywhere in the ID or asset name, select **Match to any substring of all assets**.

   For example, if you perform a U.S. name search using the string INTERNATIONAL, a prefix search will return all companies that begin with International, such as International Business Machines (IBM), but not companies like Tyco International, which contains but does not begin with INTERNATIONAL. A substring search, on the other hand, would return both IBM and Tyco in this example.

4. Click **Search**.

   At the bottom of the window, a list of assets that fit your search is displayed.

5. To add an asset from the list to your portfolio, click the asset in the list and click **Add**.
Scrolling Through the Records by Date

You can also use the arrow buttons to view the records for different dates in the portfolio database.

- ➤ Moves to records of the most recent date in the database.
- ▶ Moves to the oldest records in a portfolio database.
- ‹ Moves to the records of the next date in the database.
- ▼ Moves to the records of the previous date in the database.

Note: When scrolling through the database, you will see only those dates on which an explicit trade or holding was recorded. Empty dates, where no activity is registered, are not shown.

Viewing All Dates in the Portfolio Database

You can also use the Browse dialog to get a comprehensive list of all the record dates in the portfolio database. You can then choose the records you want to view in the workspace.

The Browse dialog is a cumulative file, containing all holdings/trades added since the portfolio database was created. It is updated whenever you import files or enter records manually.

To browse the dates in a portfolio database:

1. While viewing the portfolio database in the main window, choose All from the Record Type dropdown menu.

2. Select Database > Browse.

3. Scroll through the list to view the dates in the database. The dialog shows all date entries, whether you imported several files with the same date or several dates in the same file. For each entry, the columns show:
To view the records for a specific entry:
1. Check the **Update View** checkbox.
2. Click the row you want to view.

The main workspace shows the records for the row you selected.

**Viewing the Entry Log**

A portfolio database’s entry log shows when holdings or trades were imported into the portfolio database and where they came from. It is a cumulative file, containing all holdings/trades added since the portfolio database was created, and is updated whenever you import files or enter records manually.

**To view a portfolio database’s entry log:**
1. Select **File > Open** or click the **Open** button.
2. Click the database name, and click **Entry Log**.
Generating Reports from a Portfolio Database

Portfolio Accountant allows you to view the following reports:

- **Calculated Holdings Report**—Calculates holdings as of the user-specified holding date and analysis date. Capital adjustments can also be applied. For more information see “Viewing Calculated Holdings as of a Particular Date” on page 117.

- **Trade Activity Report**—Lists the trades entered in the portfolio database by the user between the specified start date and end date. For more information see “Viewing Trades Between Specified Dates” on page 117.

- **Reconciliation Report**—Reconciles the end date holdings, assuming the start date holdings are accurate. Reconciling items are equal to the difference in shares between two user-supplied holding dates excluding any user-supplied trade dates that have occurred in between. For more information see “Viewing a Reconciliation Report” on page 118.

  **Note:** This feature is disabled if there is only one date containing explicit holdings supplied by the user.

- **After-Tax Optimization Report**—Lets you look at a “slice” of an after-tax portfolio database you’ve created as of a date you specify. For more information, see “Creating an After-Tax Portfolio Database” on page 107 and “Viewing Tax Lots” on page 119.

  **Note:** If you don't want to view a separate report but would like to narrow the scope of the database, allowing you to view only trades or only holdings during specific time periods, see “Viewing the Records in a Portfolio Database” on page 112.
Viewing Calculated Holdings as of a Particular Date

The Calculated Holdings Report calculates implicit holdings in the portfolio database based on the user-specified holding date and analysis date and existing database records. Capital adjustments can also be applied.

To View the Calculated Holdings Report:
1. Open an existing portfolio database.
2. Select View > Holdings As Of.
3. Enter a holding date, or click on the date arrow to select the holding date using the calendar provided.
4. Enter an analysis date, or click on the date arrow to select the analysis date using the calendar provided.
5. Check the Apply Capital Adjustments box if you want capital adjustments applied.
6. Click OK.
7. To save the report select File > Save As and use the navigation tools to select the location where you would like to save the report file. Click Save.
8. To print the report select File > Print Report.

Viewing Trades Between Specified Dates

The Trade Activity Report lists the trades that were recorded in the portfolio database between the user-specified start date and end date.

To View the Trade Activity Report:
1. Open an existing portfolio database.
2. Select View > Trades From...To...
3 Enter a start date, or click on the date arrow to select the date using the calendar provided.

4 Enter an end date, or click on the date arrow to select the date using the calendar provided.

5 Click OK.

6 To save the report select File > Save As and use the navigation tools to select the location where you would like to save the report file. Click Save.

7 To print the report select File > Print Report.

Viewing a Reconciliation Report

The Reconciliation Report reconciles the number of shares for each asset over a specified period of time. The report displays those assets that may have incomplete or erroneous records in the portfolio database. The number of shares shown are equal to the difference in shares between the beginning and ending holding date netted against any trades (cash or non-cash) that occurred during the period.

In general, a positive share value for an asset indicates that there may be a “Buy” transaction missing. Conversely, a negative share value for an asset indicates that there may be a “Sell” transaction missing.

Note: This feature is enabled only for those start and end dates that contain user-supplied holding records. This feature is disabled when there is only one date (or no date) in the database that contains user-supplied holding records.

To view the Reconciliation Report:

1 Open an existing portfolio database.

2 Select View > Reconciliation
3 Select a start date from the list box. This list box shows all dates for which you entered holding records.

4 Select an end date from the list box. The list box shows only those dates that occur after the selected Start Date.

5 Click OK.

6 To save the report select File > Save As and use the navigation tools to select the location where you would like to save the report file. Click Save.

7 To print the report select File > Print Report.

Viewing Tax Lots

If you have created an after-tax portfolio database and imported files into it, you can view the tax lots for a date you specify. This lets you look at a “slice” of the database as of that date and verify that it contains all relevant information.

If you need to, you can then edit the file (for example, to indicate that a tax lot has been disqualified for wash sale purposes), so it will contain the data you need for an after-tax optimization in Aegis Portfolio Manager. To edit the file, you save it, and then open it in a spreadsheet or other editing application.

▷ Note: You don’t need to create a tax lot file in order to use an after-tax portfolio database in Portfolio Manager. Creating it here simply gives you an opportunity to view and change it first.

To view tax lots:

1 Open the after-tax portfolio database.

2 Select View > Tax Lots as of.

3 Click the dropdown menu to choose a holding date from the calendar.
4  Click OK.

To edit the tax lot file:
1  When viewing the file, choose File > Save As > File.
2  Save the file as a file type appropriate to the editing application you want to use, such as an Excel (.XLS) file.
3  Open and edit the file in your editing application, and save it with a .tax extension.
4  You can then open the tax lot file in Aegis Portfolio Manager.

Managing your Mapping Cases

You can import various types of files into Portfolio Accountant by defining a "mapping case" for each type. The mapping cases show Portfolio Accountant how to read the files when importing them. If you need to import several types of files with different formats, you would create a mapping case for each type.

For example, if you need to import files from your accounting system, you can create a mapping case the first time you import the files. From that point forward, each time you import files from your accounting system that match the file format you defined previously, you can select the mapping case you created and import the file in one easy step.

While you can create a mapping case when you import a file, Portfolio Accountant’s Mappings Manager allows you to create new mapping cases (for new file formats) ahead of time, as well as register mapping cases stored in other locations, edit existing mapping cases, and delete mapping cases.
You can share your mapping cases with other users by giving them read privileges to your mapping files (mappings.dbf and mappings.fpt). To learn more, see “Sharing your Files with Other Users” in Portfolio Accountant’s online help.

To manage your mapping cases:

1. Select File > Mappings Manager. The Manage Mappings dialog appears.

2. Click New to create a new mapping case.

3. Locate and select the file you want to use as a sample for creating a mapping case (i.e., the type of file you will be importing). The file you select will not actually be imported. It will be used simply to show Portfolio Accountant which fields correspond to the Barra-required fields.

4. Click the Open button. The Import Wizard dialog appears.
   - If the file is a delimited file see “Importing a Delimited File” on page 103.
   - If the file is a fixed width file see “Importing a Fixed Width File” on page 105.

5. To register a mapping definition that you have saved in a different location, or a mapping definition that was created by someone else, click the Register button. Locate and select the mapping case you want to register, then click Open.
6 To edit a mapping case, highlight the mapping case you want to edit and click **Edit**. The Import Wizard dialog appears and displays all of the current settings for the mapping case.

- Change the mapping case settings as necessary.
- Once you are done making changes to the mapping case click **Finish**. The Save Mapping dialog appears.
- If you want to overwrite the existing mapping case definition click **OK**. Click **Yes** to overwrite the mapping case definition.
- If you want to create a new mapping case based on the changes made, type in a new name for the map case, enter any comments, and click **OK**.

7 To delete a mapping case, highlight the mapping case and click the **Delete** button. Click **Yes** to confirm the deletion of the selected mapping case.

8 Click **Close** to close the Mappings Manager.
Setting Portfolio Accountant Preferences

Portfolio Accountant allows you to customize how it works in the Preferences dialog.

To specify your preferences:

1. Select View > Preferences. The Preferences Dialog appears:

```
Preferences

Settings:
- Number of recent databases listed in the File menu (4-15)

File Paths:
- Mapping Case Field Descriptions (1.1N)
- Import Mapping Case List
- Portfolio Database List

OK Cancel Help
```

2. When you have made your changes, click OK.

General Tab

File menu settings

Type the number of recently opened files you want listed at the bottom of the File menu. The range is from 4 to 15.
File paths

- The Mapping Case Field Descriptions file, *flddsc.ini*, contains the specifications of the Barra fields. Barra fields cannot be edited directly in the application. However, if another Barra field specification is required, the path to the Field Descriptions file can be changed. Click the **Browse** button to locate the file you want.

- The Mapping Case List database file, *mappings.dbf*, stores the mapping cases you’ve created. If you want to use someone else’s mapping cases (like a central mappings file located on a server), click the **Browse** button to locate the mappings database file you want.

- The Portfolio Database List file, *pmulist.dbf*, contains the list of portfolio databases you see in the Open Portfolio Database dialog. If you want to use someone else’s database list (like a central list located on a server), click the **Browse** button to locate the database list file you want.

Import Tab

Import mapping wizard

Type the number of text strings you want displayed in the Preview area of the mapping wizard. This lets you view as little as the first 20 lines of data in the file being imported or as many as 200 lines.

Advanced import

When you update your portfolio databases with the Advanced Import feature, you can have Portfolio Accountant automatically open the portfolio databases after they are updated, or after they are created with the **File > Import** command. Check this box to have the portfolio databases opened automatically. Leave this box unchecked to leave each portfolio database closed after it is updated/created.
Import rules

When you perform a portfolio updates more than once for the same day (i.e., import holding or trade records for a date that already contains holding or trade records), you can have Portfolio Accountant:

- **Ignore**, leave the asset’s existing holdings and trades untouched,
- **Replace**, replace the asset’s existing holdings and trades with those you’re importing, or
- **Cumulate**, add the imported trades to the existing ones and cumulate the existing holdings with those you’re importing.

For example, suppose you perform an update in which IBM has a holding of 1000. Later that day, you perform another update for the same holdings date in which IBM has a holding of 500. Here is the result of each selection of import rules:

<table>
<thead>
<tr>
<th>Selection</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ignore</td>
<td>1000</td>
</tr>
<tr>
<td>Replace</td>
<td>500</td>
</tr>
<tr>
<td>Cumulate</td>
<td>1500</td>
</tr>
</tbody>
</table>

▷ **Note:** If you use the Automation Assistant to update your portfolio databases, please note that this setting will also define the behavior for Historical Portfolio Updates performed by that application as well.

Columns Tab

On the Columns tab, you can define the columns you want to see when viewing holdings and trades. Use the arrow buttons to move items between the **Hide Columns** list on the left and the **Show Columns** list on the right.
**Date Tab**

On the Date tab, you can select date formats and behavior. You can select:

- How you want dates to appear (see a preview of your choices to the right of your selections)
- How Portfolio Accountant should handle undefined dates for data being imported
- What Portfolio Accountant should do if the end of month date lies on a weekend (Aegis requires the last trade day, rather than the last day of the month)

➤ **Note:** You must check the *End of Month Date Adjustment* box to enable your end-of-month holdings selection.

**Number Tab**

On the Number tab, you can decide how you want your numbers to appear. You can select:

- Number of decimal places
- The decimal symbol
- Whether you want to have a separator to group thousands (such as the comma in 1,000) and what the separator should be
- Whether you want to use these settings for reports

The sample at the top of the dialog shows how your numbers will appear based on these settings.
Cash Tab

In the Cash tab, you specify the identifiers your accounting system uses for cash holdings, so Portfolio Accountant can recognize and import them.

- Choose a model from the dropdown list. The models available depend on the models you have mapped to in Aegis Portfolio Manager or Aegis Performance Analyst.
- The **Barra ID** field contains cash codes for each currency type.
- For each model (for single-country models) or numeraire within the selected model (for multi-country models), type all of the cash identifiers your accounting system uses, separated by semicolons.

Reject Tab

In the Reject tab, you can tell Portfolio Accountant how to recognize the asset IDs and handle rejected assets in any user-defined files you import. Assets can be rejected, for example, because your accounting system that creates the source file either:

- lengthens the identifier (by adding an extra check digit), or
- shortens the identifier (for example, by dropping any preceding zeros).

To help minimize rejected assets, you can specify an “identifier length” for each ID type in each model.

▶ **Note**: This feature is intended for fixed-length identifiers only. Portfolio Accountant will recognize and import only the exact number of digits you specify.

To specify the identifier length settings:

- Choose a **Model** and **ID Type** from the dropdown lists, and type the Identifier length for that ID type. (For a list of model and ID type abbreviations, see the appendix on page 198.)
Suppose, for example, you specify an identifier length of 8. If an imported asset ID has more than eight characters, Portfolio Accountant imports only the first eight.

Specify an identifier length for any ID types you will be using with your model. For example, if you will be using SEDOLs and CUSIPs with your model, define a length for both.

- For IDs shorter than the identifier length you specified, you can have Portfolio Accountant either reject the asset or append specific characters (such as 000) to the beginning or end of the identifier. To append characters, type the desired character(s) in the text box and choose their location from the dropdown list. Portfolio Accountant will append characters until the asset ID reaches the length you specified.

## Portfolio Accountant Menus

<table>
<thead>
<tr>
<th>Menu</th>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>New</td>
<td>Displays the New Database dialog box, which allows you to create a new portfolio database.</td>
</tr>
<tr>
<td></td>
<td>Open</td>
<td>Displays the Open Database dialog box, which allows you to open an existing portfolio database.</td>
</tr>
<tr>
<td></td>
<td>Import</td>
<td>Displays the Import dialog box, which allows you to import a Barra-Defined File Format or any User-Defined File Format.</td>
</tr>
<tr>
<td></td>
<td>Advanced Import</td>
<td>Displays the Advanced Import dialog, which allows you to import files in bulk.</td>
</tr>
<tr>
<td></td>
<td>Save As &gt; Portfolio Database</td>
<td>This option is available only for an open portfolio database. It copies the database with the most recent changes saving the information to a new file.</td>
</tr>
<tr>
<td></td>
<td>Save As &gt; Report</td>
<td>This option is available only for an open report. Saves a copy of the active report to your local hard drive.</td>
</tr>
<tr>
<td>Menu</td>
<td>Command</td>
<td>Function</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Mappings Manager</td>
<td>Displays the Mappings Manager dialog which allows you to create, register, edit and delete mapping cases.</td>
</tr>
<tr>
<td></td>
<td>Print Spreadsheet</td>
<td>Prints the contents of the spreadsheet in the active window.</td>
</tr>
<tr>
<td></td>
<td>Print Report</td>
<td>Prints the contents of the report in the active window.</td>
</tr>
<tr>
<td>View</td>
<td>Holdings As Of...</td>
<td>Calculates implicit holdings in the portfolio database based on the user-specified holding date and analysis date. Capital adjustment can also be applied.</td>
</tr>
<tr>
<td></td>
<td>Trades from... to...</td>
<td>Lists the trades for the portfolio database based on the user-specified start date and end date.</td>
</tr>
<tr>
<td></td>
<td>Reconciliation</td>
<td>Reconciles the end date holdings, assuming the start date holdings are accurate. Reconciling items are equal to the difference in shares between two user-supplied holding dates excluding any user-supplied trade dates that have occurred in between.</td>
</tr>
<tr>
<td></td>
<td>Tax Lots as of...</td>
<td>For tax-enabled portfolio databases, generates a tax lot (.tax) file.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Shows or hides the Toolbar.</td>
<td></td>
</tr>
<tr>
<td>Navigation Toolbar</td>
<td>Shows or hides the Navigation Toolbar.</td>
<td></td>
</tr>
<tr>
<td>Status Bar</td>
<td>Shows or hides the Status bar.</td>
<td></td>
</tr>
<tr>
<td>Preferences</td>
<td>Accesses the Aegis Portfolio Accountant preferences for customizing the application.</td>
<td></td>
</tr>
<tr>
<td>Database</td>
<td>Navigation &gt; First record</td>
<td>Moves to the oldest record in the portfolio database.</td>
</tr>
<tr>
<td></td>
<td>Navigation &gt; Previous record</td>
<td>Moves to the previous record in the portfolio database.</td>
</tr>
<tr>
<td></td>
<td>Navigation &gt; Next record</td>
<td>Moves to the next record in the portfolio database.</td>
</tr>
<tr>
<td></td>
<td>Navigation &gt; Last record</td>
<td>Moves to the most recent record in the portfolio database.</td>
</tr>
<tr>
<td>Browse</td>
<td>Brings up the Browse Portfolio Database window.</td>
<td></td>
</tr>
</tbody>
</table>
Field Requirements for your Source Files

Here are the required and optional fields you can map when importing your trade and holding records into Portfolio Accountant.

For Trades

<table>
<thead>
<tr>
<th>Required</th>
<th>Optional</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asset ID</td>
<td>ID Type</td>
</tr>
<tr>
<td>Trade Date</td>
<td>Commission</td>
</tr>
<tr>
<td>Trade Size</td>
<td>Total Value of Trade</td>
</tr>
<tr>
<td>Trade Type (buy or sell)</td>
<td>Numeraire</td>
</tr>
<tr>
<td>Tax Lot Number (for tax-enabled portfolio databases)</td>
<td>Portfolio</td>
</tr>
<tr>
<td>Price per Share</td>
<td>BARRA ID</td>
</tr>
<tr>
<td></td>
<td>Asset Name</td>
</tr>
<tr>
<td></td>
<td>Cost Basis</td>
</tr>
<tr>
<td></td>
<td>Trade - Buys</td>
</tr>
<tr>
<td></td>
<td>Trade - Sells</td>
</tr>
</tbody>
</table>

⚠️ **Note:** If you’re importing trades into an after-tax portfolio database, there are additional guidelines you’ll need to follow. For complete information, see “Creating an After-Tax Portfolio Database” on page 107.
For Holdings

<table>
<thead>
<tr>
<th>Required</th>
<th>Optional</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asset ID</td>
<td>ID Type</td>
</tr>
<tr>
<td>Holding</td>
<td>Date</td>
</tr>
<tr>
<td></td>
<td>Price</td>
</tr>
<tr>
<td></td>
<td>Market Value</td>
</tr>
<tr>
<td></td>
<td>Numeraire</td>
</tr>
<tr>
<td></td>
<td>Portfolio</td>
</tr>
<tr>
<td></td>
<td>BARRA ID</td>
</tr>
<tr>
<td></td>
<td>Asset Name</td>
</tr>
</tbody>
</table>


Chapter 5

Aegis Automation Assistant

- Creating an Automation Case
- Adding an Automation Task
- Executing your Own Batch File
- Adjusting the Automation Queue
- Changing System Preferences
- Setting Error Handling Options
- Running an Automation Case
Introducing Aegis Automation Assistant

The Aegis Automation Assistant helps you maximize your use of Aegis by automating common tasks in Portfolio Manager, Performance Analyst, and Portfolio Accountant. You can specify the tasks ahead of time and then schedule Automation Assistant to execute them at your convenience (such as overnight) either on a one-time basis at a specific time and date, or on a recurring daily, weekly, or monthly frequency.

For example, you can:

- Simultaneously generate all the reports provided in Aegis Portfolio Manager for as many portfolios as you like.
- Optimize one or more portfolios for a single date or for a specific time period and frequency (such as every six months for the last five years) to test your investment strategies over time.
- Automate Multiple Portfolio Comparison reporting.
- Generate the performance reports available in Aegis Performance Analyst and save the resulting file for easy viewing by other users.
- Incorporate your own data (such as alphas, bounds, and industry classifications) into risk reporting and optimizations.
- Integrate optimization and performance reporting by analyzing the performance of an optimal portfolio over time.
- Automatically update your portfolio databases or import your accounting system files into Portfolio Accountant in bulk.
- Have Automation Assistant execute your own batch files as part of the automated processing queue.

**Note:** Because Automation Assistant performs tasks from other Aegis applications (such as Performance Analyst and Portfolio Accountant), it helps to have an understanding of those applications when you define the tasks in Automation Assistant. For detailed information about an Aegis application, see that application's online help.
Basic Steps for Automation Assistant

The basic steps to use Automation Assistant are:

1 **Create a new automation case.** An automation case is a set of tasks (such as risk reports and/or optimizations) that you have chosen to be executed automatically. These “automation tasks” are organized in the automation case by model and task. You can save your automation cases, so you can easily execute different sets of tasks depending on your needs.

2 **Choose the automation tasks you want in the automation case.** Automation tasks tell Automation Assistant which portfolios to process, benchmark and market portfolios to use, reports to produce, timespans, portfolio parameters, and numeraire currency perspectives. Automation tasks can create risk reports, perform optimizations, create multiple portfolio comparison reports, generate performance reports, and update portfolio databases.

3 **Define the settings for each task** (reports to produce, time period to use, destination directory, etc.).

4 **Add the task to the processing queue.** Even after adding a task to the queue, you can edit it, delete it, or move it to a higher or lower position in the processing order.

5 You can also set system-wide preferences for Automation Assistant and set error handling criteria for the automation runs. You may also want to review the file naming conventions to see what the names of the output files will be.

6 Once you have set up your automation case you can **run the case.** Ordinarily, this means scheduling a time for the case to be run. At the specified time, Automation Assistant will run through the automation case and execute each task for each model in the case. The results will be printed or written to the destinations you specified.

7 To review the completed process, if necessary, you can check Automation Assistant’s log files.
Creating an Automation Case

An automation case is organized by model and task. Each model has a separate workspace that displays only files for that model.

To create an automation case:

1. Clear the workspace of any previously entered data by selecting the File > New.

2. Select the model from the Model dropdown menu at the top of the screen. Models must be mapped in Aegis Portfolio Manager or Aegis Performance Analyst to appear in the dropdown.

To open an existing automation case:

1. Select File > Open.

2. Locate and select the case you want.

3. Click Open.
Adding an Automation Task

To add an automation task:

1. Choose Edit > Add or click the button.
   
   ❖ Tip: You can also double-click on an empty automation task row to add an automation task to the selected row.

2. In the Add Automation dialog, select the automation type you want to add:

<table>
<thead>
<tr>
<th>Choose This</th>
<th>To Do This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Risk Reports</td>
<td>Simultaneously generate any of the risk reports available in Aegis Portfolio Manager.</td>
</tr>
<tr>
<td>Optimization</td>
<td>Optimize a portfolio for a single date or for a specific time period and frequency (such as every six months for the last five years) to test your investment strategies over time.</td>
</tr>
<tr>
<td>Optimization with Risk Reports</td>
<td>Optimize a portfolio and generate any of the available risk reports on the resulting optimal portfolio.</td>
</tr>
<tr>
<td>Multiple Portfolio Risk Reports</td>
<td>Automate Multiple Portfolio Comparison Reporting</td>
</tr>
<tr>
<td>Performance Reports</td>
<td>Generate reports from your Aegis Performance Analyst Favorites folder and save the performance results to share with other Performance Analyst users.</td>
</tr>
<tr>
<td>Multiple Portfolio Performance Reports</td>
<td>Run a performance analysis with multiple portfolios.</td>
</tr>
<tr>
<td>Performance Reports on Preceding Time Series Optimizations</td>
<td>Run a performance analysis on an optimal portfolio over time.</td>
</tr>
<tr>
<td>Portfolio Database Updates</td>
<td>Import files from your accounting system into Aegis Portfolio Accountant.</td>
</tr>
<tr>
<td>Batch file</td>
<td>Have Automation Assistant execute a batch file of your own.</td>
</tr>
</tbody>
</table>
Automating Risk Reporting and Optimization

Automation Assistant lets you set the automation criteria for:

- **Risk Reports** - You can simultaneously generate any of the risk reports available in Aegis Portfolio Manager for as many portfolios and dates as you want.

- **Optimization** - You can optimize one or more portfolios for a single date or for a specific time period and frequency (such as every six months for the last five years).

  Optimizing over a time period (known as a “time-series optimization”) lets you test your investment strategies over time. Automation Assistant optimizes your initial portfolio, then uses the resulting optimal portfolio as the initial portfolio for the next optimization, and so on through the time period you specify.

- **Both** - You can optimize a portfolio and generate any of the available risk reports on the resulting optimal portfolio. (For time-series optimizations, risk reports will be generated off each optimized portfolio for the corresponding analysis dates.)

**Before You Begin**

The risk data or optimization that Automation Assistant generates is based on the settings you’ve defined for your portfolio in Aegis Portfolio Manager. The settings can be specified in Portfolio Manager as either:

- A **strategy** (a collection of settings you can create, save, and then use with any portfolio within the same model). A strategy is useful for implementing your firm's investment guidelines that could apply to any portfolio in the model, such as trading restrictions, weighting parameters, and so on.

- Part of the portfolio’s **environment** (settings specific to the portfolio, saved whenever you save the portfolio). The portfolio environment could contain elements you want to use with that particular portfolio, such as a benchmark or universe.
You can also include your own variables (such as alphas, asset bounds, and industry classifications) in the strategy or portfolio environment by importing user data files into Portfolio Manager.

Therefore, before you can automate risk reports or optimization in Automation Assistant, you must:

- **Create the strategy or environment** for your portfolio in Aegis Portfolio Manager. (You do so in the Settings tabbed dialog.)

- **Import user data and/or user industry files** into Portfolio Manager and specify the variables in the strategy or portfolio environment (if you want to include your own variables in the automation).

  Automation Assistant lets you import user data/industry files with multiple variables *during* an automation (so you can use new data, for example), but if those variable names haven’t been specified in the strategy or environment, Automation Assistant won’t recognize or include them in your analysis.

- **Create a Favorite report group.** Each group should include a set of desired reports for a particular Risk Automation. (You can generate the entire group of reports or individual reports within the folder.)

For more information on creating a strategy or environment, please see Portfolio Manager’s online help.
To set up risk reports or optimization:

1. From the main screen, choose **Edit > Add**, or click the button.

2. Select the type of automation you want (Risk Reports, Optimization, or Optimization with Risk Reports) and click **OK**. The following dialog appears:

3. Define the following settings:
Portfolio Information

- From the dropdown list, choose the format of the portfolio you want to use (so Automation Assistant will know how to find the portfolio file or list of holdings, depending on the dates you specify for the Time Period).
- Click the button to locate the portfolio you want to report on or optimize.
- Select a strategy from the dropdown, if desired.
- Check the Use Portfolio-Specific Settings checkbox if you want to use the settings in the portfolio’s environment file.

Note: Portfolio-specific settings take priority over any parameters also in the selected strategy.

- In Global Equity Models, you can select a new numeraire for the automation task using the dropdown menu. This creates a new numeraire for the automation task only. The original portfolio numeraire remains the same.

Benchmark Information

- From the dropdown list, choose the format of the portfolio you want to use for your benchmark (so Automation Assistant will know how to find the portfolio file or list of holdings, depending on the dates you specify for the Time Period).
- Click the button to locate the portfolio you want to use for your benchmark. If the benchmark is stored in a dated directory (Barra-supplied or not), you can simply type the portfolio name in the text box. If stored elsewhere, use the button to browse for it.

Note: The selected benchmark will supersede any strategy or portfolio-specific settings. For optimizations, this setting will not work in conjunction with a strategy containing a long-short optimization, but will work with each of the other optimization types.
Market Information

- Select the format of the portfolio you want to use for your market information.
- Click the button to locate the portfolio you want to use for your market information.

**Note:** The selected portfolio will supersede any strategy or portfolio-specific settings. For optimizations, this setting will only work in conjunction with a strategy containing a long-short optimization, but will work not with each of the other optimization types.

Universe Information

You can add universe assets to your managed portfolio and include universe assets in your risk reports. To do this:

- In Portfolio Manager, enable the preference **Add universe assets when loading a portfolio**.
- In Automation Assistant, specify a universe portfolio. This can be a Barra-provided portfolio or your own user portfolio. Click the button to locate the portfolio you want to use for your universe.
- Select the format of the portfolio you want to use for your universe.

User Settings

- Click **User Data** if you want to incorporate your own data (alphas, bounds, transaction costs, etc.) in the reports or optimization. (These variables must be specified in either the strategy or the environment to be included in the analysis.)
- Click **User Industries** if you want to incorporate your own industry data in the reports or optimization. Constraints on user industries must be specified either in the strategy or the environment.

**Note:** If you provide a user industry file that contains more than one column of industry classifications, selecting the user industry report option will generate one report per user industry variable provided, up to a maximum of five.
Time Period

- Set the Start and End Dates, and the Frequency of the reports or optimization. For example, if you select a 12-92 start date and a 12-95 end date, and a Semi-Annual frequency, reports are generated every six months within that three year period.

- If you select Daily as a Frequency, you can select any date in the model as a Start and End Date.

  If you select Weekly, select the day of the week (Monday to Friday) that you would like to rebalance your portfolio in the Day of the Week dropdown. The start and end dates reflect the dates for the weekday you selected. (If the weekday is a holiday, the preceding trading day will be used.)

  If you select Monthly, Quarterly, Semi-Annually, or Annually, you can select end-of-month dates for Start Date and End Date.

  **Note:** You can also select Latest for both start end dates, which uses the latest installed date during the runtime of the automation case. For example, If you select Latest, then schedule a BarraLink download for 1a.m. and run the Automation Assistant at 3 a.m., the newly downloaded model date is used.

Additional Settings

- Click Risk Report Settings to set the desired report criteria. See page 144.

- Click the Optimization Settings button to specify a universe portfolio and to set the path and format for the resulting optimal portfolio. See page 145.

- In Global Equity Models, you can select a new numeraire for the automation task using the dropdown menu. This creates a new numeraire for the automation task only. The original portfolio numeraire remains the same.
4 If you want Automation Assistant to use your settings as the defaults, click **Save as Default**.

5 When you are done defining the parameters for this automation task, click **Add to Queue**.

**Report Settings**

In the Report Settings dialog, you select the reports you want to generate and their destination (printer or file).

1 From the Risk Reports or Optimization dialog (see page 140), click the **Report Settings** button. The following dialog appears:

![Report Settings Dialog](image)

**Report Options**

- From the Favorite Reports dropdown list, choose the “Favorites” folder you want to use (from those created for the current model in Portfolio Manager). You can select individual reports within a Favorites folder, or the entire folder. Selecting a Favorites folder will include all reports in that folder but not the subfolders and reports contained beneath the selected folder.
Report Destination

- Select the **Printer** radio button if you want to print the reports.
- Select the **File** radio button if you want to print the reports to a file. Use the **...** button to specify the destination directory for the reports, and select the format you want for the report file (.xls, .csv, .htm, .txt, .bmp, or .jpg) and name the report.

2 If you want Automation Assistant to use your settings as the defaults, click **Save as Default**.

3 When you finish defining the parameters for Risk Reports, click **OK**.

Optimization Settings

Automation Assistant lets you optimize one or more portfolios for a single date or for a specific time period (such as every six months for the last five years) to test your investment strategies over time.

In the Optimization Settings dialog, you specify the destination directory for the optimized portfolios.
To specify the optimization settings:

1. From the Risk Reports or Optimization dialog (see page 140), click the Optimization Settings button. The following dialog appears:

![Optimization Settings dialog](image)

Save Optimized Portfolios

- From the dropdown list, choose the format you want to save the portfolio in. You can choose to output dated portfolios (.yym), daily portfolios (.yyyymmdd) for daily optimizations, or Portfolio Accountant portfolio databases.

▶ Note: If you save the portfolios as portfolio databases, you must be aware of the following:

- If you use Automation Assistant’s default destination and name for your optimized portfolio databases (instead of specifying your own), the files will be overwritten the next time another automation case is run using the same default destination and name.
• If you specify a path but use the default name, any existing *registered* database in that path using the default name will *not* be overwritten. The optimization will not be completed, and Automation Assistant will move on to the next automation task in the queue. Any existing *unregistered* database in that path using the default name will be overwritten.

• If you specify both the path and the database name and there is an existing database (registered or unregistered) with the same name in that path, then Automation Assistant will overwrite the existing database.

• Click the button to specify the destination directory for the optimized portfolios.

• Type a name for the file.

**Export Alphas to File**

• If you would like to generate expected returns from your optimization, check the box **Export Alphas to File**. You can use this feature as a way to check the expected returns that are submitted to the optimizer.

• Select a date format, a directory in which to save the files, a base name for the files, and a file type (XLS or CSV). The resulting file will have that name and extension and will appear in the directory you specified. One file will be saved for each date.

2 If you want Automation Assistant to use your settings as the defaults, click **Save as Default**.

3 When you are done defining the parameters for optimization, click **OK**.
User Data Settings

Automation Assistant allows you to import custom data during the automation process so you can incorporate it in the reports or optimization. In the User Data dialog, you specify the location of the data you want to incorporate, so Automation Assistant will be able to find it. (your variable names must be specified in either the strategy or the portfolio environment to be included in the analysis. For complete information on importing user data, including the format Aegis requires, see Portfolio Manager’s online help.)

Note: The user data is imported temporarily, just for the purpose of the automation. It does not permanently update your asset database.

To specify the User Data settings:

1. From the Risk Reports or Optimization dialog (see page 140), click the User Data button. The following dialog appears:
One File for Each Date

Click this radio button if your data is currently stored in dated files (where one file holds the data for one date). For example, US992.xls could be an Excel file of US data for February 1999.

- Click the button to specify the directory where the data is located.
- Type the prefix you use to identify the dated file (such as US in the example above).
- Select the date format the file uses.
- Select the extension (.xls or .csv) the file uses.

One File for All Dates

Click this radio button if your data for all dates is currently stored in a single file. For example, you could have an Excel file containing multiple data types for multiple dates.

- Click the button to specify the directory where the data is located.

Optimize when User Data Available

If you would like the optimizer to start only when user data for the selected model exists, check Optimize when user data available. Aegis looks for the user data for the amount time you specify in the error handling preference for user data (see page 175).

Use Assets with expected Returns Only

If you want the optimizer to use only the universe assets to which you have assigned an alpha and ignore assets that don't have any alpha value assigned, check Use assets with expected returns only. This is useful, for example, if you are running different long-short backtesting strategies to find out which strategy worked best historically.
You can specify user data settings as detailed above. If you would like to use the specified user data in the automation, check **Use User Data**.

*Note:* If the **Use User Data** option is enabled and Aegis cannot locate your user data, the automation will not continue. If a single month or day of user data is missing, the error handling preferences will be obeyed.

3. If you want Automation Assistant to use your settings as the defaults, click **Save as Default**.

4. When you are done, click **OK**.

**User Industries Settings**

Automation Assistant allows you to import your own industry classifications during the automation process so you can incorporate them in the reports or optimization. In the User Industries dialog, you specify the location of the data you want to include, so Automation Assistant will be able to find it. (your variable names must be specified in either the strategy or the portfolio environment to be included in the analysis. For complete information on importing user industries, including the format Aegis requires, see Portfolio Manager's online help.)

*Note:* The user industries are imported *temporarily*, just for the purpose of the automation. They are not permanently written to your list of industries.
To specify the User Industries settings:

1. From the Risk Reports or Optimization dialog, click the User Industries button. The following dialog appears:

![User Industries dialog](image)

**One File for Each Date**

Click this radio button if your data is currently stored in dated files (where one file holds the data for one date). For example, US992.xls could be an Excel file of US data for February 1999.

- Click the button to specify the directory where the data is located.
- Type the prefix you use to identify the dated file (such as US in the example above).
- Select the date format the file uses.
- Select the extension (.xls or .csv) the file uses.

**One File for All Dates**

Click this radio button if your data for all dates is currently stored in a single file. For example, you could have an Excel file containing multiple data types for multiple dates.

- Click the button to specify the directory where the data is located.
2 You can specify user industry settings as detailed above. If you would like to use the specified user data in the automation, check Use User Industries.

➤ Note: If the Use User Industries option is enabled and Aegis cannot locate your user industries, the automation will not continue. If a single month or day of user data is missing, the error handling preferences will be obeyed.

3 If you want Automation Assistant to use your settings as the defaults, click Save as Default.

4 When you are done, click OK.

Automating Multiple-Portfolio Comparison Reporting

Automation Assistant allows you to set the automation criteria for multiple portfolio comparison reporting.

To set up multiple portfolio risk reports:

1 From the main screen, choose Edit > Add or click the button.

2 Choose Multiple Portfolio Risk Reports and click OK. The following dialog appears:
Define the following settings:

**Select MPC Case**

- Locate the MPC Case you want to use by clicking the [ ] button. A case is simply the list of portfolios to be analyzed. You create MPC cases in the Aegis Portfolio Manager. (For complete information on analyzing multiple portfolios, see Portfolio Manager's online help.)
Time Period

- Set the start and end dates, and the frequency of the reports. For example, if you select a 12-92 start date and a 12-95 end date, and a Semi-Annual frequency, reports are generated every six months within that three year period.

- If you select Daily frequency, you can select any date in the model as a start and end date. If you select Monthly, Quarterly, Semi-Annually, or Annually, you can select end-of-month dates for Start Date and End Date.

Note: You can also select Latest for both start and end dates, which uses the latest installed date during the runtime of the automation case. For example, If you select Latest, then schedule a BarraLink download for 1 a.m. and run the Automation Assistant at 3 a.m., the newly downloaded model date is used.

Select Reports

- Select the reports you want to generate by clicking the check boxes.

Report Destination

- Select the Printer radio button if you want to print the MPC. Click the printer setup button to configure the printer following standard Windows procedures.

- Select the File radio button if you want to print the MPC to a file. Use the button to specify the destination directory for the report, and select the format you want for the MPC report file (.xls, .csv, or .htm).

4 If you want Automation Assistant to use your settings as the defaults, click Save as Default.

5 When you are done defining the parameters for this automation task click the Add to Queue button.
Automating Single-Portfolio Performance Reports

Automation Assistant lets you generate the performance reports available to you in your Aegis Performance Analyst “Favorites” folder. (For specific details about Performance Analyst Favorites folders, see the Performance Analyst online help.)

Before You Begin

Before performance reports can be created, several tasks must be completed in Performance Analyst. Please note that steps A and B may need to be repeated on an ongoing basis each time you want to generate updated performance reports using Automation Assistant:

(a) Create and/or update your Attribution Data Source. The attribution data source should have all of your portfolios (including benchmarks and markets) processed for the aggregate time span. You can update the ADS with Automation Assistant.

(b) Import any user data for transaction costs and return reconciliation.

(c) Create a Favorite report group. Each group should include a set of desired reports for a particular Performance Automation.

To set up performance reports:

1 Select a model from the dropdown list in the main screen.

2 Choose Edit > Add, or click the button.

3 Select Performance Reports and click OK. The following dialog appears:
4 Define the following settings:

Selecting and Updating your Attribution Data Source

- Click the Select ADS button to choose the attribution source for the reports. Use the Map button if the desired attribution source is not currently listed, and browse to locate the desired Attribution Data Source definition file (perfat.def).

  Note: Automation Assistant will not allow you to choose an Attribution Data Source that does not match the active model.

- If you have Aegis model data available beyond what is currently processed in the Attribution Data Source, you can choose to extend the ADS with this data. This means that all portfolios in the
attrition data source will be updated to the months you specify. To do this, check the box **Extend ADS if more recent model data is available**. Then change the end date to a later end date.

- In order to update the ADS with a range of dates, you must have each date in the range available. If you have missing portfolios, you can select to have these extrapolated to create a contiguous time span, using the **Extrapolate missing user portfolios if necessary** checkbox. This does not apply to Barra-supplied portfolios.

**Managed Portfolio, Timespan, and Return Reconciliation**

- From the Portfolio dropdown list, choose the portfolio you want to report on.

  The Start and End dates default to the timespan processed for the managed portfolio in Performance Analyst. You can change them by choosing other dates from the dropdown lists. As an alternative, you can choose a **Trailing Time Period**, which defines the timespan as a period of time back from the end date, such as six months, one year, etc. **Latest** will set the end date to the most recent available Attribution Data Source date.

- If you’ve imported user-supplied returns for the current model for the same timespan that you’ve selected for the managed portfolio, you can choose the User Return you want from the dropdown list.

- For Transaction Costs, you can choose **None**, **Estimated** (Barra-calculated), or **User**. (If you’ve imported user-supplied transaction costs for the current model for the same timespan that you’ve selected for the managed portfolio, choose the one you want from the dropdown list).
Benchmark and Market Information

- From the Portfolio dropdown list, choose the benchmark portfolio you want to use.
- You can choose the User Return you want for the benchmark from the dropdown list if the time span of your user returns matches the time span you've selected for the managed portfolio.
- If you are using a single-country model, choose the market portfolio you want to use. The list includes all portfolios in your ADS processed for the dates you specified.
- If you are using a single-country model, adjust the Risk Premium, if desired.

Miscellaneous Settings

- Select your risk index (Style), industry (Sector), and currency (Numeraire) settings and your country (Region) mappings. You can select from Barra defaults or your own mappings. (To learn how create your own mappings, see Performance Analyst online help).
- For single-country models, select your Style and Sector mapping.
- For global models, choose the Region and Sector mapping, and Numeraire you want to use.

Report Options

- From the Favorite Reports dropdown list, choose the “Favorites” folder you want to use (from those created for the current model in Performance Analyst).

▶ Note: Selecting a Favorite group will include only the reports contained in the selected folder. For example, selecting “\Favorites\A” would include “\Favorites\A\Total_Monthly_Attribution” but not “\Favorites\A\subgroup\Active_Monthly_Attribution,” nor “\Favorites\B\Total_Monthly_Attribution.”

- If you would like to save the performance results file (.pfn file) to share with other Performance Analyst users, click in the Results File Name textbox to specify the file name and location to save the results.
Report Destination

Specify whether to send the reports to the printer or a file.

- Click Printer Setup to adjust the printer settings, if desired. The print orientation (portrait or landscape) is determined by the Report Properties function in Performance Analyst, regardless of what you select in the Print Setup dialog. For more information on print orientation and Report Properties, see Performance Analyst online help.

- To save the report to a file, click to choose the directory, select the file format from the dropdown list, and enter the file name.

  Tip: You can create a new folder by typing it as part of the path in the Directory field.

5 Click Save as Default to have Automation Assistant use your Report Options and Report Destination as the defaults. (The other settings are not saved because they depend on the attribution source you choose for the reports.)

6 When you are done defining the settings for this automation task, click Add to Queue.
Automating Multiple-Portfolio Performance Reports

Automation Assistant lets you input multiple portfolios to generate the performance reports available to you in your Aegis Performance Analyst “Favorites” folder. (For specific details about Performance Analyst Favorites folders, see the Performance Analyst online help.)

Before You Begin

Before performance reports can be created, two tasks must be completed in Performance Analyst. Please note that step “b” may need to be repeated on an ongoing basis each time you want to generate updated performance reports using Automation Assistant:

(a) Create your Attribution Data Source. The ADS should have all of your portfolios (including benchmarks and markets) processed for the aggregate time span. You can update the ADS with Automation Assistant using the Extend feature (see below).

(b) Import any user data for transaction costs and return reconciliation.

(c) Create a Favorite report group. Each group should include a set of desired reports for a particular Performance Automation. You must have a unique set of Favorites for multiple- and single-portfolio analysis.

(d) If you are generating performance reports for multiple portfolios, define a multiple-portfolio analysis in Performance Analyst. (To learn more, see “Creating a Multiple-Portfolio Analysis” in the Performance Analyst online Help.)

To set up performance reports:

1. Select a model from the dropdown list in the main screen.

2. Choose Edit > Add or click the button.

3. Select Multiple Portfolio Performance Reports and click OK. The following dialog appears:
4 Define the following settings:

Selecting and Updating your Attribution Data Source

- Click the Select ADS button to choose the attribution source for the reports. Use the Map button if the desired attribution source is not currently listed, and browse to locate the desired Attribution Data Source definition file (perfat.def).

  Note: Automation Assistant will not allow you to choose an Attribution Data Source that does not match the active model.

- If you have performance data available beyond what is currently processed in the Attribution Data Source, you can choose to extend the ADS with this data. To do this, check the box Extend ADS if more recent model data is available.
• In order to update the ADS with a range of dates, you must have each date in the range available. If you have missing portfolios, you can select to have these extrapolated to create a contiguous time span, using the **Extrapolate missing user portfolios if necessary** checkbox.

**Loading Previously Saved Settings**
• If you set up and saved multiple portfolio analysis settings in Performance Analyst or Automation Assistant (using the **Save** button), press the **Load** button at the bottom of this dialog to retrieve them. If not, select the settings as outlined below.

**Managed Portfolio, Time Span, and Return Reconciliation**
• Make a list of managed portfolios that you would like to report on by selecting them in the **Portfolio Name** column.
• If you would like to remove a portfolio from this list, either:
  • Highlight the row and press delete, or
  • Re-select a portfolio for that row and select the blank row from the list of available portfolios.
• The start and end dates default to the time span processed for the managed portfolio in Performance Analyst. You can change them by choosing other dates from the dropdown lists. As an alternative, you can choose a **Trailing Time Period**, which defines the time span as a period of time back from the end date, such as six months, one year, etc. **Latest** will set the end date to the most recent available Attribution Data Source date, or, if you are extending your ADS (see paragraphs above), the last date for which you have contiguous data.
• If you’ve imported user-supplied returns for the current model for the same time span that you’ve selected for the managed portfolio, you can choose the User Return you want from the dropdown list.
• For Transaction Costs, you can choose **None**, **Estimated** (Barra-calculated), or **User**. (If you’ve imported user-supplied transaction costs for the current model for the same time span that you’ve selected for the managed portfolio, choose the one you want from the dropdown list).
Benchmark and Market Information

- From the Portfolio dropdown list, choose the benchmark portfolio you want to use. The list includes all portfolios in your ADS processed for the dates you specified.
- You can choose the User Return you want for the benchmark from the dropdown list if the time span of your user returns matches the time span you've selected for the managed portfolio.
- If you are using a single-country model, choose the market portfolio you want to use. The list includes all portfolios in your ADS processed for the dates you specified.
- If you are using a single-country model, adjust the Risk Premium (in percent), if desired.

Miscellaneous Settings

- Select your risk index (Style), industry (Sector), and currency (Numeraire) settings and your country (Region) mappings. You can select from Barra defaults or your own mappings. (To learn how create your own mappings, see Performance Analyst Help).
- For single-country models, select your Style and Sector mapping.
- For global models, choose the Region and Sector mapping, and Numeraire you want to use.

Report Options

- From the Favorite Reports dropdown list, choose the “Favorites” folder you want to use (from those created for the current model in Performance Analyst). You can select individual reports within a Favorites folder, or the entire folder. Selecting a Favorite group will include only the reports contained in the selected folder. For example, selecting “\Favorites\A” would include “\Favorites\A\Total_Monthly_Attribution” but not “\Favorites\A\subgroup\Active_Monthly_Attribution,” nor “\Favorites\B\Total_Monthly_Attribution.”
- If you would like to save the performance results file (.pfn file) to share with other Performance Analyst users, click in the Name textbox to specify the file name and location to save the results.
Report Destination

- Specify whether to send the reports to the printer or a file.
- Click Printer Setup to adjust the printer settings, if desired. The print orientation (portrait or landscape) is determined by the Report Properties function in Performance Analyst, regardless of what you select in the Print Setup dialog. For more information on print orientation and Report Properties, see Performance Analyst online help.
- To save the report to a file, click to choose the directory, and choose the file format from the dropdown list.

Note: You can create a new folder by typing it as part of the path in the Directory field.

5 Click Save as Default to have Automation Assistant use your Report Options and Report Destination as the defaults. (The other settings are not saved because they depend on the attribution source you choose for the reports.)

6 If you would like to save the ADS and portfolio settings you have selected in this dialog as a file to use in Automation Assistant or Performance Analyst, press Save. You can then restore these settings anytime you want to reconstruct this analysis by pressing Load from this dialog in Automation Assistant or Performance Analyst.

7 When you are done defining the settings for this automation task, click Add to Queue.
Automating Performance Reports on Time Series Optimizations

Automation Assistant lets you integrate optimization and performance reporting, making it easy to combine the power of these analytical tasks. Here’s how:

- You add a time-series optimization to the automation queue, to optimize your portfolio over a period of time (such as every six months for the last five years) so you can test its strategy. (See “Automating Risk Reporting and Optimization” on page 138.)

- As the next automation task in the queue, you set up a performance attribution on the preceding time-series optimization which will analyze the optimal portfolio’s performance over the same timespan.

When you run the automation case, Automation Assistant executes the optimization and then runs a performance analysis on the output optimal portfolio, using the optimization settings as the parameters for performance processing.

Note: To optimize multiple portfolios, you can add multiple time-series optimizations (with the same timespan) to the queue, one after another, and Automation Assistant will run a performance analysis on them all. Make sure to give the optimized portfolios different names for each time series optimization, so that each portfolio will be unique in the attribution data source and performance report file output.

To generate performance reports on preceding time-series optimizations:

1. Create a time-series optimization task and add it to the automation queue.

2. Double-click the empty row below the optimization task to display the list of automations.
3 Choose **Performance Reports on Preceding Time-Series Optimizations**, and click **OK**. The following dialog appears:

4 Choose the Risk Premium you want. (This is only for single-country equity models.)

5 Choose the Favorite Report Group you want to generate.

6 Define the following settings:

   **If Benchmark/Market Not Specified in Case**

   Different types of optimizations use benchmark and market portfolios differently. In a standard optimization, for example, you cannot specify a market. In a long-short optimization, you cannot specify a benchmark.
Performance analysis, however, requires both a benchmark and a market (just a benchmark in global models). You must therefore tell Automation Assistant what to use if a benchmark or market portfolio is not specified in the optimization case. You can:

- Choose a cash portfolio in place of a benchmark or market.
- Specify a particular portfolio or database as the benchmark or market. Choose the format from the dropdown list, then click the button to locate the portfolio or database you want.

**Report Destination**

Specify whether to send the reports to the printer or a file.

- To save the report to a file, click the button to choose the directory, and choose the file format from the dropdown list.

**Performance Results**

- To save the results as a performance results file (.pfn file) which can be shared with other Performance Analyst users, check the Generate Results File checkbox and click the button to specify the location.
- To save the attribution database so you can use it again to generate performance reports, check the Save Attribution DB checkbox and click the button to specify the location.

7 If you want Automation Assistant to use your settings as the defaults, click Save as Default.

8 When you are done defining the settings for this automation task, click Add to Queue.
Automating Portfolio Database Updates

Automation Assistant lets you update your portfolio databases by importing data in bulk into Portfolio Accountant. (For specific details about Portfolio Accountant, see the Portfolio Accountant online help.)

As part of an ongoing process, this automation can be used to update a portfolio database from files generated by your accounting system or your trade order management system. If you are unable to have these files generated to a particular directory that will be accessible to Automation Assistant, try using the batch file automation to copy over new files to the directory selected in step 3. (See “Executing your Own Batch File” on page 170.)

To update your portfolio databases:

1. From the main screen, choose Edit > Add or click the button.

2. Select Portfolio Database Updates and click OK. The following dialog appears:
3. Click the button, select the directory where the files to be imported are located, and click OK. All the files in the directory are then listed in the Details section of the dialog.

4. If you want to import all the files into the same portfolio database, check the Use same database for all files checkbox and choose the portfolio database from the dropdown list.

5. If you want to use the same mapping case for all the files (for example, if they are all holdings files in the same format), check the Use same mapping case for all files checkbox and choose the mapping case from the dropdown list.

6. In the Inc (“Include”) column of the spreadsheet, check the checkboxes of the files you want to import, and for each one choose a portfolio database name and mapping case from the dropdown menus.

   ✻ Tip: Click the Inc column heading to check or uncheck all the checkboxes.

   If any files are in Barra format, their Mapping Case field will show Not Needed because Portfolio Accountant recognizes them automatically.

   ▶ Note: If you chose to use the same portfolio database or mapping case for all files in step 4 or 5, you can't access the portfolio database name or mapping case dropdown menus in the spreadsheet.

7. If you want Automation Assistant to use your settings as the defaults, click Save as Default.

8. When you are done defining the settings for this automation task, click Add to Queue.
Executing your Own Batch File

For advanced users: You can add your own batch file to the automation queue so Automation Assistant will execute it as part of its automation processing.

To add your own batch file:

1. From the main screen, choose Edit > Add Automation or click the button.

2. Select Batch file and click OK.

3. Locate and select your batch file. Automation Assistant adds it to the processing queue.

   Note: If you insert your file anywhere except at the end of the list of automation tasks, you should specify how long a timeout Automation Assistant should take to allow the batch file to finish processing before continuing on with other tasks in the queue. You specify the timeout in the Error Handling dialog. If you place your batch file at the end of the list, no timeout is necessary. (For details on error handling, see “Setting Error Handling Options” on page 173.)

Adjusting the Automation Queue

Even after adding a task to the queue, you can edit it, delete it, or move it to a higher or lower position in the processing order.
Editing an Automation Task

You can edit any existing automation tasks in your automation case. To do so:

1. Highlight the row that contains the automation task you want to edit.
2. Click on the button, or select Edit > Edit.
   ➫ Tip: You can also double click on any row to edit the automation task.

Deleting an Automation Task

You can delete automation tasks from your automation case. To do so:

1. Highlight the row or rows of automation tasks that you want to remove from your automation case.
2. Click on the button, or select Edit > Delete.

Moving an Automation Task

You can move any automation task up or down in the list of tasks for the selected model. This allows you to decide the order in which the automation tasks are processed. To move an automation task:

1. Highlight the automation task.
2. Click the button to move the automation task up a row. You can click on the up button multiple times to move selected automation task up several rows.
3. Click the button to move the automation task down a row. You can click on the down button multiple times to move selected automation task down several rows.
Changing System Preferences

The Automation Assistant allows you to identify default directories for both input data and output data.

To set the system preferences:

1. Select System > Preferences.

2. Select a model from the Model dropdown at the bottom of the dialog. The Default Directories box allows you to specify the following default directories:
   - Input Portfolio
   - Benchmark Portfolio
   - Market
   - User Data
   - Universe
   - Output
   - Portfolio Report
   - MPC Case
   - MPC Report

3. In the Default Directory box, click the button and select a directory path for each directory type.

4. When you are done selecting your default directories click OK.
**Setting Error Handling Options**

During an automation run, when the Automation Assistant is processing the automation cases, two log files—the log file and the ADT log file—are created. Each file provides information about the processing of the automation cases. This is valuable information for troubleshooting system problems.

In the Error Handling dialog, you specify what directory you want the log files stored in. You can also specify whether/how Automation Assistant should proceed if model or portfolio data cannot be found during processing.

▶ **Note:** When you use Automation Scheduler to schedule and execute your automation cases, the Scheduler creates cumulative logs of all cases processed.

If you run an automation case *yourself* rather than scheduling it for automatic processing through the Scheduler, Automation Assistant creates logs for *that case only*. If you then run another case yourself, Automation Assistant *overwrites* the log files for the previous case.

If you will be running a series of cases and want to be sure you have log files for all of them, schedule them through the Automation Scheduler rather than running them yourself as separate cases. (For details on scheduling automation cases, see “Scheduling Automation Cases” on page 179.)
To set error handling options:

1. Select System > Error Handling. The following dialog appears:

![Error Handling Dialog]

2. Define the following settings:

**Automation Log**
- Check the checkbox of the log file(s) you want to generate.
- Click the button to choose a directory path and file name for each log file.
- Check the Errors Only box if you want only the errors to be reported in the log file.

**Timeout for Batch Files**

If you are having Automation Assistant run a Batch File of your own, you should specify here how long Automation Assistant should wait for the file to execute before continuing on with other automation tasks in its queue. For example, if you are including a batch file to rename a number of portfolios, you might specify a timeout of two minutes for
the task to be completed before Automation Assistant resumes its other processing. If you add your batch at the end of the queue, no timeout is needed.

Save Adjusted Portfolios

Time-series optimizations optimize portfolios for a specific time period, such as the last six months. Automation Assistant automatically applies Barra-supplied adjustments for corporate actions (such as stock splits and dividends) over the time period. If you want to save the adjustment files (to have a record of the changes), check the **Save adjusted portfolios for Time Series Optimizations** checkbox. Adjustment files are saved in the same location as the output optimal portfolios with _adj appended to the filename, prior to the extension.

If Model Data/Portfolios Missing

To be sure that time-series automations (such as optimizations or risk reporting) work the way you want, you must tell Automation Assistant what it should do if the model or portfolio data it is looking for (for a particular month, for example) is missing. For each tab page, specify whether Automation Assistant should:

- **Abort automation.** If you want the automation process to end immediately if the model/portfolio data cannot be found, click this option.

- **Use old dates for ______.** If you want Automation Assistant to use older data when it cannot find the date it needs, click this option and specify the number of days, months, quarters, or years.

  For example, if you specify 2 months and Automation Assistant cannot find the portfolio for a particular month, it looks for the next most recent portfolio that is two months old or less, adjusts it for corporate actions up to the date of the missing portfolio, and uses it in the automation task. If the portfolio is more than two months old, Automation Assistant ends the task and moves on to the next automation in the processing queue.

- **Use old dates indefinitely.** If you want Automation Assistant to use older data regardless of its age, click this option.
• Proceed and look for user data for __ __. (User data only) If you selected “Optimize when user data is available” in User Data Settings (see page 148), select when to stop the automation. For example, if you get data irregularly, but generally no more than 5 months pass between data updates, we suggest that you select 6 months here.

• Use these settings for all missing data types. If you want to use the same settings for all the tab pages, click this button.

Whatever you choose, Automation Assistant will record the process in the log file(s) you’ve specified.

3 Click OK to save your changes.

---

**Saving an Automation Case**

To schedule a case for automatic processing, you must first save it.

**To save an automation case:**

• Select File > Save, or click the button on the tool bar.

The first time you save the file, you must enter the file name and location. Subsequent saving will save the file under the same name and location.

▷ **Note:** To save the automation file under a different name and location, select File > Save As.
Running an Automation Case

Running an automation case generally involves these options:

- **Review** the automation parameters and activities before running the automation.
- **Change** the status of an automation, if necessary.
- **Run** the automation case immediately, if you want to do it yourself.
- **Schedule** automation cases for automatic processing by using the Automation Scheduler.

Reviewing the Case Summary

The Case Summary window provides an overview of all activities to be performed by the automation process and the parameters to be used, sorted by model. You can make any changes necessary before running the automation.

- To view the automation summary, select **View > Case Summary**.
- To exit the summary, click **OK**.

Changing the Status of an Automation

If an automation task has a status of “error” or “completed,” this task will not be processed when you run the automation. To reprocess an automation task with a status of “error” or “completed,” you must change the status of the task. You can reset the status for the current model, for the entire case, or for individual automation tasks within your automation case.

To reset the status of an automation task:

1. Highlight the automation task or tasks you want to reset.
2. Select **Actions > Reset Current Automation**. The status of all automation tasks selected will be changed to **In Queue**.
To reset the status of an entire model:
1. Select the model from the model dropdown menu
2. Select Actions > Reset Current Model. The status of all automation tasks, for the model and automation case displayed, will be changed to In Queue.

To reset the status of an entire automation case:
1. Select Actions > Reset All.
2. The status of all automation tasks within the automation case will be changed to In Queue.

Running an Automation Case Immediately

To run an automation case immediately:

- Select Actions > Run or click the run button on the tool bar.

  The system will process all automation tasks, for all models in the case, that have a status of In Queue. If an automation task has a status of “error” or “completed,” this automation task will not be processed. To reprocess an automation task with a status of “error” or “completed,” you must change the status of the task. For more information see “Changing the Status of an Automation” on page 177.

  Note: Processing Automation Cases can take a significant amount of time and computer resources. You may want to close other applications before beginning.

To run automation cases from DOS, use the following command:

Aegbat32 <name> /r

where <name> is the path of an Aegis Automation Assistant .aaa file.

Calling aegbat32.exe from the command line without passing the “/r” switch will simply start Automation Assistant and load the case, but not run the automation case.
To interrupt the processing of an automation case:

- Click Cancel. The program will complete the current task and then stop.

Scheduling Automation Cases

You can schedule your automation cases to be processed automatically on a one-time basis at a specific time and date, or on a recurring daily, weekly, or monthly frequency.

➤ Note: To schedule an automation case, you must have saved it first. See “Saving an Automation Case” on page 176.

To define the schedule:


2. Choose Edit > Add or click  in the Scheduler tool bar.

3. Click to choose an automation case to schedule.

   ➤ Note: Automation files created prior to version 3.1 of Automation Assistant cannot be used with Automation Assistant 3.2 or later.

4. Choose how often the case should be run (Once, Daily, Weekly, or Monthly).

5. Depending on your choice, specify the appropriate frequency (the date, every so many days, day of the week or month).

6. Specify the execution time.

7. Click OK.

8. You can continue to schedule other automation cases by repeating steps 2-7.
9 When you’ve scheduled all the automation cases you want, choose File > Close.

► Note: When you close the Scheduler window, the Scheduler remains minimized on your computer. It must stay that way for the automation cases to be executed.

Automation Scheduler Log Files

The Automation Scheduler keeps cumulative logs of all cases processed to help you troubleshoot any problems. To specify the directory and file name for the Automation Log and the ADT Log files:

1 Choose System > Automation Log.

2 Click the button and select a directory path and file name for each log file.

3 Check the errors only box if you want only the errors to be reported in the log file.

4 To delete all the accumulated log files, click Clear Files.

5 Click OK.

Viewing the Log Files

After an automation case has been run, you can review the process by checking Automation Assistant’s log files.

To view the log files:

* Select View > Log File or ADT Log File.

The ADT log file contains more detailed information, but both files are useful for reviewing or troubleshooting the automation process.

► Note: The files you can view depend on which file(s) you chose to generate in the Error Handling dialog.
Output File Naming Conventions

Portfolio Manager Reports

Portfolio Manager reports can be sent to the printer or saved as files. The file name is composed of the following parts:

Prefix_Portfolio_Date_Report.Ext

<table>
<thead>
<tr>
<th>This</th>
<th>Means This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prefix</td>
<td>Default: Model abbreviation (U3, FT, FR…)</td>
</tr>
<tr>
<td>Portfolio</td>
<td>File name of the portfolio</td>
</tr>
<tr>
<td>Date</td>
<td>Pricing date in the format yyymm.dd (19971231,</td>
</tr>
<tr>
<td></td>
<td>11980130…)</td>
</tr>
<tr>
<td>Report</td>
<td>Portfolio Manager report type abbreviation (WRK,</td>
</tr>
<tr>
<td></td>
<td>RR…)</td>
</tr>
<tr>
<td>Ext</td>
<td>File format extension (.csv, .xls…)</td>
</tr>
</tbody>
</table>

Multiple Portfolio Comparison

Multiple Portfolio Comparison reports can be sent to the printer or saved as files. The file name is composed of the following parts:

Prefix_Date_MPC_Report.Ext

<table>
<thead>
<tr>
<th>This</th>
<th>Means This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prefix</td>
<td>Default: Model abbreviation (U3, FT, FR…)</td>
</tr>
<tr>
<td>Date</td>
<td>Pricing date in the format yyymm.dd (19971231,</td>
</tr>
<tr>
<td></td>
<td>11980130…)</td>
</tr>
</tbody>
</table>
### Optimizer

Optimizer runs generate optimal portfolios. The naming convention for optimized portfolios is:

- **Filename.Ext**

<table>
<thead>
<tr>
<th>This</th>
<th>Means This</th>
</tr>
</thead>
<tbody>
<tr>
<td>MPC Report</td>
<td>Constant string (MPC) that marks MPC reports. The report type abbreviation: (...)</td>
</tr>
<tr>
<td>Ext</td>
<td>File format extension (.csv, .xls...)</td>
</tr>
</tbody>
</table>

### Performance Reports

Performance reports can be sent to the printer or saved as files. The naming convention for performance reports is:

- **Filename.Ext**

<table>
<thead>
<tr>
<th>This</th>
<th>Means This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filename</td>
<td>File name specified in the Name text box. The default is set to the case name followed by a sequence number.</td>
</tr>
<tr>
<td>Ext</td>
<td>File format extension (portfolio databases .pac, .por, .yym)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This</th>
<th>Means This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filename</td>
<td>File name specified in the Results File Name box.</td>
</tr>
<tr>
<td>Ext</td>
<td>File format extension (.pfn)</td>
</tr>
</tbody>
</table>
Date Conventions in Time-Series Automations

All dates in time-series automations use the end-of-month date convention. Thus, universe.00c, CustomData0012.xls, and output.00c all refer to data as of the end of December, 2000. Specific examples are outlined below:

YYM Portfolio Files

Portfolio files in YYM format use the same date conventions as the Aegis Performance Analyst. The holding date is specified by the file extension. YY stand for the last two digits of the year. YY greater than 50 is interpreted as 19YY, while YY smaller than 50 is interpreted as 20YY. M stands for a month for months 1-9. For the months 10, 11 and 12, the letters a, b and c are used. The file with the extension YYM stands for the holding at the end of the month. For example, SP500.981 contains holdings of the S&P 500 index at the end of January 31, 1998, while SP500.00C contains the holdings for December 31 of 2000.

User Data files

Dated user data files use the same date conventions as the Aegis Alphabuilder. YY stands for Years (see YYM portfolio files), MM for a double-digit month (01 stand for January) and M for a one digit/letter month (see YYM portfolio files). The file with the date YYMM stands for the user data containing a return forecast from the end of the month MM in year YY for the next month. So the user data file alpha9801.csv file contains the return forecasts from the January 31st, 1998, which are typically used in optimizations to determine the holdings for the next month.
Time-Series Automations

The date conventions used in a time-series automation leave room for misinterpretation. The following example illustrates how the convention is used in Automation Assistant:

1. Assume we run a monthly time-series optimization from January 1998 (19971230) to December 1998 (19981130). The optimizer uses the January 1998 risk data, with prices as of December 30, 1997. It processes the custom data file Alpha97c.xls and loads the initial portfolio into the optimizer to generate the holdings for January.

2. Since the YYM format stores end-of-month holdings, it is saved as holdings for the beginning of January 1998, which is equivalent to the end of December 1997. Therefore the holdings are saved in the portfolio file name.97c.

3. After that, the resulting portfolio is adjusted for corporate actions so that it can be used as the initial portfolio for the February 1998 optimization. The adjusted file contains holdings as of the end of January 1998 and is saved in the file name_adj.981. The optimized portfolio for February is saved into name.981.
Chapter 6

Aegis DataConnect

- Introducing Aegis DataConnect
- Create a New Job
- Schedule your Job
- Check the Status of your Job
Introducing Aegis DataConnect

Aegis DataConnect™ helps you to integrate your data flow into Aegis. It automates the transformation and import of your portfolio/index data, industries, and user data into Aegis.

For portfolio and index data, you can use Aegis DataConnect to:

- Create and run automated jobs that transform common third-party data and internal file formats (tab, space, or comma separated files) into Aegis-ready formats (.por, .yyym, or .yyyyymdd).
- Optionally process the portfolio as a composite.
- Place the Aegis-ready files into your BarraLink dated directories or in a fixed directory of your choice. You can then open these files directly in Aegis (no need to import them).

For industries, you can use Aegis DataConnect to:

- Automate importing of user industries for any model in the Aegis Portfolio Manager. This capability includes a flexible way to transform your input file format into an Aegis-ready format during the import process.
- Calculate weights and marginal contribution to risk associated with each user industry. In Aegis, you can then view user industry weights and marginal contributions to risk.

For user data, you can use Aegis DataConnect to:

- Automatically transform your vendor’s fundamental data into Aegis-ready format.

Aegis DataConnect supports all existing Barra models and ID types, including user-defined ID types.

Your models and user IDs will be automatically detected from your Aegis set-up.
You can schedule your jobs to at a convenient time, such as after hours, via Microsoft® scheduler (which is integrated with DataConnect), Aegis Automation Assistant, or any other command line driven scheduler.

Before you Begin

Before you can use Aegis DataConnect, be sure you have:

- installed the Aegis system
- (for Aegis versions earlier than 3.4.2 only) installed Aegis DataConnect
- downloaded your data from your data vendors.

Step 1: Create a New Job

Select Job > New or press \.

In the New Job dialog, select button to create a portfolio, industry classification, or user data job and name the new job.

Creating an Job that Imports Portfolio/Index Data into Aegis

Aegis DataConnect can automatically transform your vendor’s portfolio or index files into Aegis-ready format.

Simply select Portfolio from the New Job dialog, name the new portfolio job, and then enter the parameters in the Maintain Portfolio Job dialog, as shown below.
If you have many portfolios of the same type to import into Aegis, you can use wildcards in the filename. This creates a batch job that imports all of the portfolios at once, rather than just one at a time.

Any models that are mapped in the Select Model and Dates dialog in Aegis Portfolio Manager and Aegis Performance Analyst are available to select here.

Checking this box removes the last digit in the SEDOL field. You should only select this if your input file contains 7-digit SEDOLs and SEDOL7 is not available as an ID Type.

You can tell DataConnect where to read the effective date, such as in the file or in the filename. Selecting "Latest" will make the latest available model date the effective date.

If the effective date is provided inside the file, you must specify the exact location here.

You must also specify where the first asset ID is listed in the file and the column that contains holdings or weights.

You can have your input files moved to an archive location once the output file has been created.

You can select where to save the output file, in the Barra dated directory or in a fixed location.

You can have the output file name match the input file name. Be sure to check this box if you use wildcards in the input file name, as shown above.

You can use the portfolio as a benchmark in Aegis Portfolio Manager if you have DataConnect process it as a composite. Select a price and, if you selected a multi-country model as above, a currency for the composite asset.
Creating a Job that Imports Industry Classifications into Aegis

Aegis DataConnect can automatically transform your user or vendor-supplied industries into Aegis-ready format.

Simply select Industry Classification from the New Job dialog, name the new industry job, and then enter the parameters in the Maintain Portfolio Job dialog.
You must tell DataConnect where it should read the effective date for holdings or weights for this file. In this case, the effective date is the first cell in the source file.

We specified that we will use Tickers as the asset ID type in this file, and that the source file contains tickers beginning in row 3 of the first column.

We specified that the industries for each asset are listed in column 3 of our source file.

If you would like to create marginal contributions to user industry factors for your Aegis reports, check this box.

If your source file contains industry codes (or alternate names), you can get the desired names for the industries from another file. Simply tell DataConnect where to find the file and the names within the file.

You can determine what percentage of Barra industries must be covered for the risk forecast to be calculated. To improve the accuracy of the risk forecast, we recommend that your source file contains a broad range of assets that matches as closely as possible Barra’s estimation universe for the model you have chosen.
Note: The methodology used to calculate marginal contributions to risk for user industries (what is computed when you check the Create User Industry Risk Forecast box) is described in Marginal Contribution to User Industries (PDF 103kb).

Once your job runs successfully, your Aegis-ready industry classification file can be found in model\UserIndustry\xxIndustryClassificationName_userYYYYMMDD.txt, where xx refers to the primary Barra model code, IndustryClassificationName comes from the name you assign the industry classification, and the YYYYMMDD comes from the model date.

Creating a Job that Imports User Data into Aegis

Aegis DataConnect can automatically transform your vendor’s fundamental data into Aegis-ready format.

Simply select User Data from the New Job dialog, name the new user data job, and then enter the parameters in the Maintain User Data Job dialog.
If you are importing more than one user data file at a time with the same effective date, keep in mind that if you have columns with the same name in different files, the last one imported will overwrite the earlier one. (For example, you might have a column labeled Alpha in two different files with the same effective date.) To avoid this, make sure the files have different effective dates or unique names for the columns.

Indicate in which row the name(s) of your user data columns (column headings) can be found.

Indicate in which column(s) the user data values can be found.
Step 2: Schedule your Job

After you have completed filling in the parameters for your portfolio or industry job, you can save your job, run your job, or schedule it to be run at regular intervals using the buttons at the bottom of the 

Maintain Portfolio/Industry Classification Job 

dialogs. If you have closed this dialog, you can reopen it by double-clicking on the job name in the DataConnect application.

Command line for this job is:

```
C:\Program Files\Barra\Aegis\DataConnect\dcUtil.exe "C:\Aegis\DataConnect\config\my
```

Press Schedule to schedule the job to run on a regular basis.

DataConnect interfaces seamlessly with Windows Scheduler, but we make it easy to use any scheduling program. If you want to use a scheduling program other than the Windows Scheduler, you can copy this text and paste it into your scheduling program.
Step 3: Check the Status of Your Job

To check the status of your jobs, go to the Monitor Job Runs dialog (select Jobs > Monitor or press ).
You can select to view all jobs or individual jobs in the View dropdown.

Jobs are listed here. In addition to the columns listed here, displayed details include status and last modified time for each file.

Click on a job name above to see its job log here. This will show any error messages, such as dropped assets.

You can see a list of rejected assets or open and save the log file (in a text editor) by clicking on these buttons.

You can sort by any column by clicking on the column title. Here we clicked on the Input File column to see the jobs listed in alphabetical order.
Appendix

- Asset Identifier Types and Model Codes
- Weight Codes
- Numeraire Codes
# Asset Identifier Types and Model Codes

The following table lists the asset identifier types and their symbols for each Barra risk model. The two-digit code for each model is shown in parentheses beside the model's name.

<table>
<thead>
<tr>
<th>ID Type</th>
<th>Symbol</th>
<th>ID Type</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Australia (A3)</strong></td>
<td></td>
<td><strong>Germany (G3)</strong></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>U</td>
<td>BARRID</td>
<td>X</td>
</tr>
<tr>
<td>ASX</td>
<td>A</td>
<td>REUTICK</td>
<td>I</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td><strong>Brazil (B2)</strong></td>
<td></td>
<td><strong>Germany Trading Model (GT)</strong></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>H</td>
<td>BARRID</td>
<td>X</td>
</tr>
<tr>
<td>Ticker</td>
<td>T</td>
<td>REUTICK</td>
<td>I</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td><strong>Canada (C4)</strong></td>
<td></td>
<td><strong>Global Model (MS &amp; FT)</strong></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>K</td>
<td>BARRID</td>
<td>G</td>
</tr>
<tr>
<td>ExchTick</td>
<td>E</td>
<td>Ticker</td>
<td>L</td>
</tr>
<tr>
<td>CUSIP</td>
<td>C</td>
<td>SEDOL-CUSIP</td>
<td>SC</td>
</tr>
<tr>
<td><strong>China (C2)</strong></td>
<td></td>
<td><strong>Greece (GC)</strong></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>G</td>
<td>BARRAID</td>
<td>W</td>
</tr>
<tr>
<td>LOCALID</td>
<td>A</td>
<td>ASE_ID</td>
<td>V</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td><strong>European Equity Model (E2)</strong></td>
<td></td>
<td><strong>Hong Kong (HK)</strong></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>G</td>
<td>BARRID</td>
<td>Z</td>
</tr>
<tr>
<td>Ticker</td>
<td>L</td>
<td>HKSE_ID</td>
<td>Y</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td><strong>France (F3)</strong></td>
<td></td>
<td><strong>Indonesia (ID)</strong></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>F</td>
<td>BARRID</td>
<td>W</td>
</tr>
<tr>
<td>Sicovam</td>
<td>Q</td>
<td>JSX_ID</td>
<td>V</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td>ID Type</td>
<td>Symbol</td>
<td>ID Type</td>
<td>Symbol</td>
</tr>
<tr>
<td>---------</td>
<td>--------</td>
<td>---------</td>
<td>--------</td>
</tr>
<tr>
<td>Japan (J3)</td>
<td>Singapore (SG)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>P</td>
<td>BARRID</td>
<td>P</td>
</tr>
<tr>
<td>Code</td>
<td>J</td>
<td>SES</td>
<td>Q</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td>Japan Short Term (JS)</td>
<td>South Africa (S3)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>P</td>
<td>BARRID</td>
<td>J</td>
</tr>
<tr>
<td>Code</td>
<td>J</td>
<td>ALP-CODE</td>
<td>~</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td>Korea (K2)</td>
<td>Sweden (SN)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>H</td>
<td>BARRID</td>
<td>Z</td>
</tr>
<tr>
<td>PCODE</td>
<td>M</td>
<td>CIDEID</td>
<td>Y</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td>Malaysia (ML)</td>
<td>Switzerland (SW)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>W</td>
<td>BARRID</td>
<td>W</td>
</tr>
<tr>
<td>K_CODE</td>
<td>V</td>
<td>VALOREN</td>
<td>V</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td>Mexico (MX)</td>
<td>Taiwan (TW)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>G</td>
<td>BARRID</td>
<td>#</td>
</tr>
<tr>
<td>Ticker</td>
<td>E</td>
<td>TSE_ID</td>
<td>*</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td>Netherlands (NL)</td>
<td>Thailand (TH)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>N</td>
<td>BARRID</td>
<td>&amp;</td>
</tr>
<tr>
<td>FCODE</td>
<td>%</td>
<td>SEDOL</td>
<td>S</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>TICKID</td>
<td>@</td>
</tr>
<tr>
<td>New Zealand (NZ)</td>
<td>United Kingdom (U6)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>B</td>
<td>BARRID</td>
<td>D</td>
</tr>
<tr>
<td>NZSE</td>
<td>N</td>
<td>Own-sym</td>
<td>O</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>SEDOL</td>
<td>S</td>
</tr>
</tbody>
</table>
The weighting schemes available in Aegis indicate how Aegis should interpret the holdings in a portfolio. Typically, portfolios are share weighted. However, you can choose from:

### Weight Codes

<table>
<thead>
<tr>
<th>ID Type</th>
<th>Symbol</th>
<th>ID Type</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>United Kingdom Trading (UM)</td>
<td></td>
<td>United States Multitple Horizon Long Term (UB)</td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>D</td>
<td>BARRID</td>
<td>G</td>
</tr>
<tr>
<td>Own-sym</td>
<td>O</td>
<td>ExchTick</td>
<td>T</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>CUSIP</td>
<td>C</td>
</tr>
<tr>
<td>United Kingdom (U7)</td>
<td></td>
<td>United States Multitple Horizon Short Term (UA)</td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>D</td>
<td>BARRID</td>
<td>G</td>
</tr>
<tr>
<td>Own-sym</td>
<td>O</td>
<td>ExchTick</td>
<td>T</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>CUSIP</td>
<td>C</td>
</tr>
<tr>
<td>United Kingdom Trading 7(UM)</td>
<td></td>
<td>United States Trading (SR)</td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>D</td>
<td>BARRID</td>
<td>G</td>
</tr>
<tr>
<td>Own-sym</td>
<td>O</td>
<td>ExchTick</td>
<td>T</td>
</tr>
<tr>
<td>SEDOL</td>
<td>S</td>
<td>CUSIP</td>
<td>C</td>
</tr>
<tr>
<td>United States (U3)</td>
<td></td>
<td>United States SmallCap (SM)</td>
<td></td>
</tr>
<tr>
<td>BARRID</td>
<td>G</td>
<td>BARRID</td>
<td>G</td>
</tr>
<tr>
<td>Ticker</td>
<td>T</td>
<td>ExchTick</td>
<td>T</td>
</tr>
<tr>
<td>CUSIP</td>
<td>C</td>
<td>CUSIP</td>
<td>C</td>
</tr>
</tbody>
</table>
## Numeraire Codes

The following table lists numeraire codes for multi-country models. This is useful when creating a user-data file in Performance Analyst for a multi-country model.

<table>
<thead>
<tr>
<th>Weight code</th>
<th>Description</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SHRE</td>
<td>The Share weighting scheme uses share and price information to calculate asset weights.</td>
<td>Price and share information are not used.</td>
</tr>
<tr>
<td>EQUW</td>
<td>The Equal weighting scheme assigns equal weights to all assets.</td>
<td>The Equal Share weighting scheme assigns an equal number of shares to each asset. Original share information in the portfolio file is not used. Assets then become weighted by their prices.</td>
</tr>
<tr>
<td>EQSH</td>
<td>The Equal Share weighting scheme assigns an equal number of shares to each asset. Original share information in the portfolio file is not used. Assets then become weighted by their prices.</td>
<td>The Capitalization weighting scheme assigns weights based on the capitalization of the assets.</td>
</tr>
<tr>
<td>CAPW</td>
<td>The Capitalization weighting scheme assigns weights based on the capitalization of the assets.</td>
<td>This weight scheme is used for holdings that are explicit weights (in decimal percent) or for holdings that are values (in units of currency). The holdings column is summed up and each asset’s holding is divided by the total to determine its weight. Shares (to display in the workspace) are then determined using price and portfolio value.</td>
</tr>
</tbody>
</table>

### Numeraire Codes

The following table lists numeraire codes for multi-country models. This is useful when creating a user-data file in Performance Analyst for a multi-country model.

<table>
<thead>
<tr>
<th>Country</th>
<th>Numeraire Code</th>
<th>Country</th>
<th>Numeraire Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argentina</td>
<td>ARGENTIN</td>
<td>Korea</td>
<td>KOREA</td>
</tr>
<tr>
<td>Australia</td>
<td>AUSTRAL</td>
<td>Malaysia</td>
<td>MALASIA</td>
</tr>
<tr>
<td>Austria</td>
<td>AUSTRIA</td>
<td>Mexico</td>
<td>MEXICO</td>
</tr>
<tr>
<td>Belgium</td>
<td>BELGIUM</td>
<td>Morocco</td>
<td>MOROCCO</td>
</tr>
<tr>
<td>Brazil</td>
<td>BRAZIL</td>
<td>The Netherlands</td>
<td>NETHERL</td>
</tr>
<tr>
<td>Canada</td>
<td>CANADA</td>
<td>New Zealand</td>
<td>NEWZEAL</td>
</tr>
<tr>
<td>Chile</td>
<td>CHILE</td>
<td>Norway</td>
<td>NORWAY</td>
</tr>
<tr>
<td>China</td>
<td>CHINA</td>
<td>Pakistan</td>
<td>PAKISTAN</td>
</tr>
<tr>
<td>Colombia</td>
<td>COLOMBIA</td>
<td>Peru</td>
<td>PERU</td>
</tr>
<tr>
<td>Czech Republic</td>
<td>CZECH REP</td>
<td>The Philippines</td>
<td>PHILIPPI</td>
</tr>
<tr>
<td>Country</td>
<td>Numeraire Code</td>
<td>Country</td>
<td>Numeraire Code</td>
</tr>
<tr>
<td>----------------------------</td>
<td>----------------</td>
<td>------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Denmark</td>
<td>DENMARK</td>
<td>Poland</td>
<td>POLAND</td>
</tr>
<tr>
<td>Egypt</td>
<td>EGYPT</td>
<td>Portugal</td>
<td>PORTUGAL</td>
</tr>
<tr>
<td>European Monetary Union</td>
<td>EMU</td>
<td>Russia</td>
<td>RUSSIA</td>
</tr>
<tr>
<td>Finland</td>
<td>FINLAND</td>
<td>South Africa</td>
<td>SAFRICA</td>
</tr>
<tr>
<td>France</td>
<td>FRANCE</td>
<td>Singapore</td>
<td>SINGAPOR</td>
</tr>
<tr>
<td>Germany</td>
<td>GERMANY</td>
<td>Spain</td>
<td>SPAIN</td>
</tr>
<tr>
<td>Greece</td>
<td>GREECE</td>
<td>Sri Lanka</td>
<td>SRILANKA</td>
</tr>
<tr>
<td>Hong Kong</td>
<td>HONGKONG</td>
<td>Sweden</td>
<td>SWEDEN</td>
</tr>
<tr>
<td>Hungary</td>
<td>HUNGARY</td>
<td>Switzerland</td>
<td>SWITZER</td>
</tr>
<tr>
<td>India</td>
<td>INDIA</td>
<td>Taiwan</td>
<td>TAIWAN</td>
</tr>
<tr>
<td>Indonesia</td>
<td>INDONES</td>
<td>Thailand</td>
<td>THAILAND</td>
</tr>
<tr>
<td>Republic of Ireland</td>
<td>IRELAND</td>
<td>Turkey</td>
<td>TURKEY</td>
</tr>
<tr>
<td>Israel</td>
<td>ISRAEL</td>
<td>United Kingdom</td>
<td>UK</td>
</tr>
<tr>
<td>Italy</td>
<td>ITALY</td>
<td>United States</td>
<td>USA</td>
</tr>
<tr>
<td>Japan</td>
<td>JAPAN</td>
<td>Venezuela</td>
<td>VENEZUEL</td>
</tr>
<tr>
<td>Jordan</td>
<td>JORDAN</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Glossary

A

Active Holding
The weight of an asset in the managed portfolio minus the weight of the asset in the benchmark portfolio.

Active Management
An investment strategy centered on developing return forecasts of superior accuracy to the consensus forecast as that consensus is expressed in current market prices.

Active Return
The difference in Total Return between the managed portfolio and the benchmark portfolio. For single country equity models, Active Return can be broken down into Expected Active Return and Exceptional Active Return. For global equity models, Active Return decomposes into Asset Allocation Return and Within Market Return.

Active Risk
The volatility of active return. This can be observed by looking at past returns and also forecast using a risk model based on active exposure to common factors, a factor covariance matrix, active holdings, and specific risk forecasts. Active risk is also referred to as “tracking error” for passive, indexing applications.

In Aegis Portfolio Manager, the active risk displayed is a predicted risk number, based on the Barra multiple-factor risk models.

In Aegis Performance Analyst, the active risk is either a predicted risk number or a Bayesian adjusted risk number, depending on the report shown. Refer to the report help for more details. Also see Bayesian adjustment.

Alpha
The “risk-adjusted expected return,” or the return in excess of what would be expected from a diversified portfolio with the same systematic risk. When applied to stocks, alpha is essentially synonymous with misvaluation: a stock with a positive alpha is viewed as undervalued relative to other stocks with the same systematic risk, and a stock with a negative alpha is viewed as overvalued relative to other stocks with the same systematic risk. When applied to portfolios, alpha is a description of extraordinary reward obtainable through the portfolio strategy. Here it is synonymous with good active management: a better active manager will have a greater positive alpha at a given level of risk.

For expository purposes, alpha is usually expressed as percentage annual return. For mathematical purposes, alpha is expressed as an adjustment to proportional return (or
logarithmic return), expressed as an annual rate.

**Asset Allocation Return**  
The contribution to Active Return that is due to the manager’s decision to hold more or less weight in the equities and currencies of each country relative to the benchmark.

**Asset Selection Return**  
For single country equity models, Asset Selection Return is the contribution to Exceptional Active Return that is specific to the assets themselves. For global equity models, Asset Selection Return is the contribution to Within Market Return that is specific to the assets themselves. In either model type, the contribution comes from 1) all assets held by the managed portfolio and 2) all benchmark assets not held.

**Asset Selection Return from Assets Held in Portfolio**  
The contribution to Asset Selection Return from all assets ever held by the managed portfolio regardless of whether they were members of the benchmark. This contribution can be broken down into Asset Selection Return from Over-Weighted Assets and Asset Selection Return from Under-Weighted Assets.

**Asset Selection Return from Benchmark Assets Not Held**  
The contribution to Asset Selection Return due to benchmark assets the manager decided not to hold. The returns to benchmark assets that the manager did not hold represent an opportunity cost (or benefit) to the portfolio’s performance.

**Asset Selection Return from Over-weighted Assets**  
The contribution to Asset Selection Return that is due to the manager’s decision to hold 1) benchmark assets but at a higher relative weight and 2) non-benchmark assets. Technically, this contribution comes from managed portfolio assets whose active weight is greater than zero.

**Asset Selection Return from Under-weighted Assets**  
The contribution to Asset Selection Return that is due to the manager’s decision to hold benchmark assets but at a lower relative weight. This contribution comes from only benchmark assets that are held by the managed portfolio and whose active weight is less than zero.

**Asset Selection Risk**  
(formerly specific risk) Risk that is specific to a company and is uncorrelated (or negligibly correlated) with the asset selection risks of other companies. Also called specific, unique, idiosyncratic, or independent risk.

Active Asset Selection Risk (also known as active specific risk) is the part of active risk due to the specific (idiosyncratic) risk of securities.

**Bayesian Adjustment**  
Named after the Rev. Thomas Bayes, this refers to a statistical procedure in which judgmental data are combined with empirical data. The optimal Bayes estimator is that combination of the individual’s prior judgment and the evidence from observations of the process (measurement) which has the smallest mean square error (or error variability) in prediction.

**Benchmark**  
A standard of comparison for investment performance and risk control, widely used to evaluate and track performance of investment
managers. A benchmark can be a generally accepted market-weighted index or a customized index.

**Benchmark Excess Return**
The Total Return to the benchmark less the Risk-Free Return. In the case of global equity models, the risk-free return used depends on the currency perspective, or numeraire, chosen for the analysis.

**Benchmark Portfolio**
The list of assets that represents the investment manager's performance target. The benchmark will typically contain assets that fall within a manager's investment style. For example, a large cap growth manager of United States equities may choose the S&P 500 Growth Index as a benchmark portfolio since it represents the type of assets that he or she would hold in the managed portfolio.

**Benchmark Return**
The Total Return to the benchmark portfolio.

**Beta**
The systematic risk coefficient which expresses the expected response of an asset or portfolio's excess return to the excess return on a market portfolio. Beta is the regression coefficient of a security return upon the market return. For example, a beta of 1.5 implies that if the excess return on the market is positive, 1.5 times this positive return can be expected. If the excess return on the market portfolio is negative, 1.5 times this negative return can be expected.

**Capitalization**
The product of the market price and the number of shares outstanding of an asset. It represents the total market value of the security.

**Capitalization-Weighted**
A portfolio in which the value invested in each asset is an approximately equal fraction of the asset's capitalization.

**Cash-Equity Policy Return**
The contribution to Asset Allocation Return that is due to the trade-off between the manager's decision to hold cash versus equity securities in a global market. For instance, if the managed portfolio had a positive active equity weight (i.e., the managed portfolio equity weight is greater that the benchmark equity weight) and the excess return to the benchmark equities was positive, then this policy contribution will be positive.

**Coefficient of Determination (R²)**
A statistical term describing the fraction of variance in the dependent variable that can be explained by the independent or explanatory variable(s). The coefficient of determination is a pure number ranging from 0 to 1, with 1 giving perfect explanation. It is often used to describe the fraction of investment risk in portfolios that can be associated with market risk. R²’s for singly managed portfolios typically range from 0.8 up to 1, with a median at about 0.95. For multiply managed pension sponsor portfolios, R²’s presently range from about 0.96 to 1, with a median at about 0.98.

**Common Factor**
A characteristic shared by a group of assets which drives their returns. Examples of common factors are risk indices, industries, and countries.

**Common Factor Risk**
The part of total risk due to exposure to common factors, or characteristics shared by a group of securities.
Composite Asset

Active Common Factor Risk is the part of active risk associated with exposure to common factors (risk indices and industries). Residual Common Factor Risk is the part of common factor risk associated with exposure to common factors.

Composite Asset
A composite asset consists of two or more assets, yet behaves like a single asset. Typically, in Aegis, a composite asset is a portfolio that you process as a single asset and add to your portfolio like a single asset.

You can use composite assets to represent market index portfolios, so you can buy or sell shares of funds that reflect the collective performance of a group of assets; simulate index futures, so fund managers or securities firms can hedge against future market fluctuations. You can also use them to examine multiple managers or funds, or as a benchmark (see Benchmark).

Constraints
In portfolio optimization, a limitation imposed upon the portfolio so that it will have desired characteristics.

Country Selection Return
The contribution to Asset Allocation Return that is due to the managed portfolio's active equity weight and the performance of each country's equities in the benchmark relative to the benchmark as a whole. For instance, if 1) the active equity weight in country K is positive and 2) the benchmark equities in country K outperformed the benchmark equities as a whole then the contribution from this policy will be positive.

Country Selection Return from Average Active Equity Weight
The contribution to Country Selection Return due to the managed portfolio's average active equity weight in each country. For a given month, if 1) the average active equity weight in country K is positive and 2) the benchmark equities in country K outperformed the benchmark equities as a whole then the contribution from this policy will be positive.

Country Selection Return from Variation in Active Equity Weight
The contribution to Country Selection Return due to the variation in the managed portfolio's active equity weight from the average. For a given month, if 1) the active equity weight of country K is greater than the average active equity weight for the period and 2) the benchmark equities in country K outperformed the benchmark equities as a whole then the contribution from this policy will be positive.

Covariance
The tendency of different random investment returns to have similar outcomes, or to "co-vary." When two uncertain outcomes are positively related, covariance is positive, and conversely. The magnitude of covariance measures the strength of the common movement. For the special case of a return's covariance with itself, the simplified name of variance is used. Covariance can be scaled to obtain the pure number, correlation, that measures the closeness of the relationship without its magnitude.

To sum to total variance, multiply covariance by 2. For two random variables, \( \text{var}(x + y) = \text{var}(x) + \text{var}(y) + 2\text{Cov}(x,y) \).

Currency Selection Return
The contribution to Asset Allocation Return that is due to the managed portfolio's active country weight and the performance of the country's currency relative to the country currencies of the benchmark as a whole. The
active country weight is the sum of the active equity weight in the country and the active currency weight in the country. Currency Selection Return decomposes into Explicit Currency Selection Return (currency only) and Implicit Currency Selection Return (equity only).

**Currency Selection Return from Average Active Weight**
The contribution to Currency Selection Return due to the managed portfolio's average active country. The active country weight is the sum of the active equity weight in the country and the active currency weight in the country. For a given month, if 1) the average active country weight for country K is positive and 2) the excess currency return of country K is greater than the excess return to the benchmark's country currencies as a whole then the contribution from this policy will be positive.

**Currency Selection Return from Variation in Active Weight**
The contribution to Currency Selection Return due to the variation in the managed portfolio's active country weight from the average. The active country weight is the sum of the active equity weight in the country and the active currency weight in the country. For a given month, if 1) the active country weight is greater than the average for country K and 2) the excess currency return of country K is greater than the excess return to the benchmark's country currencies as a whole, then the contribution from this policy will be positive.

**Distribution**
The function which describes the frequency with which a random variable takes on any given value.

**Distribution, Normal**
The familiar bell-shaped curve which is called the “normal” distribution because it is the distribution that occurs when large numbers of independent factors are added together. It is a symmetrical distribution, with approximately two-thirds of all outcomes falling within ± 1 standard deviation and approximately 95 percent of all outcomes falling within ± 2 standard deviations.

**Diversification**
The reduction in risk that is obtained by investing (positive) wealth in assets which are not perfectly positively correlated. Diversification is the spreading of risk among a number of different investment opportunities. Since the assets are not perfectly correlated, losses of any one asset tend to be offset by gains on other assets. In this manner, the risk of a portfolio may well be less than the average risk of its constituent assets. The measure of diversification is either the R (the positive square root of the coefficient of determination) or residual standard deviation (see Hedging).

**Efficient Frontier**
A general term for the set of optimal portfolios at differing levels of reward and variance. Each portfolio on the frontier offers the highest possible expected reward at its level of variance, and the lowest possible variance at its level of expected reward. The term is also used for total investment results, the source of which can be decomposed into the efficient
Elasticity to Root

frontier from passive management and the active efficient frontier. The total efficient frontier is the “envelope” of combinations of passive and active frontiers.

Elasticity to Root
This variable describes how correlated an asset is to its underlying (root) asset.

Environment File
Each portfolio that you save in Aegis Portfolio Manager has an accompanying environment file (with an .env extension) that contains the risk environment data for that portfolio. This includes any information defined in the tabbed Settings pages which is specific to that portfolio and different from the strategy settings. The portfolio environment could contain elements you want to use with that particular portfolio only, such as a benchmark or universe.

Equal-Weighted
A portfolio in which approximately equal value is invested in all assets.

Exceptional Active Return
The contribution to Active Return that is due to the manager’s implicit or explicit investment policies; it is the value added by the manager beyond that already provided by the stock market on average. Investment policies include market timing, active risk index (style) exposures, active industry (sector) weights, and asset selection.

Expected Active Return
In Aegis Performance Analyst, Expected Active Return is the contribution to Active Return that one would expect given the manager’s active beta (adjusted for cash) and the long-term expected Market Risk Premium.

In Aegis Portfolio Manager, Expected Active Return is the expected return of the portfolio above that of the benchmark based on the user’s expectation of return. This is based on either supplied asset-level expected returns, or factor returns.

Expected Market Return
The market portfolio has, on average over long periods of time, earned investors a return in excess of the risk-free rate. This excess return, according to the CAPM, represents a premium that investors can expect to earn (again, on average) due to the undiversifiable nature of market risk. The CAPM further concludes that every asset should have an expected excess return that is equal to its Beta times the Market Risk Premium.

The Market Risk Premium is often used as the expected market return in calculations that utilize this term, such as when expected returns are adjusted for market biases.

Expected Return
The average investment return. Expected return is the mean of the probability distribution of investment return.

Explicit Currency Selection Return
The contribution to Currency Selection Return that is due to the managed portfolio’s active currency weight (explicit currency holdings) and the performance of the country’s currency relative to the country currencies of the benchmark as a whole.

Explicit Currency Selection Return from Average Active Weight
The contribution to Currency Selection Return due to the managed portfolio’s average active currency weight. For a given month, if 1) the average active currency weight for country K is positive and 2) the excess currency return of country K is greater than the excess return to the benchmark’s country
Implicit Currency Selection Return from Average Active Weight

currencies as a whole then the contribution from this policy will be positive.

**Explicit Currency Selection Return from Variation in Active Weight**
The contribution to Currency Selection Return due to the variation in the managed portfolio’s active currency weight from the average. For a given month, if 1) the active currency weight is greater than the average for country K and 2) the excess currency return of country K is greater than the excess return to the benchmark’s country currencies as a whole, then the contribution from this policy will be positive.

**F**

**Factor Exposure**
A term used to quantify the magnitude of an asset’s (or portfolio’s) sensitivity to factors. For risk indices, exposure is expressed in standard deviation and for industries it is expressed in percent of portfolio value.

“Active Factor Exposure” is the portfolio exposure to a factor minus the benchmark exposure.

“Active Residual Factor Exposure” is the portfolio exposure to a factor minus the benchmark exposure, with an adjustment (usually small) for beta.

**Factor Portfolio**
The hypothetical long-short portfolio that has an exposure of 1 to one factor, an exposure of 0 to all other factors in the model, and minimum risk.

**Factor Return**
The estimated return to the factor portfolio calculated by multivariate regression.

**H**

**Hedging**
The process whereby the risks of several opportunities are largely or completely (“perfect hedge”) offset. Hedging requires either that the two opportunities be negatively correlated (gold stocks and brokerage firm stocks or a put option and its underlying security), in which case positive amounts are invested in both opportunities, or that the two opportunities are positively correlated (a call option and its underlying security or two very similar securities), in which case one opportunity is short-sold. Hedging is the offsetting of risk; diversification is the spreading of risk (see **Diversification**).

**I**

**Identifier**
A short series of letters and/or numbers that uniquely identifies a particular asset. All Barra models have multiple identifier types available for use, and each asset will have a unique identifier of each type. For a list of identifier types for each model, see the **Model Reference Guide**.

**Implicit Currency Selection Return**
The contribution to Currency Selection Return that is due to the managed portfolio’s active equity weight for the country (implicit currency holdings) and the performance of the country’s currency relative to the benchmark’s country currencies as a whole.

**Implicit Currency Selection Return from Average Active Weight**
The contribution to Implicit Currency Selection Return due to the managed portfolio’s average active equity weight for each country. For a given month, if 1) the average active equity weight for country K is positive
Implicit Currency Selection Return from Variation in Active Weight

and 2) the excess currency return of country K is greater than the excess return to the benchmark's country currencies as a whole, then the contribution from this policy will be positive.

Implicit Currency Selection Return from Variation in Active Weight
The contribution to Implicit Currency Selection Return due to the variation in the managed portfolio's active equity weight from the average for each country. For a given month, if 1) the active equity weight is greater than the average for country K and 2) the excess currency return of country K is greater than the excess return to the benchmark's country currencies as a whole, then the contribution from this policy will be positive.

Implied Alpha
Implied alpha is the expected return implied by the current portfolio holdings that would result in optimality. In other words, were the current portfolio optimal, the implied alphas are the returns you would have supplied. Alternatively, if you supplied the implied alphas as expected returns to the optimizer with the current portfolio as initial portfolio, the optimizer could make no improvement. The implied alphas are useful as a check against your intuition. The order of the assets in the implied alpha list should agree with your expectations, otherwise you can re-weight your portfolio and get higher expected return at the same or a lower level of risk.

Implied Return
The return implied by the portfolio holdings that is required to make the portfolio optimal.

Industry Return
The industry return is used in the decomposition of return in Aegis Performance Analyst. For single country equity models, the Industry Return is the contribution to Exceptional Active Return. For global equity models, the Industry Return is the contribution to Within Market Return. In either case, Industry Return is due to the managed portfolio's active industry weights relative to the benchmark.

In Aegis Portfolio Manager, the expected industry return is the user's expectation of return for that particular industry.

Industry Return from Average Active Weight
The contribution to Industry Return due to each average active industry weight for the entire analysis period. For each industry and each month, if the average active weight and residual factor return are both positive, the manager's contribution will be positive.

Industry Return from Variation in Active Weight
The contribution to Industry Return due to the variation in active weight about the average. For instance, for each month that the active weight is greater than the average for the period and the residual factor return is positive, the manager's contribution will be positive. Conversely, for each month that the active weight is less than the average for the period and the residual factor return is positive, the manager will experience a negative contribution.

Information Coefficient (IC)
A measure of the precision in an analyst's forecast. It is the correlation between the active or residual return forecasts (alpha) made by the analyst and the corresponding realized active or residual return. A very good analyst would have an information coefficient (IC) of 0.1, a good analyst an IC of 0.05. The average IC is zero.
Information Ratio (IR)
The ratio of annualized active return (measured in units of %) to annualized active risk (measured in units of % standard deviation). It can be interpreted as the amount of active return earned for each unit of active risk taken. As the name suggests, the IR measures the information content of an active investment process. Being a standardized measure, it allows for an “apples-to-apples” comparison between different time periods and between different active managers (or active strategies). A central measurement for active management, value added is proportional to the square of the information ratio. A top decile money manager has an IR $\geq 1$. A top quartile manager has an IR $\geq 0.5$. The median IR = 0.

Initial Portfolio
In the Portfolio Manager, the initial portfolio is the starting point for generating the trade list and transaction cost analysis and, for taxable portfolios, calculating tax costs. Aegis calculates transaction costs as the difference between the portfolio loaded in the workspace (current) and the initial portfolio; that is, it is the cost of moving from the initial portfolio to the current portfolio. This transaction cost calculation is used in Marginal Contribution to Utility estimates.

In an optimization, the initial portfolio is the portfolio you want to optimize.

K

Kurtosis
Characterizes the relative peakedness or flatness of a distribution compared with the normal distribution. The kurtosis of a normal distribution is 0. Positive kurtosis indicates a relatively peaked distribution. Negative kurtosis indicates a relatively flat distribution.

L

Linked Asset Selection Risk
(Formerly called linked specific risk.) Asset selection returns on different types of assets can be correlated. This is the case, for example, for multiple classes of stock, derivatives, American Depositary Receipts (ADRs), and composites which are written, at least in part, on the same asset. This asset we call a root asset. The link to the root asset, direct or indirect, leads to nonzero asset selection covariances between assets with the same root, linked asset selection risk. Aegis uses the elasticity to root of the asset to its root asset to calculate asset selection covariance. (See Elasticity to Root in the glossary.)

Local Market Timing Return
The contribution to Within Market Return that is due to the managed portfolio’s active beta relative to each local market and the performance of the local market factor. The local market is defined as all equity securities for a country that is a member of the model estimation universe. For instance, if the active beta of the equities in country K is positive and the return to the local market is positive, the contribution from this policy will be positive.

Local Market Timing Return from Average Active Beta
The contribution to Local Market Timing Return that is due to the average active beta for the entire analysis period. For instance, if the average active beta of the equities in country K is positive and the return to the local market is positive, the contribution from this policy will be positive.
Local Market Timing Return from Variation in Active Beta

The contribution to Local Market Timing Return that is due to the variation in the managed portfolio’s active beta from the average. For instance, for a given month, if the active beta for country K’s equities is greater than its average for the period and the return to the local market is positive, the manager’s contribution will be positive. Conversely, if the active beta of the equities in country K is less than its average for the period and the return to the local market is positive, the manager will experience a negative contribution.

Managed Portfolio
A list of assets and their relative weights held by the investment manager.

Managed Return
The Total Return to the managed portfolio.

Marginal Contribution (MC)
An asset’s contribution to a particular characteristic of a portfolio. It is a measure of the effect that adding one percent of your portfolio value to that asset would have on that characteristic. For example, an asset’s marginal contribution to utility is the change in your portfolio’s utility if you add one percent of the portfolio’s value to that asset.

Marginal Contribution to Active Risk (MCAR)
Measures the effect of a small increase in exposure to an asset or common factor on the active risk of a portfolio. This type of sensitivity analysis allows one to see which assets or common factors would have the largest impact on the active risk of the portfolio, on the margin.

For example, an asset’s MCAR is approximately the increase in predicted active risk that would result if you increased the asset’s weight by one percent of portfolio value and decreased cash by one percent to keep the portfolio value constant. For an industry, the MCAR is the active risk change due to a 1% increase in the industry weight. A risk index factor’s MCAR represents the change in active risk that would result from an increase in the portfolio’s exposure to the risk index by 0.01 standard deviations.

Market Portfolio
The broad-based portfolio representative of the whole market. The betas, systematic risk, residual risk, and active risk of the managed and comparison portfolios are calculated relative to the market portfolio.

Market Risk Premium
(Synonymous with Risk Premium.) The average annual return to a country’s overall stock market in excess of the risk-free return over the last several years.

Market Timing Return
(Formerly Systematic Return.) The contribution to Exceptional Active Return that is due to the manager’s decision to 1) hold cash and 2) hold assets that have a higher or lower beta on average relative to the benchmark’s assets.

Market Timing Return from Above Average Active Beta
The contribution to Market Timing Return that arises when the active beta for any month was higher than the average active beta for the period. For instance, for those months when the active beta is greater than the average and the market portfolio performed better than expected (i.e. the realized market portfolio return is greater than the long term expected...
Market Risk Premium), the manager will experience a positive contribution from this policy.

**Market Timing Return from Average Active Beta**
The contribution to Market Timing Return that is due to the average active beta for the entire analysis period. For instance, if the average active beta is positive during a period in which the market portfolio returned more than expected (i.e. the realized market portfolio return is greater than the long term expected Market Risk Premium), the manager's contribution from this policy will be positive.

**Market Timing Return from Below Average Active Beta**
The contribution to Market Timing Return that arises when the active beta for any month was lower than the average active beta for the period. For instance, for those months when the active beta is less than the average and the market portfolio performed worse than expected (i.e. the realized market return was less than the long term expected Market Risk Premium), the manager will experience a positive contribution from this policy.

**Market Timing Return from Beta Policy**
The sum of Market Timing Return from Average Active Beta and Market Timing Return from Variation In Active Beta.

**Market Timing Return from Cash Policy**
The contribution to Market Timing Return that is due to the manager's active cash weights relative to the benchmark. For instance, if 1) the managed portfolio held more weight in cash than the benchmark and 2) the benchmark returned less than what was expected given its beta and the realized excess market return, then the manager would experience a positive contribution.

**Market Timing Return from Variation in Active Beta**
The contribution to the manager's Market Timing Return that is due to the variation in active beta from the average. This contribution is the sum of the Above Average Active Beta and the Below Average Active Beta contributions.

**Market Timing Risk**
(Formerly Systematic Risk.) The part of active risk due to exposure to the market. In standard deviation terms, it is equal to the active beta times the risk of the market. In variance terms, it is the active beta squared times the variance of the market.

**Momentum**
A factor in the some Barra Risk Models. This factor reflects the historic performance of the stock relative to the market aggregate.

**N**

**Numeraire**
The currency in which your portfolio is valued and from which portfolio risk is calculated.

**O**

**Optimization**
Optimization creates an optimal portfolio by trading assets found in the initial and universe portfolios. The primary goal of this is to maximize utility while taking into account any constraints you've incorporated.

**Option**
An amount paid for the right to buy or sell a security. The holder of the option is not obligated to buy the security, but the amount paid for the option is non-refundable.
Managers often pursue covered option strategies, or use options as hedging instruments and substitute assets. They also benefit broker dealers, who can compute the risk of their combined option and common stock inventory.

Penalties
Penalties, like constraints, let you customize your optimization by tilting toward certain characteristics or restricting factor values to certain ranges. Unlike constraints, however, penalties are not binding. When you apply a penalty, you specify a target for a portfolio characteristic, as well as an upper and lower penalty threshold, which indicate how closely the characteristic value in the optimal solution should approach the target value.

R-Squared
See coefficient of determination.

Region
A group of countries which are in the same geographic vicinity. In the Aegis System, there are default region mappings according to the Morgan Stanley (MS) or Financial Times (FT) classifications. If you wish, you may define your own regions in Aegis Performance Analyst.

Residual Factor Return
The total factor return less the return we would expect given the beta of the factor portfolio relative to the market portfolio.

Residual Risk
The standard deviation of residual return. Residual return is return not attributable to market influence. The residual return of an asset is return due to events specific to that company. Residual risk can be thought of as diversifiable risk, as opposed to systematic/undiversifiable risk.

Risk
The uncertainty of investment outcomes. Technically, risk defines all uncertainty about the mean outcome, including both upside and downside possibilities. The more intuitive concept for risk measurement is the standard deviation of the distribution, a natural measure of spread. Variance, the square of the standard deviation, is used to compare independent elements of risk.

Risk-Adjusted Return
This is the return minus a penalty for risk. The risk penalty is computed by taking the risk aversion times the variance of return. The risk aversion is uniquely specified by the investor. A positive value indicates that the risk is worth taking, a negative value that it is not. The higher the risk-adjusted return, the more attractive is the investment.

Risk Aversion
The risk aversion parameter allows you to adjust your level of risk tolerance. The risk aversion value is part of the utility calculation. In Aegis, you can increase the risk aversion to create a portfolio with lower risk and, consequently, lower return. Or, you can
decrease the risk aversion to create a portfolio with higher return and, consequently, higher risk. (In effect, you're moving up or down the efficient frontier).

**Risk-Free Return**
The certain return to a purely “risk-free” investment. Conceptually, such an investment should have guaranteed purchasing power at its termination. In practice, this rate is usually defined by the rate of return on short-term government-issued bonds for the investment period. These securities have no risk in nominal terms but substantial risk in real purchasing power.

**Risk Index**
A risk index is fundamental to the prediction of portfolio risk in Aegis. The models measure asset exposures to each risk index and normalize the asset exposures within each local market so that the mean exposure within that market is 0.0, and one standard deviation in the market is 1.0.

For example, an asset with a Size exposure of 0.0 is average-sized for its local market, while an asset with a Size exposure of 1.0 is larger than five-sixths of the assets in its local market. The portfolio’s exposure to each risk index is the weighted average exposure of the assets that make up the portfolio.

Because asset risk index exposures are normalized within each local market, they don’t reflect absolute measures that can be compared across local markets.

**Risk Index Return**
For single country equity models, Risk Index Return is the contribution to Active Return. For global equity models, Risk Index Return is the contribution to Within Market Return. In either model type, the contribution is due to the managed portfolio’s active risk index exposures relative to the benchmark.

**Risk Index Return from Average Active Exposure**
The contribution to Risk Index Return due to each average active risk index exposure for the entire analysis period. For each risk index and each month, if the average active exposure and residual factor return are both positive, the manager’s contribution will be positive.

**Risk Index Return from Variation in Active Exposure**
The contribution to Risk Index Return due to the variation in active exposures about the average. For instance, for each month that an active risk index exposure is greater than its average for the period and the residual factor return is positive, the manager’s contribution will be positive. Conversely, for each month that an active risk index exposure is less than its average for the period and the residual factor return is positive, the manager will experience a negative contribution.

**Root Asset Selection Risk**
(Formerly Root Specific Risk) The asset selection risk of the root (underlying) asset. Aegis links the asset selection risk of significantly correlated assets, such as multiple voting issues of a stock (Class A to Class B). This provides a more accurate description of risk, particularly for risk forecasts, marginal contribution rankings (diversifying character of individual assets), and optimal portfolios.

**Skewness**
Skewness characterizes the degree of asymmetry of a distribution around its mean. The skewness of the normal distribution is 0. Positive skewness indicates a distribution with
an asymmetric tail extending toward more positive values.

**Sector Return**
For single country equity models, Sector Return is the contribution to Active Return. For global equity models, Sector Return is the contribution to Within Market Return. In either model type, the contribution is due to the managed portfolio’s active sector weights relative to the benchmark. As long as all industries are mapped to one sector, Total Sector Return will always equal Total Industry Return for a given analysis. The return to any sector is simply the sum of the returns for each industry that make up the sector (see definition of Sector).

**Sector Return from Average Active Weight**
The contribution to Sector Return due to each average active sector weight for the entire analysis period. For each sector and each month, if the average active sector weight and residual factor return are both positive, the manager’s contribution will be positive.

**Sector Return from Variation in Active Weight**
The contribution to Sector Return due to the variation in active sector weight about the average. For instance, for each month that the active sector weight is greater than the average for the period and the residual factor return is positive, the manager’s contribution will be positive. Conversely, for each month that the active sector weight is less than the average for the period and the residual factor return is positive, the manager will experience a negative contribution.

**Sectors**
A group of industries with similar economic characteristics.

**Specific Risk**
See Asset Selection Risk.

**Standard Deviation**
The statistical term that measures the spread of values around a mean value. Its intuitive meaning is best seen in a simple, symmetric distribution, such as the normal distribution, where approximately two-thirds of all outcomes fall within one standard deviation and 95% of all outcomes fall within two standard deviations. The standard deviation of return—or more properly, of the logarithm of return, which is nearly symmetrically distributed—is widely used as a measure of risk for portfolio investments.

Standard deviation is the square root of variance.

**Standardized Return**
The ratio of monthly return (measure in units of %) to monthly risk (measure in units of % standard deviation).

**Strategy**
In the Aegis Portfolio Manager, a strategy is the full set of parameters defined in all twelve Settings tab pages. You can save the settings with a descriptive name you specify (such as Active, Passive, etc.), so you can use that strategy for any portfolio in the model. A strategy is useful for implementing your firm’s investment guidelines that could apply to any portfolio in the model, such as trading restrictions, weighting parameters, and so on.

**Style**
A group of risk indices within a single country equity model (Styles are not available in global equity models). Styles are analogous to sectors. For instance, the default styles provided in the United States equity model are 1) Size = SIZE, SIZENONL, and NONESTU, 2)
Growth/Value = GROWTH, EARNYLD, VALUE, and YIELD, and 3) Risk = VOLTILITY, MOMENTUM, TRADEACT, EARNVAR, LEVERAGE, and CURRSEN. In Aegis Performance Analyst, you may define and save several of your own style mappings for any single country equity model.

Style Return
The contribution to Active Return that is due to the managed portfolio's style. As long as all risk indices are mapped to one style, Total Style Return will always equal Total Risk Index Return. The return to any style is simply the sum of the returns for each risk index that make up the style (see definition of Style).

Style Return from Average Active Exposure
The sum of the respective risk index contributions to Risk Index Return from Average Active Exposure.

Style Return from Variation in Active Exposure
The sum of the respective risk index contributions to Risk Index Return from Variation from Average Active Exposure.

Systematic Risk
See Market Timing Risk.

Total Return
The total (gross) return to a portfolio including capital gains and dividend income. For global equity models, the total return is calculated with respect to a currency perspective or numeraire. The monthly total return is calculated assuming a buy and hold strategy – the holdings at the beginning of the month are assumed held until the end of the month with no transactions.

Tracking Error
The standard deviation of the portfolio's active risk. It is similar to residual risk, but it has not been beta adjusted.

Transaction Costs
The costs incurred for a portfolio when securities are changed for other securities. Transaction costs are deducted from the value of the portfolio directly, rather than paid as fees to the money manager. These costs arise from three sources: (1) commissions and taxes paid directly in cash; (2) the typical “dealer's spread” (or one half of this amount) earned by a dealer, if any, who acts as an intermediary between buyer and seller; and (3) the net advantage or disadvantage earned by giving or receiving accommodation to the person on the other side of the trade. The third component averages out to zero across all trades, but it may be positive or negative, depending on the extent to which a trader, acting urgently, moves the market against the selected strategy.

T-statistic
A statistical measure of whether an estimate differs significantly from zero. Technically, it is the ratio of the estimate to its standard error. This statistic is interesting because assuming the error terms are normally distributed, we know the distribution of the estimate. For example, if the true value is zero, the probability of observing a t-stat greater than 2 in magnitude is only 5%.

Universe
The list of all assets eligible for consideration for inclusion in a portfolio. At any time, some assets in the universe may be temporarily ruled out because they are currently viewed as overvalued. However, the universe should contain all of those securities that might be
considered for inclusion in the near term if their prices move to such an extent that they become undervalued. Sometimes the term universe is also used to define the normal position of a money manager, equating his normal holding with the capitalization-weighted average of the securities in his universe or followed list.

User Data
Data that may be supplied to Aegis by the user. User data may contain any variables (numeric or text) that the user would like to display in the Aegis workspace, use as expected returns, use as asset bounds, use as a variable to constrain in optimization, or use as transaction costs or round lot sizes.

Utility
A measure of the desirability or goodness of a risky series of outcomes.

The equation below is a general formula, though utility will not always take this form:

\[
utility = (\text{alpha multiplier}) (\text{return}) - (\text{risk aversion}) (\text{variance}) - (\text{transaction costs})
\]

Utility, then, is a function of risk and return, and managers can, if they wish, include transaction costs.

V
Value at Risk (VaR)
Value at risk is a measure that characterizes the potential loss in currency units in a given time period for a given probability level. In the Portfolio Manager, the time horizon is set to one year. For example, a VaR of -$1,000,000 at the 5% probability level indicates there is a 95% probability one would not lose more than $1,000,000 in the coming year.

Variance
A statistical term for the variability of a random variable about its mean. The variance is defined as the expected squared deviation of the random variable from its mean—that is, the average squared distance between the mean value and the actually observed value of the random variable. When a portfolio includes several independent elements of risk, the variance of the total arises as a summation of the variances of the separate components.

Volatility
1. In the Market Impact Model, a factor which describes the standard deviation of log return.
2. A factor in some Barra Equity Models that measures the volatility of the asset's security price.

W
Within Market Return
The contribution to Active Return that is due to the factors common to the equity securities of the local country markets themselves. Within Market Return can be broken down into Local Market Timing Return, Risk Index Return, Industry Return (or Sector Return), and Asset Selection Return.
Index

A
accounting returns preparing 90
accounting returns and transaction costs importing 90
active return breakdown 79
ADS creating 62
after-tax portfolio database creating in Portfolio Accountant 107
analyze risk in portfolio 23
annualized 87
asset contribution reports 78
asset identifier types 198
attribution data source creating 62
attribution report styles 75
attribution reports 71
Automation Assistant basic steps to run 135
automation case creating 136
running 177
running from DOS 178
running immediately 178
saving 176
scheduling 179
automation summary reviewing before running 177
automation task
adding to case 137
changing processing order 171
changing status before running 177
deleting 171
editing 171
B
backtest date conventions in Automation Assistant 183
basic steps Portfolio Accountant 97
batch file executing your own in Automation Assistant 170
benchmark selecting in Portfolio Manager 16
bounds 44
C
calculation utility 42
Cash tab 127
changing records in Portfolio Accountant 106
codes model 198
numeraire 201
weight 200
components of risk 26
composite asset 18
constraints 44
country exposures 32
create attribution data source 62
performance reports 60
creating risk reports 10
cumulative 87
cumulative attribution graph 73
customize reports in Performance Analyst 89
workspace settings 49

D
daily cumulative 87
data import 53
database attribution data source 62
creating or opening in Portfolio Accountant 97
viewing records in Portfolio Accountant 112
date select model and pricing date 12
Date Conventions in Automation Assistant 183
Date tab 126

E
ero error handling in Automation Assistant 173
executive summary 24
export alphas to file 147
exposures country 32
market risk 34
exposures vs. MCAR 28

F
favorites 51
features of Portfolio Manager 8
file conventions in Automation Assistant 181
format portfolio files 10
frontier optimization 43

I
identifier types 198
import accounting returns and transaction costs 90
custom data 53
importing files into Portfolio Accountant 100
industry exposures 30

L
list of trades 40
log files in Automation Assistant 173
in Automation Scheduler 180

M
mapping cases managing in Portfolio Accountant 120
marginal contribution 36
market portfolio selecting in Portfolio Manager 16
MCAR 28
menus in Portfolio Accountant 128
what is a Barra risk model 12
model codes 198
monthly 87
monthly/daily 87
monthly cumulative 87
multiple portfolio comparison reports printing and saving 181
multiple portfolio performance reports in Automation Assistant 160

N
naming conventions in Automation Assistant 181
new analysis in Performance Analyst 66
Number Format tab 126
numeraire codes 201

O
open portfolio in Portfolio Manager 14
optimization types 43
optimization settings in Automation Assistant 145
optimizer 42
output naming conventions in Automation Assistant 181

P
Paths tab 123
penalties 44
performance reports creating 60
in Automation Assistant 155
trade
  list of  40
  trades
    simulating  38
transaction summary  40
types of optimizations  43
types of reports in Performance Analyst  70
types of reports in Portfolio Manager  22

U
user data
  import  53
user data file
    format of  90
User Data Settings
  in Automation Assistant  148
User Industries Settings
  in Automation Assistant  150
utility calculation  42

V
view
  new portfolio in Portfolio Manager  14
  reports in Portfolio Manager  20

W
weight codes  200
workspace
  customize settings  49
  Portfolio Manager  14